summaryrefslogtreecommitdiffstats
path: root/abs/core/supplemental-web
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-08-17 23:07:38 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-08-17 23:07:38 (GMT)
commit6b44b0fc2469ec3d8d5b35d42a84653c64aa4945 (patch)
treeb8d2a4e4872d4d5e030e8e2f2fb61c2907911c32 /abs/core/supplemental-web
parent9b93d67c55bb90ec0a1f4ea2b4a8cf04f7b1fb47 (diff)
downloadlinhes_pkgbuild-6b44b0fc2469ec3d8d5b35d42a84653c64aa4945.zip
linhes_pkgbuild-6b44b0fc2469ec3d8d5b35d42a84653c64aa4945.tar.gz
linhes_pkgbuild-6b44b0fc2469ec3d8d5b35d42a84653c64aa4945.tar.bz2
supplemental-web / xymon: Add restart MBE to web interface.
Tweaks to css for call log
Diffstat (limited to 'abs/core/supplemental-web')
-rw-r--r--abs/core/supplemental-web/PKGBUILD2
-rw-r--r--abs/core/supplemental-web/contents/frame.css117
-rwxr-xr-x[-rw-r--r--]abs/core/supplemental-web/contents/process.py9
3 files changed, 69 insertions, 59 deletions
diff --git a/abs/core/supplemental-web/PKGBUILD b/abs/core/supplemental-web/PKGBUILD
index dd73d51..42bbf6a 100644
--- a/abs/core/supplemental-web/PKGBUILD
+++ b/abs/core/supplemental-web/PKGBUILD
@@ -1,7 +1,7 @@
pkgbase=supplemental-web
pkgname=('supplemental-web' 'supplemental-web-slave')
pkgver=8.0
-pkgrel=15
+pkgrel=17
arch=('i686' 'x86_64')
license=('GPL')
backup=('data/srv/httpd/cgi/extra.cfg.txt')
diff --git a/abs/core/supplemental-web/contents/frame.css b/abs/core/supplemental-web/contents/frame.css
index 59da3c7..63a6121 100644
--- a/abs/core/supplemental-web/contents/frame.css
+++ b/abs/core/supplemental-web/contents/frame.css
@@ -1,12 +1,12 @@
* /* Our "universal rule" */
{
- padding: 0px;
- margin: 0px;
- border: 0px;
+ padding: 0px;
+ margin: 0px;
+ border: 0px;
}
body {
/* background: url("page_background.jpg") repeat-y #9FA9B3; */
- background-color: #191c26;
+ background-color: #191c26;
//background-color: #ebb81c;
//background-image: -webkit-gradient(linear, left top, left bottom, from(#ebb81c), to(#0072bc)); /* Saf4+, Chrome */
@@ -38,27 +38,27 @@ body {
#mainContainer {
clear: both;
- width: 770px;
- margin: 10px auto;
- text-align: left; /* Since we used text-align: center in the body to be sure some older IE versions are going to center our design, we now align the text left */
- display: block;
+ width: 770px;
+ margin: 10px auto;
+ text-align: left; /* Since we used text-align: center in the body to be sure some older IE versions are going to center our design, we now align the text left */
+ display: block;
}
#header {
- color: #fff;
- text-align: center;
+ color: #fff;
+ text-align: center;
}
#content {
- float: left; /* Our content is going to be left aligned */
- width: 320px; /* And it's going to have a 320px width */
- /*background: #D9D9D9;*/
- margin-left:60px;
+ float: left; /* Our content is going to be left aligned */
+ width: 320px; /* And it's going to have a 320px width */
+ /*background: #D9D9D9;*/
+ margin-left:60px;
}
#column {
- float: right; /* Our column is going to be right aligned */
- width: 320px; /* And it's going to have a 320px width */
- /*background: #8A8AE6;*/
- margin-right:60px;
+ float: right; /* Our column is going to be right aligned */
+ width: 320px; /* And it's going to have a 320px width */
+ /*background: #8A8AE6;*/
+ margin-right:60px;
}
#resultbox {
@@ -79,8 +79,8 @@ body {
#netContainer {
clear: both;
width: 770px;
- margin: 10px auto;
- display: block;
+ margin: 10px auto;
+ display: block;
}
img.center {
@@ -93,10 +93,10 @@ img.center {
}
#footer {
- clear: both; /* We have to clear our floats */
- width: 770px; /* We need to set the width on the footer since it's outside the mainContainer, and therefor isn't controlled by it */
- margin: 0px auto; /* We need to center the footer also */
- color: gold;
+ clear: both; /* We have to clear our floats */
+ width: 770px; /* We need to set the width on the footer since it's outside the mainContainer, and therefor isn't controlled by it */
+ margin: 0px auto; /* We need to center the footer also */
+ color: gold;
text-align: center;
font-size: 10px;
}
@@ -115,9 +115,9 @@ img.center {
}
#navlist a:link
{
- color: #fff;
+ color: #fff;
# background-color: #FDB14F;
- text-decoration: underline;
+ text-decoration: underline;
}
@@ -125,45 +125,48 @@ img.center {
#navlist a:visited
{
# color: #FDB14F;
- color: gold;
- text-decoration: underline;
+ color: gold;
+ text-decoration: underline;
}
table.sample {
- border-width: 4px;
- border-spacing: 2px;
- border-style: outset;
- border-color: #808080;
- border-collapse: separate;
- width:300px;
+ border-width: 4px;
+ border-spacing: 2px;
+ border-style: outset;
+ border-color: #808080;
+ border-collapse: separate;
+ width:300px;
}
table.sample td {
- border-width: 1px;
- padding: 1px;
- border-style: inset;
- border-color: #808080;
- /*width:300px;*/
- -moz-border-radius: ;
+ border-width: 1px;
+ padding: 1px;
+ border-style: inset;
+ border-color: #808080;
+ /*width:300px;*/
+ -moz-border-radius: ;
}
table.calllog {
- border-width: 4px;
- border-spacing: 2px;
- border-style: outset;
- border-color: #808080;
- border-collapse: separate;
- width:500px;
+ border-width: 4px;
+ border-spacing: 2px;
+ border-style: outset;
+ border-color: #808080;
+ border-collapse: separate;
+ width:500px;
+ margin-left:auto;
+ margin-right:auto;
+ body {text-align:center;}
}
table.calllog td {
- border-width: 1px;
- padding: 1px;
- border-style: inset;
- border-color: #808080;
- /*width:300px;*/
- -moz-border-radius: ;
+ border-width: 1px;
+ padding: 1px;
+ border-style: inset;
+ border-color: #808080;
+ /*width:300px;*/
+ -moz-border-radius: ;
}
@@ -202,9 +205,9 @@ table.calllog td {
a:link
{
- color: #fff;
+ color: #fff;
# background-color: #FDB14F;
- text-decoration: underline;
+ text-decoration: underline;
# margin-left:10px;
@@ -213,9 +216,9 @@ a:link
a:visited
{
# color: #FDB14F;
- color: gold;
- text-decoration: underline;
- margin-left:10px;
+ color: gold;
+ text-decoration: underline;
+ margin-left:10px;
}
#submitbutton {
diff --git a/abs/core/supplemental-web/contents/process.py b/abs/core/supplemental-web/contents/process.py
index 988ebfc..7ad9af6 100644..100755
--- a/abs/core/supplemental-web/contents/process.py
+++ b/abs/core/supplemental-web/contents/process.py
@@ -257,7 +257,12 @@ def go_kill(myhost,kill_type):
results=os.popen(command,'r')
return results
-
+def go_restart_mbe_local():
+ cmd = "/usr/LH/bin/lh_backend_control.sh restart &"
+ #results=os.popen(cmd,'r')
+ os.popen(cmd,'r')
+ results = ["Attempting restart of backend service"]
+ return results
@@ -342,6 +347,8 @@ if __name__ == '__main__':
mylogfile=go_kill(myhost,kill_type)
elif selection == "Upload":
mylogfile = go_upload(up_file)
+ elif selection == "RestartMBE":
+ mylogfile = go_restart_mbe_local()
cgiprint(contentheader) # content header