summaryrefslogtreecommitdiffstats
path: root/abs/core/talloc
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-23 18:06:28 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-23 18:06:28 (GMT)
commit9d60489a74969c68758de7f2515b6b709993a2d1 (patch)
treed1982e09adb8f63b65a55ec1029cb0999a4c0bc3 /abs/core/talloc
parente7aaf188763ef9e001962be04bae45eedb151a3a (diff)
downloadlinhes_pkgbuild-9d60489a74969c68758de7f2515b6b709993a2d1.zip
linhes_pkgbuild-9d60489a74969c68758de7f2515b6b709993a2d1.tar.gz
linhes_pkgbuild-9d60489a74969c68758de7f2515b6b709993a2d1.tar.bz2
talloc: update to 2.1.5
Diffstat (limited to 'abs/core/talloc')
-rw-r--r--abs/core/talloc/PKGBUILD18
-rw-r--r--abs/core/talloc/fix_test_path.patch13
2 files changed, 28 insertions, 3 deletions
diff --git a/abs/core/talloc/PKGBUILD b/abs/core/talloc/PKGBUILD
index c19a0fc..15dfc1b 100644
--- a/abs/core/talloc/PKGBUILD
+++ b/abs/core/talloc/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
pkgname=talloc
-pkgver=2.1.0
+pkgver=2.1.5
pkgrel=1
pkgdesc="Hierarchical pool based memory allocator with destructors"
arch=('i686' 'x86_64')
@@ -12,10 +12,16 @@ url="http://talloc.samba.org/"
depends=('glibc')
makedepends=('python2' 'docbook-xsl')
optdepends=('python2: for python bindings')
-source=("http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+source=(http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.{gz,asc}
+ fix_test_path.patch)
+sha1sums=('bdf3b3d8449e2c354f1ebc43d3e1058160eb4adb'
+ 'SKIP'
+ '34132be289f9ce1c38c8b367def8d91ac7dbb706')
+validpgpkeys=(9147A339719518EE9011BCB54793916113084025) # samba-bugs@samba.org
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 < ../fix_test_path.patch
sed -i -e 's#python#python2#g' buildtools/bin/waf
}
@@ -24,12 +30,18 @@ build() {
./configure --prefix=/usr \
--sysconfdir=/etc/samba \
--localstatedir=/var \
+ --bundled-libraries=NONE \
+ --builtin-libraries=replace \
--enable-talloc-compat1
make
}
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make check
+}
+
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
}
-md5sums=('85a69bfb5808fcadf378bd9eadb1f9c2')
diff --git a/abs/core/talloc/fix_test_path.patch b/abs/core/talloc/fix_test_path.patch
new file mode 100644
index 0000000..37ed604
--- /dev/null
+++ b/abs/core/talloc/fix_test_path.patch
@@ -0,0 +1,13 @@
+diff --git a/wscript b/wscript
+index 9cedbbf..4432a9a 100644
+--- a/wscript
++++ b/wscript
+@@ -158,7 +158,7 @@ def test(ctx):
+ cmd = os.path.join(Utils.g_module.blddir, 'talloc_testsuite')
+ ret = samba_utils.RUN_COMMAND(cmd)
+ print("testsuite returned %d" % ret)
+- magic_cmd = os.path.join(srcdir, 'lib', 'talloc',
++ magic_cmd = os.path.join(srcdir,
+ 'test_magic_differs.sh')
+
+ magic_ret = samba_utils.RUN_COMMAND(magic_cmd)