summaryrefslogtreecommitdiffstats
path: root/abs/core/tar/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:00:01 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:00:01 (GMT)
commit4fee3b1193dca42f7d4ef895f84705218f098970 (patch)
tree9bda50f74ffd42c10c1fb8fcdb6d1ba493fcb778 /abs/core/tar/PKGBUILD
parent48614be8079d39d29ba31c44d89d65519a4a28cb (diff)
downloadlinhes_pkgbuild-4fee3b1193dca42f7d4ef895f84705218f098970.zip
linhes_pkgbuild-4fee3b1193dca42f7d4ef895f84705218f098970.tar.gz
linhes_pkgbuild-4fee3b1193dca42f7d4ef895f84705218f098970.tar.bz2
tar 1.26
-glibc patch
Diffstat (limited to 'abs/core/tar/PKGBUILD')
-rw-r--r--abs/core/tar/PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/abs/core/tar/PKGBUILD b/abs/core/tar/PKGBUILD
index 3bde59b..e7ac2e4 100644
--- a/abs/core/tar/PKGBUILD
+++ b/abs/core/tar/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id$
+# $Id: PKGBUILD 142080 2011-11-04 23:36:17Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: Andreas Radke <andyrtr@archlinux.org>
pkgname=tar
pkgver=1.26
-pkgrel=1
+pkgrel=2
pkgdesc="Utility used to store, backup, and transport files"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/tar/tar.html"
@@ -13,15 +13,17 @@ groups=('base')
depends=('glibc' 'sh')
options=('!emptydirs')
install=tar.install
-source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
+source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
tar.1)
md5sums=('0ced6f20b9fa1bea588005b5ad4b52c1'
- 'e0538778516a284e3558c454b2576c2f')
+ '6618d5fe7785e138c27d7d6a24e998b2'
+ 'e97e7343f4e23724b4c48bca2f033e38')
build() {
cd ${srcdir}/$pkgname-$pkgver
+ sed -i '/gets is a security hole/d' gnu/stdio.in.h
- FORCE_UNSAFE_CONFIGURE=1 ./configure --prefix=/usr --libexecdir=/usr/lib/tar --bindir=/bin
+ ./configure --prefix=/usr --libexecdir=/usr/lib/tar --bindir=/bin
make
}