summaryrefslogtreecommitdiffstats
path: root/abs/core/tcl
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-11 19:47:23 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-11 19:47:23 (GMT)
commitc103226eaf0601de087b4c1405cf0ebeb3517e29 (patch)
tree7c31a2e65bfb5dde532b886e98d909eaff173ccf /abs/core/tcl
parent89f4822308f3985112a7dbc62bcd68e4081e1961 (diff)
downloadlinhes_pkgbuild-c103226eaf0601de087b4c1405cf0ebeb3517e29.zip
linhes_pkgbuild-c103226eaf0601de087b4c1405cf0ebeb3517e29.tar.gz
linhes_pkgbuild-c103226eaf0601de087b4c1405cf0ebeb3517e29.tar.bz2
tcl/tk: updated to 8.5.9
Diffstat (limited to 'abs/core/tcl')
-rw-r--r--abs/core/tcl/PKGBUILD35
1 files changed, 21 insertions, 14 deletions
diff --git a/abs/core/tcl/PKGBUILD b/abs/core/tcl/PKGBUILD
index bcf3ab2..acce9e8 100644
--- a/abs/core/tcl/PKGBUILD
+++ b/abs/core/tcl/PKGBUILD
@@ -1,17 +1,17 @@
-# $Id: PKGBUILD 22246 2008-12-24 10:50:10Z allan $
+# $Id: PKGBUILD 90377 2010-09-11 03:54:51Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
# Committer: Judd Vinet <jvinet@zeroflux.org>
pkgname=tcl
-pkgver=8.5.6
+pkgver=8.5.9
pkgrel=1
pkgdesc="The Tcl scripting language"
arch=('i686' 'x86_64')
+url="http://tcl.sourceforge.net/"
license=('custom')
depends=('glibc')
source=(http://downloads.sourceforge.net/sourceforge/tcl/tcl${pkgver}-src.tar.gz)
-url="http://tcl.sourceforge.net/"
-md5sums=('d0b0b3ff7600ff63135c710b575265cd')
+md5sums=('8512d8db3233041dd68a81476906012a')
build() {
cd ${srcdir}/tcl${pkgver}/unix
@@ -22,20 +22,27 @@ build() {
./configure --prefix=/usr --mandir=/usr/share/man --enable-threads --disable-64bit
fi
- make || return 1
+ make
+}
+
+package()
+{
+ cd ${srcdir}/tcl${pkgver}/unix
+
make INSTALL_ROOT=${pkgdir} install install-private-headers
ln -sf tclsh8.5 ${pkgdir}/usr/bin/tclsh
+
# install license
install -Dm644 ../license.terms ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- # remove buildroot traces / fixes #3602
+ # remove buildroot traces
sed -i \
- -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
- -e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='/usr/include'," \
- -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
- -e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
- -e "s,^TCL_LIB_FILE='libtcl8.5..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.5\$\{TCL_DBGX\}.so\"," \
- -e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:/usr/lib'," \
- -e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:/usr/lib'," \
- ${pkgdir}/usr/lib/tclConfig.sh
+ -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='/usr/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ -e "s,^TCL_LIB_FILE='libtcl8.5..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.5\$\{TCL_DBGX\}.so\"," \
+ -e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:/usr/lib'," \
+ -e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:/usr/lib'," \
+ ${pkgdir}/usr/lib/tclConfig.sh
}