summaryrefslogtreecommitdiffstats
path: root/abs/core/tdb
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-10-07 19:21:26 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-10-07 19:21:26 (GMT)
commit1caaf4f490f2bd7491789cb0ec15d5b748d55d0f (patch)
treed70b022eeaeb574b7c38f65ad33733591b8472ac /abs/core/tdb
parent0294b4c7a4444cbdb28ad3761eed86fc1145a216 (diff)
downloadlinhes_pkgbuild-1caaf4f490f2bd7491789cb0ec15d5b748d55d0f.zip
linhes_pkgbuild-1caaf4f490f2bd7491789cb0ec15d5b748d55d0f.tar.gz
linhes_pkgbuild-1caaf4f490f2bd7491789cb0ec15d5b748d55d0f.tar.bz2
tdb: udpate to 1.3.0
Diffstat (limited to 'abs/core/tdb')
-rw-r--r--abs/core/tdb/0001-tdb-include-include-stdbool.h-in-tdb.h.patch27
-rw-r--r--abs/core/tdb/PKGBUILD15
2 files changed, 38 insertions, 4 deletions
diff --git a/abs/core/tdb/0001-tdb-include-include-stdbool.h-in-tdb.h.patch b/abs/core/tdb/0001-tdb-include-include-stdbool.h-in-tdb.h.patch
new file mode 100644
index 0000000..33a15cb
--- /dev/null
+++ b/abs/core/tdb/0001-tdb-include-include-stdbool.h-in-tdb.h.patch
@@ -0,0 +1,27 @@
+From 4e14a437963ba54987cd58b4e0705d9a6d8aea6f Mon Sep 17 00:00:00 2001
+From: Adam Williamson <awilliam@redhat.com>
+Date: Fri, 23 May 2014 10:08:14 -0700
+Subject: [PATCH] tdb/include: include stdbool.h in tdb.h
+
+Commit db5bda56bf08 (tdb: add TDB_MUTEX_LOCKING support) adds a bool, but does
+not include stdbool.h. This causes any build including tdb.h to fail, at least
+for me with GCC 4.9.0.
+---
+ lib/tdb/include/tdb.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/tdb.h b/include/tdb.h
+index 5ea5e60..03e429c 100644
+--- a/include/tdb.h
++++ b/include/tdb.h
+@@ -31,6 +31,7 @@ extern "C" {
+ #endif
+
+ #include <signal.h>
++#include <stdbool.h>
+
+ /**
+ * @defgroup tdb The tdb API
+--
+1.9.3
+
diff --git a/abs/core/tdb/PKGBUILD b/abs/core/tdb/PKGBUILD
index d0e3a79..277b37c 100644
--- a/abs/core/tdb/PKGBUILD
+++ b/abs/core/tdb/PKGBUILD
@@ -4,15 +4,23 @@
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=tdb
-pkgver=1.2.12
-pkgrel=1
+pkgver=1.3.0
+pkgrel=2
pkgdesc="A Trivial Database similar to GDBM but allows simultaneous commits"
arch=(i686 x86_64)
license=('GPL3')
url="http://tdb.samba.org/"
-source=(http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz)
makedepends=('python2' 'libxslt' 'docbook-xsl')
optdepends=('python2: for python bindings')
+source=(http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ 0001-tdb-include-include-stdbool.h-in-tdb.h.patch)
+md5sums=('f18cd6afc4f5670edfe58f72d2665f94'
+ '2b0b6003b3d8ca03adccd4aa1a3b8313')
+
+prepare() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -Np1 -i ../0001-tdb-include-include-stdbool.h-in-tdb.h.patch
+}
build() {
cd ${srcdir}/${pkgname}-${pkgver}
@@ -33,4 +41,3 @@ package() {
export PYTHON=/usr/bin/python2
make DESTDIR=$pkgdir/ install
}
-md5sums=('53e6168a7c2c93735a1c024fd2c3a7b4')