summaryrefslogtreecommitdiffstats
path: root/abs/core/tdb
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
commitc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (patch)
treef4e4f7a91e1d9d90033fd99d89e5e26a2c144528 /abs/core/tdb
parent0e7b327a1ae444233f1308a95420f70540ad74a3 (diff)
downloadlinhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.zip
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.gz
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.bz2
RSYNC CORE:
resync core-testing -> core Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/core/tdb')
-rw-r--r--abs/core/tdb/PKGBUILD34
1 files changed, 16 insertions, 18 deletions
diff --git a/abs/core/tdb/PKGBUILD b/abs/core/tdb/PKGBUILD
index e908119..4bf2af6 100644
--- a/abs/core/tdb/PKGBUILD
+++ b/abs/core/tdb/PKGBUILD
@@ -1,28 +1,26 @@
-# $Id: PKGBUILD 37511 2009-05-02 16:17:09Z tpowa $
-# Maintainer: eric <eric@archlinux.org>
+# $Id: PKGBUILD 63109 2010-01-14 18:55:16Z tpowa $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# Contributorr: eric <eric@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=tdb
-pkgver=3.3.4
+pkgver=1.2.0
pkgrel=1
-# We use the 'A' to fake out pacman's version comparators. Samba chooses
-# to append 'a','b',etc to their subsequent releases, which pamcan
-# misconstrues as alpha, beta, etc. Bad samba!
-_realver=3.3.4
-pkgdesc="A Trivial Database similar to GDBM but allows simultaneous commits"
+pkgdesc="A Trivia Database similar to GDBM but allows simultaneous commits"
arch=(i686 x86_64)
license=('GPL3')
-url="www.samba.org"
-source=(http://us1.samba.org/samba/ftp/samba-${_realver}.tar.gz)
-options=(!makeflags)
+url="http://tdb.samba.org/"
+source=(http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+makedepends=('python')
+optdepends=('python: for python bindings')
+options=(force)
build() {
- cd ${srcdir}/samba-${_realver}/source/lib/tdb
- ./autogen.sh
- ./configure --prefix=/usr
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr \
+ --localstatedir=/var \
+ --sysconfdir=/etc/samba
make || return 1
- make DESTDIR=$startdir/pkg install
- ln -sf /usr/lib/libtdb.so.1.1.2 ${pkgdir}/usr/lib/libtdb.so.1
- ln -sf /usr/lib/libtdb.so.1.1.2 ${pkgdir}/usr/lib/libtdb.so
+ make DESTDIR=$pkgdir/ install
}
-md5sums=('1443165edb7cb3f56f1e77aec1ee3266')
+md5sums=('4115849d2ef431a10bc1f1933eafb9b6')