summaryrefslogtreecommitdiffstats
path: root/abs/core/tdb
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-11 02:09:01 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-11 02:09:01 (GMT)
commitf1229829f09110d9d8827d295194c5eaf1d8da25 (patch)
treec163679bd16dba66cb4980ef1344bfd8a2b9db79 /abs/core/tdb
parentafa2a40b8e491d011d510521f56409aebd467685 (diff)
downloadlinhes_pkgbuild-f1229829f09110d9d8827d295194c5eaf1d8da25.zip
linhes_pkgbuild-f1229829f09110d9d8827d295194c5eaf1d8da25.tar.gz
linhes_pkgbuild-f1229829f09110d9d8827d295194c5eaf1d8da25.tar.bz2
tdb: update to 1.2.1
Diffstat (limited to 'abs/core/tdb')
-rw-r--r--abs/core/tdb/PKGBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/abs/core/tdb/PKGBUILD b/abs/core/tdb/PKGBUILD
index 4bf2af6..7739dc1 100644
--- a/abs/core/tdb/PKGBUILD
+++ b/abs/core/tdb/PKGBUILD
@@ -1,26 +1,35 @@
-# $Id: PKGBUILD 63109 2010-01-14 18:55:16Z tpowa $
+# $Id: PKGBUILD 89866 2010-09-04 14:37:32Z remy $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Contributorr: eric <eric@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=tdb
-pkgver=1.2.0
-pkgrel=1
+pkgver=1.2.1
+pkgrel=2
pkgdesc="A Trivia Database similar to GDBM but allows simultaneous commits"
arch=(i686 x86_64)
license=('GPL3')
url="http://tdb.samba.org/"
source=(http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-makedepends=('python')
-optdepends=('python: for python bindings')
+makedepends=('python2' 'libxslt' 'docbook-xsl')
+optdepends=('python2: for python bindings')
options=(force)
build() {
cd ${srcdir}/${pkgname}-${pkgver}
+ sed -i 's#python2\.6\([^ ]*\)#python2.7\1 python2.6\1#' configure
+ # Use system docbook.xsl
+ _manstyle="/usr/share/xml/docbook/xsl-stylesheets-1.76.0/manpages/docbook.xsl"
+ sed -i "s#http.*xsl#$_manstyle#" tdb.mk
+
./configure --prefix=/usr \
--localstatedir=/var \
--sysconfdir=/etc/samba
make || return 1
- make DESTDIR=$pkgdir/ install
}
-md5sums=('4115849d2ef431a10bc1f1933eafb9b6')
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+md5sums=('73ea81282a82e5c959d9c082af2d0215')
+