summaryrefslogtreecommitdiffstats
path: root/abs/core/tzdata/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:02:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:02:09 (GMT)
commitdba198996192078303bbfa789c1742c9fedfddd6 (patch)
tree3a09624345dedbc94ececdcb9df2955e77bd0434 /abs/core/tzdata/PKGBUILD
parenta331e8fb709157b149f630d63dc01becf07be135 (diff)
downloadlinhes_pkgbuild-dba198996192078303bbfa789c1742c9fedfddd6.zip
linhes_pkgbuild-dba198996192078303bbfa789c1742c9fedfddd6.tar.gz
linhes_pkgbuild-dba198996192078303bbfa789c1742c9fedfddd6.tar.bz2
tzdata 2012
Diffstat (limited to 'abs/core/tzdata/PKGBUILD')
-rw-r--r--abs/core/tzdata/PKGBUILD51
1 files changed, 17 insertions, 34 deletions
diff --git a/abs/core/tzdata/PKGBUILD b/abs/core/tzdata/PKGBUILD
index dcedbd5..1f4c16a 100644
--- a/abs/core/tzdata/PKGBUILD
+++ b/abs/core/tzdata/PKGBUILD
@@ -1,45 +1,28 @@
-# $Id: PKGBUILD 130868 2011-07-08 14:35:26Z andyrtr $
+# $Id: PKGBUILD 163845 2012-07-21 11:06:11Z andyrtr $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
pkgname=tzdata
-pkgver=2011h
-pkgrel=2
-_tzcode=2011g
-_tzdata=2011h
+pkgver=2012d
+pkgrel=1
pkgdesc="Sources for time zone and daylight saving time data"
-arch=('i686' 'x86_64')
-url="http://www.twinsun.com/tz/tz-link.htm"
+arch=('any')
+url="http://www.iana.org/time-zones"
license=('GPL')
-depends=()
-makedepends=()
-optdepends=('bash: required by tzselect')
options=('!emptydirs')
-source=(ftp://elsie.nci.nih.gov/pub/tzcode${_tzcode}.tar.gz \
- ftp://elsie.nci.nih.gov/pub/${pkgname}${_tzdata}.tar.gz \
- Makefile.patch)
-md5sums=('ecb564279b28c5b184421c525d997d6c'
- '546d27b6c1e5e1097bd512651815017f'
- 'a64ed97d1fc03c66ee8612c0d9f40507')
+source=(http://www.iana.org/time-zones/repository/releases/${pkgname}${pkgver}.tar.gz)
+sha1sums=('65d98727233bfd3f5d20dceafab0a81ae2cb5527')
-build() {
- cd ${srcdir}
-
- tar -xf tzcode${_tzcode}.tar.gz
- tar -xf ${pkgname}${_tzdata}.tar.gz
-
- patch -Np1 -i "${srcdir}/Makefile.patch"
-
- make
-}
-
-check() {
- cd ${srcdir}
- make check
-}
+timezones=('africa' 'antarctica' 'asia' 'australasia'
+ 'europe' 'northamerica' 'southamerica'
+ 'pacificnew' 'etcetera' 'backward'
+ 'systemv' 'factory'
+ 'solar87' 'solar88' 'solar89')
package() {
cd ${srcdir}
- make DESTDIR="${pkgdir}" install
-
- rm "${pkgdir}/usr/share/zoneinfo/localtime"
+ zic -y ./yearistype -d ${pkgdir}/usr/share/zoneinfo ${timezones[@]}
+ zic -y ./yearistype -d ${pkgdir}/usr/share/zoneinfo/posix ${timezones[@]}
+ zic -y ./yearistype -d ${pkgdir}/usr/share/zoneinfo/right -L leapseconds ${timezones[@]}
+ zic -y ./yearistype -d ${pkgdir}/usr/share/zoneinfo -p America/New_York
+ install -m444 -t ${pkgdir}/usr/share/zoneinfo iso3166.tab zone.tab
}