summaryrefslogtreecommitdiffstats
path: root/abs/core/tzdata
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
committerJames Meyer <James.meyer@operamail.com>2008-10-02 03:19:12 (GMT)
commit0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a (patch)
treec0aa2c0b53c317be87eacfcb77b63f53f1f415e7 /abs/core/tzdata
downloadlinhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.zip
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.gz
linhes_pkgbuild-0e2532d4e8f4eed5e047f1db54d5c03ba849ec0a.tar.bz2
initial import
Diffstat (limited to 'abs/core/tzdata')
-rw-r--r--abs/core/tzdata/Makefile.patch140
-rw-r--r--abs/core/tzdata/PKGBUILD36
-rw-r--r--abs/core/tzdata/chile.patch65
3 files changed, 241 insertions, 0 deletions
diff --git a/abs/core/tzdata/Makefile.patch b/abs/core/tzdata/Makefile.patch
new file mode 100644
index 0000000..e88f9d9
--- /dev/null
+++ b/abs/core/tzdata/Makefile.patch
@@ -0,0 +1,140 @@
+diff -Naur src/Makefile src-p/Makefile
+--- src/Makefile 2007-08-20 16:47:41.000000000 +0200
++++ src-p/Makefile 2007-10-02 04:07:44.000000000 +0200
+@@ -34,17 +34,17 @@
+
+ # Everything gets put in subdirectories of. . .
+
+-TOPDIR= /usr/local
++TOPDIR= $(DESTDIR)/usr
+
+ # "Compiled" time zone information is placed in the "TZDIR" directory
+ # (and subdirectories).
+ # Use an absolute path name for TZDIR unless you're just testing the software.
+
+-TZDIR= $(TOPDIR)/etc/zoneinfo
++TZDIR= $(TOPDIR)/share/zoneinfo
+
+ # The "tzselect", "zic", and "zdump" commands get installed in. . .
+
+-ETCDIR= $(TOPDIR)/etc
++SBINDIR= $(TOPDIR)/sbin
+
+ # If you "make INSTALL", the "date" command gets installed in. . .
+
+@@ -52,7 +52,7 @@
+
+ # Manual pages go in subdirectories of. . .
+
+-MANDIR= $(TOPDIR)/man
++MANDIR= $(TOPDIR)/share/man
+
+ # Library functions are put in an archive in LIBDIR.
+
+@@ -83,7 +83,7 @@
+
+ # Non-default libraries needed to link.
+ # Add -lintl if you want to use `gettext' on Solaris.
+-LDLIBS=
++LDLIBS=$(LDFLAGS)
+
+ # Add the following to the end of the "CFLAGS=" line as needed.
+ # -Dconst= if `const' does not work (SunOS 4.x cc, OSF1 V5.0 cc)
+@@ -211,7 +211,7 @@
+ # before the first Monday in January when a "%V" format is used and January 1
+ # falls on a Friday, Saturday, or Sunday.
+
+-CFLAGS=
++CFLAGS += -std=gnu99
+
+ # If you want zic's -s option used when installing, uncomment the next line
+ # ZFLAGS= -s
+@@ -220,7 +220,7 @@
+ ZIC= $(zic) $(ZFLAGS)
+
+ # The name of a Posix-compliant `awk' on your system.
+-AWK= nawk
++AWK= awk
+
+ # The path where SGML DTDs are kept.
+ SGML_SEARCH_PATH= $(TOPDIR)/share/doc/sgml-lib/REC-html401-19991224/
+@@ -241,8 +241,10 @@
+
+ ###############################################################################
+
+-cc= cc
+-CC= $(cc) -DTZDIR=\"$(TZDIR)\"
++CC+= -DTZDIR=\"$(TZDIR)\"
++ifeq ($(NLS),1)
++CC += -DHAVE_GETTEXT=1 -DTZ_DOMAIN=\"libc\"
++endif
+
+ TZCSRCS= zic.c localtime.c asctime.c scheck.c ialloc.c
+ TZCOBJS= zic.o localtime.o asctime.o scheck.o ialloc.o
+@@ -282,14 +284,16 @@
+
+ ALL: all date
+
+-install: all $(DATA) $(REDO) $(TZLIB) $(MANS) $(TABDATA)
++install: all $(DATA) $(REDO) $(MANS) $(TABDATA)
+ $(ZIC) -y $(YEARISTYPE) \
+ -d $(TZDIR) -l $(LOCALTIME) -p $(POSIXRULES)
+ -rm -f $(TZDIR)/iso3166.tab $(TZDIR)/zone.tab
+ cp iso3166.tab zone.tab $(TZDIR)/.
+- -mkdir $(TOPDIR) $(ETCDIR)
+- cp tzselect zic zdump $(ETCDIR)/.
+- -mkdir $(TOPDIR) $(MANDIR) \
++ -mkdir -p $(TOPDIR) $(SBINDIR)
++ cp zic zdump $(SBINDIR)/.
++ -mkdir -p $(TOPDIR) $(BINDIR)
++ cp tzselect $(BINDIR)/.
++ -mkdir -p $(TOPDIR) $(MANDIR) \
+ $(MANDIR)/man3 $(MANDIR)/man5 $(MANDIR)/man8
+ -rm -f $(MANDIR)/man3/newctime.3 \
+ $(MANDIR)/man3/newtzset.3 \
+@@ -298,13 +302,11 @@
+ $(MANDIR)/man8/zdump.8 \
+ $(MANDIR)/man8/zic.8
+ cp newctime.3 newtzset.3 $(MANDIR)/man3/.
+- cp tzfile.5 $(MANDIR)/man5/.
+- cp tzselect.8 zdump.8 zic.8 $(MANDIR)/man8/.
+
+ INSTALL: ALL install date.1
+- -mkdir $(TOPDIR) $(BINDIR)
++ -mkdir -p $(TOPDIR) $(BINDIR)
+ cp date $(BINDIR)/.
+- -mkdir $(TOPDIR) $(MANDIR) $(MANDIR)/man1
++ -mkdir -p $(TOPDIR) $(MANDIR) $(MANDIR)/man1
+ -rm -f $(MANDIR)/man1/date.1
+ cp date.1 $(MANDIR)/man1/.
+
+@@ -334,9 +336,9 @@
+ # You must replace all of $(TZDIR) to switch from not using leap seconds
+ # to using them, or vice versa.
+ other_two: zic leapseconds $(TDATA)
+- $(ZIC) -y $(YEARISTYPE) -d $(TZDIR)-posix -L /dev/null $(TDATA)
++ $(ZIC) -y $(YEARISTYPE) -d $(TZDIR)/posix -L /dev/null $(TDATA)
+ $(ZIC) -y $(YEARISTYPE) \
+- -d $(TZDIR)-leaps -L leapseconds $(TDATA)
++ -d $(TZDIR)/right -L leapseconds $(TDATA)
+
+ posix_right: posix_only other_two
+
+@@ -367,7 +369,7 @@
+ <$? >$@
+ chmod +x $@
+
+-check: check_tables check_web
++check: check_tables
+
+ check_tables: checktab.awk $(PRIMARY_YDATA)
+ $(AWK) -f checktab.awk $(PRIMARY_YDATA)
+diff -Naur src/tzselect.ksh src-p/tzselect.ksh
+--- src/tzselect.ksh 2007-08-20 16:47:42.000000000 +0200
++++ src-p/tzselect.ksh 2007-10-02 04:07:44.000000000 +0200
+@@ -1,4 +1,4 @@
+-#! /bin/ksh
++#! /bin/bash
+
+ # '@(#)tzselect.ksh 8.1'
+
diff --git a/abs/core/tzdata/PKGBUILD b/abs/core/tzdata/PKGBUILD
new file mode 100644
index 0000000..544f1c7
--- /dev/null
+++ b/abs/core/tzdata/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 8190 2008-08-08 21:11:59Z andyrtr $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=tzdata
+pkgver=2008e
+pkgrel=10
+_tzcode=2008e
+_tzdata=2008e
+pkgdesc="Sources for time zone and daylight saving time data"
+arch=('i686' 'x86_64')
+url="http://www.twinsun.com/tz/tz-link.htm"
+license=('GPL')
+groups=('base')
+depends=()
+makedepends=()
+options=()
+source=(ftp://elsie.nci.nih.gov/pub/tzcode${_tzcode}.tar.gz \
+ ftp://elsie.nci.nih.gov/pub/${pkgname}${_tzdata}.tar.gz \
+ Makefile.patch)
+md5sums=('12ec2d85324ddcba39db1471a03f486b'
+ '3b4578110a3d193ed9a00d61f27aba28'
+ 'a64ed97d1fc03c66ee8612c0d9f40507')
+
+build() {
+ cd ${srcdir}/
+
+ tar -xf tzcode${_tzcode}.tar.gz || return 1
+ tar -xf ${pkgname}${_tzdata}.tar.gz || return 1
+
+ patch -Np1 -i ../Makefile.patch || return 1
+
+ make || return 1
+ make DESTDIR="${pkgdir}" install
+
+ rm ${pkgdir}/usr/share/zoneinfo/localtime
+}
diff --git a/abs/core/tzdata/chile.patch b/abs/core/tzdata/chile.patch
new file mode 100644
index 0000000..38c389c
--- /dev/null
+++ b/abs/core/tzdata/chile.patch
@@ -0,0 +1,65 @@
+------- southamerica -------
+*** southamerica Wed Mar 5 14:40:25 2008
+--- southamerica Wed Mar 5 14:40:25 2008
+***************
+*** 1,4 ****
+! # @(#)southamerica 8.15
+ # <pre>
+
+ # This data is by no means authoritative; if you think you know better,
+--- 1,4 ----
+! # @(#)southamerica 8.18
+ # <pre>
+
+ # This data is by no means authoritative; if you think you know better,
+***************
+*** 759,764 ****
+--- 759,784 ----
+ # America/Santiago. The pre-1980 Pacific/Easter data are dubious,
+ # but we have no other source.
+
++ # From German Poo-Caaman~o (2008-03-03):
++ # Due to drought, Chile extends Daylight Time in three weeks. This
++ # is one-time change (Saturday 3/29 at 24:00 for America/Santiago
++ # and Saturday 3/29 at 22:00 for Pacific/Easter)
++ # The Supreme Decree is located at
++ # <a href="http://www.shoa.cl/servicios/supremo316.pdf">
++ # http://www.shoa.cl/servicios/supremo316.pdf
++ # </a>
++ # and the instructions for 2008 are located in:
++ # <a href="http://www.horaoficial.cl/cambio.htm">
++ # http://www.horaoficial.cl/cambio.htm
++ # </a>.
++
++ # From José Miguel Garrido (2008-03-05):
++ # ...
++ # You could see the announces of the change on
++ # <a href="http://www.shoa.cl/noticias/2008/04hora/hora.htm">
++ # http://www.shoa.cl/noticias/2008/04hora/hora.htm
++ # </a>.
++
+ # Rule NAME FROM TO TYPE IN ON AT SAVE LETTER/S
+ Rule Chile 1927 1932 - Sep 1 0:00 1:00 S
+ Rule Chile 1928 1932 - Apr 1 0:00 0 -
+***************
+*** 789,795 ****
+ Rule Chile 1998 only - Sep 27 4:00u 1:00 S
+ Rule Chile 1999 only - Apr 4 3:00u 0 -
+ Rule Chile 1999 max - Oct Sun>=9 4:00u 1:00 S
+! Rule Chile 2000 max - Mar Sun>=9 3:00u 0 -
+ # IATA SSIM anomalies: (1992-02) says 1992-03-14;
+ # (1996-09) says 1998-03-08. Ignore these.
+ # Zone NAME GMTOFF RULES FORMAT [UNTIL]
+--- 809,819 ----
+ Rule Chile 1998 only - Sep 27 4:00u 1:00 S
+ Rule Chile 1999 only - Apr 4 3:00u 0 -
+ Rule Chile 1999 max - Oct Sun>=9 4:00u 1:00 S
+! Rule Chile 2000 2007 - Mar Sun>=9 3:00u 0 -
+! # N.B.: the end of March 29 in Chile is March 30 in Universal time,
+! # which is used below in specifying the transition.
+! Rule Chile 2008 only - Mar 30 3:00u 0 -
+! Rule Chile 2009 max - Mar Sun>=9 3:00u 0 -
+ # IATA SSIM anomalies: (1992-02) says 1992-03-14;
+ # (1996-09) says 1998-03-08. Ignore these.
+ # Zone NAME GMTOFF RULES FORMAT [UNTIL]
+