summaryrefslogtreecommitdiffstats
path: root/abs/core/udevil
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-08-10 13:49:44 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-08-10 13:49:44 (GMT)
commit59afebf4e09cb74383fe0237471d05e3157e84c4 (patch)
treeb747a829a110c115f213836fad043f14f6701c45 /abs/core/udevil
parent6782a7515790d455738f485f2147bc5477657766 (diff)
downloadlinhes_pkgbuild-59afebf4e09cb74383fe0237471d05e3157e84c4.zip
linhes_pkgbuild-59afebf4e09cb74383fe0237471d05e3157e84c4.tar.gz
linhes_pkgbuild-59afebf4e09cb74383fe0237471d05e3157e84c4.tar.bz2
udevil: update to 0.4.4
Diffstat (limited to 'abs/core/udevil')
-rw-r--r--abs/core/udevil/PKGBUILD22
-rw-r--r--abs/core/udevil/__changelog1
2 files changed, 11 insertions, 12 deletions
diff --git a/abs/core/udevil/PKGBUILD b/abs/core/udevil/PKGBUILD
index 912d0bf..bae0f80 100644
--- a/abs/core/udevil/PKGBUILD
+++ b/abs/core/udevil/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 80589 2012-11-26 14:58:37Z bpiotrowski $
+# $Id$
# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
# Contributor: IgnorantGuru http://igurublog.wordpress.com/contact-ignorantguru/
pkgname=udevil
-pkgver=0.3.5
+pkgver=0.4.4
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Mount and unmount without password'
@@ -11,29 +11,27 @@ url='http://ignorantguru.github.com/udevil/'
license=('GPL3')
makedepends=('intltool' 'gettext')
depends=('udev' 'glib2')
-optdepends=('nfs-utils: mount nfs shares'
+optdepends=('davfs2: mount WebDAV shares'
+ 'nfs-utils: mount nfs shares'
'sshfs: mount sftp shares'
'curlftpfs: mount ftp shares'
'cifs-utils: mount samba shares'
- 'eject: eject via devmon'
'zenity: devmon popups'
- 'pmount: devmon mount without suid udevil'
- 'udisks: devmon mount without suid udevil'
'udisks2: devmon mount without suid udevil')
provides=('devmon')
backup=('etc/udevil/udevil.conf')
install=$pkgname.install
-source=(https://raw.github.com/IgnorantGuru/$pkgname/master/packages/$pkgver/$pkgname-$pkgver.tar.xz)
+source=($pkgname-$pkgver.tar.gz::https://github.com/IgnorantGuru/udevil/archive/$pkgver.tar.gz)
+md5sums=('281aa065d92c679cb41728069e72b272')
build() {
- cd $srcdir/$pkgname-$pkgver
+ cd $pkgname-$pkgver
+ sed -i 's:#include <limits.h>:#include <limits.h>\n#include <sys/stat.h>:g' src/device-info.h
./configure --prefix=/usr
make
}
package() {
- cd $srcdir/$pkgname-$pkgver
- make DESTDIR=$pkgdir install
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
}
-
-md5sums=('0acb03c85f06fc8b59c6997830613529')
diff --git a/abs/core/udevil/__changelog b/abs/core/udevil/__changelog
new file mode 100644
index 0000000..8561a28
--- /dev/null
+++ b/abs/core/udevil/__changelog
@@ -0,0 +1 @@
+PKGBUILD: add #include <sys/stat.h> to device-info.h to fix error