summaryrefslogtreecommitdiffstats
path: root/abs/core/unzip
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
commitc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (patch)
treef4e4f7a91e1d9d90033fd99d89e5e26a2c144528 /abs/core/unzip
parent0e7b327a1ae444233f1308a95420f70540ad74a3 (diff)
downloadlinhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.zip
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.gz
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.bz2
RSYNC CORE:
resync core-testing -> core Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/core/unzip')
-rw-r--r--abs/core/unzip/PKGBUILD29
1 files changed, 10 insertions, 19 deletions
diff --git a/abs/core/unzip/PKGBUILD b/abs/core/unzip/PKGBUILD
index 4bcecf5..730beb9 100644
--- a/abs/core/unzip/PKGBUILD
+++ b/abs/core/unzip/PKGBUILD
@@ -2,33 +2,19 @@
# Maintainer: Dan McGee <dan@archlinux.org>
pkgname=unzip
-pkgver=5.52
-pkgrel=4
+pkgver=6.00
+_pkgver=60
+pkgrel=1
pkgdesc="Unpacks .zip archives such as those made by PKZIP"
arch=('i686' 'x86_64')
url="http://www.info-zip.org/"
license=('custom')
depends=('glibc')
-source=(http://downloads.sourceforge.net/infozip/unzip552.tar.gz
- unzip-5.5.2-CVE-2008-0888.patch
- unzip-5.50-alt-iconv-v1.2-utf8.patch
- unzip542-size-64bit.patch)
-md5sums=('9d23919999d6eac9217d1f41472034a9'
- '2de357c2ba84576f38b17aed87915c87'
- 'a4797a1f6e45385f5e021f9f6f2ec0fa'
- '83c7e79de9618bf7d081dd639dd3dde1')
+source=(http://downloads.sourceforge.net/infozip/${pkgname}${_pkgver}.tar.gz)
build() {
- cd $startdir/src/$pkgname-$pkgver
-
- # http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0888
- patch -Np0 -i ../unzip-5.5.2-CVE-2008-0888.patch || return 1
+ cd $startdir/src/${pkgname}${_pkgver}
- # FS#8383
- patch -Np1 -i ../unzip-5.50-alt-iconv-v1.2-utf8.patch || return 1
-
- [ "$CARCH" == "x86_64" ] && (patch -Np0 -i ../unzip542-size-64bit.patch || return 1)
-
export CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64"
if [ "${CARCH}" = "i686" ]; then
make -f unix/Makefile LOCAL_UNZIP="$CFLAGS" prefix=/usr linux || return 1
@@ -39,3 +25,8 @@ build() {
install -Dm644 LICENSE $startdir/pkg/usr/share/licenses/unzip/LICENSE
}
+md5sums=('62b490407489521db863b523a7f86375'
+ '2de357c2ba84576f38b17aed87915c87'
+ 'a4797a1f6e45385f5e021f9f6f2ec0fa'
+ '83c7e79de9618bf7d081dd639dd3dde1')
+md5sums=('62b490407489521db863b523a7f86375')