summaryrefslogtreecommitdiffstats
path: root/abs/core/usbutils
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:04:36 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:04:36 (GMT)
commitf3d2833257ef401f6311b0d1a7a7e5c7fb5bdc12 (patch)
treee51cde56ce633b0833d9050a2947035bcb333b4d /abs/core/usbutils
parentc79effe21dccc03d1cecc5eb6dbc58a3b9f4cb9f (diff)
downloadlinhes_pkgbuild-f3d2833257ef401f6311b0d1a7a7e5c7fb5bdc12.zip
linhes_pkgbuild-f3d2833257ef401f6311b0d1a7a7e5c7fb5bdc12.tar.gz
linhes_pkgbuild-f3d2833257ef401f6311b0d1a7a7e5c7fb5bdc12.tar.bz2
usbutils 006
Diffstat (limited to 'abs/core/usbutils')
-rw-r--r--abs/core/usbutils/PKGBUILD33
1 files changed, 19 insertions, 14 deletions
diff --git a/abs/core/usbutils/PKGBUILD b/abs/core/usbutils/PKGBUILD
index fff0508..08513e5 100644
--- a/abs/core/usbutils/PKGBUILD
+++ b/abs/core/usbutils/PKGBUILD
@@ -1,30 +1,35 @@
-# $Id: PKGBUILD 87429 2010-08-13 10:22:39Z tpowa $
-# Maintainer: Judd Vinet <jvinet@zeroflux.org>
+# $Id: PKGBUILD 163502 2012-07-13 16:29:26Z tpowa $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Tom Gundersen <teg@jklm.no>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
# Contributor: Curtis Campbell <curtisjamescampbell@hotmail.com>
pkgname=usbutils
-pkgver=0.90
+pkgver=006
pkgrel=1
pkgdesc="USB Device Utilities"
-arch=('i686' 'x86_64')
+arch=(i686 x86_64)
license=('GPL')
groups=('base')
-makedepends=('wget')
-depends=('glibc' 'libusb')
+depends=('libusb' 'hwids')
+optdepends=('python2: for lsusb.py usage'
+ 'coreutils: for lsusb.py usage')
url="http://linux-usb.sourceforge.net/"
-source=(http://www.kernel.org/pub/linux/utils/usb/$pkgname/$pkgname-$pkgver.tar.gz)
+source=("http://www.kernel.org/pub/linux/utils/usb/usbutils/${pkgname}-${pkgver}.tar.xz"
+ fix-python2.patch)
+md5sums=('c9aa14ee3d6c991fda183f42cf72a8a8'
+ '45766196895b4cc50b53cd56e1bbf3d1')
build() {
cd $srcdir/$pkgname-$pkgver
- rm usb.ids
- wget http://www.linux-usb.org/usb.ids
+ # patch lsusb.py to use correct usb.ids file and python2 interpreter
+ patch -Np1 -i $srcdir/fix-python2.patch
./configure --prefix=/usr --datadir=/usr/share/hwdata --disable-zlib
- make || return 1
+ make
}
+
package() {
cd $srcdir/$pkgname-$pkgver
make DESTDIR=$pkgdir install
- # fix pkgconfig file
- mkdir -p $pkgdir/usr/lib
- mv $pkgdir/usr/share/hwdata/pkgconfig $pkgdir/usr/lib/
+ # this is now in the hwids package
+ rm -rf $pkgdir/usr/{share/hwdata,sbin}
}
-md5sums=('53f0269e2cba704d5a35dfe291511292')