summaryrefslogtreecommitdiffstats
path: root/abs/core/util-linux/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-12-15 20:53:53 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-12-15 20:53:53 (GMT)
commit02c29713e636d105e63fe2286fdd673a57573eea (patch)
treece91af604a0b92e61f00bb68edc9ae7c10bf7516 /abs/core/util-linux/PKGBUILD
parentfca162ce703a757f1b23106065851b574428315f (diff)
downloadlinhes_pkgbuild-02c29713e636d105e63fe2286fdd673a57573eea.zip
linhes_pkgbuild-02c29713e636d105e63fe2286fdd673a57573eea.tar.gz
linhes_pkgbuild-02c29713e636d105e63fe2286fdd673a57573eea.tar.bz2
util-linux: update to 2.29
Diffstat (limited to 'abs/core/util-linux/PKGBUILD')
-rw-r--r--abs/core/util-linux/PKGBUILD39
1 files changed, 33 insertions, 6 deletions
diff --git a/abs/core/util-linux/PKGBUILD b/abs/core/util-linux/PKGBUILD
index 64faa1a..72df84c 100644
--- a/abs/core/util-linux/PKGBUILD
+++ b/abs/core/util-linux/PKGBUILD
@@ -5,7 +5,8 @@
pkgbase=util-linux
pkgname=(util-linux libutil-linux)
-pkgver=2.27.1
+_pkgmajor=2.29
+pkgver=${_pkgmajor}
pkgrel=1
pkgdesc="Miscellaneous system utilities for Linux"
url="https://www.kernel.org/pub/linux/utils/util-linux/"
@@ -14,13 +15,33 @@ makedepends=('systemd' 'python2')
license=('GPL2')
options=('strip' 'debug')
validpgpkeys=('B0C64D14301CC6EFAEDF60E4E4B71D5EEC39C284') # Karel Zak
-source=("https://www.kernel.org/pub/linux/utils/util-linux/v${pkgver%.?}/$pkgbase-$pkgver.tar."{xz,sign}
- pam-{login,common,su})
-md5sums=('3cd2698d1363a2c64091c2dadc974647'
+source=("https://www.kernel.org/pub/linux/utils/util-linux/v$_pkgmajor/$pkgbase-$pkgver.tar."{xz,sign}
+ pam-{login,common,su}
+ '0001-sfdisk-don-t-be-silent-when-list-non-existing-device.patch'
+ '0001-sfdisk-cleanup-dump-error-messages.patch'
+ '0001-sfdisk-support-empty-label-use-case.patch'
+ '0001-chrt-default-to-SCHED_RR-policy.patch'
+ '0001-lsns-Fix-parser-for-proc-pid-stat-which-is-including.patch')
+md5sums=('07b6845f48a421ad5844aa9d58edb837'
'SKIP'
'4368b3f98abd8a32662e094c54e7f9b1'
'a31374fef2cba0ca34dfc7078e2969e4'
- 'fa85e5cce5d723275b14365ba71a8aad')
+ 'fa85e5cce5d723275b14365ba71a8aad'
+ '3fce7192ce1b3d97fdffd0226ed63a90'
+ '2f3c061865360170cacda948035fd02d'
+ '6d2e3915124938577f0ff18ef701c87f'
+ '168c1cb2cfe7d4eddfc6e3f3b19d3ced'
+ '68c2076a9a09564ba0c9776540a175fa')
+
+prepare() {
+ cd "$pkgbase-$pkgver"
+
+ patch -Np1 <../0001-sfdisk-don-t-be-silent-when-list-non-existing-device.patch
+ patch -Np1 <../0001-sfdisk-cleanup-dump-error-messages.patch
+ patch -Np1 <../0001-sfdisk-support-empty-label-use-case.patch
+ patch -Np1 <../0001-chrt-default-to-SCHED_RR-policy.patch
+ patch -Np1 <../0001-lsns-Fix-parser-for-proc-pid-stat-which-is-including.patch
+}
build() {
cd "$pkgbase-$pkgver"
@@ -36,7 +57,7 @@ build() {
--enable-chfn-chsh \
--enable-write \
--enable-mesg \
- --enable-libmount-force-mountinfo \
+ --disable-tailf \
--with-python=2
make
@@ -80,6 +101,12 @@ package_util-linux() {
### runtime libs are shipped as part of libutil-linux
rm "$pkgdir"/usr/lib/lib*.{a,so}*
+
+ ### tailf has been deprecated for a while. let's not include it anymore.
+ rm \
+ "$pkgdir"/usr/bin/tailf \
+ "$pkgdir"/usr/share/bash-completion/completions/tailf \
+ "$pkgdir"/usr/share/man/man1/tailf.1
}
package_libutil-linux() {