summaryrefslogtreecommitdiffstats
path: root/abs/core/util-linux/PKGBUILD
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-07-17 20:43:32 (GMT)
committerCecil <knoppmyth@gmail.com>2011-07-17 20:43:32 (GMT)
commitbc20eabc527a488cdde599da89306442342b41f3 (patch)
treef131d0e973022f86aae5a87eb8695518e3f970fa /abs/core/util-linux/PKGBUILD
parent1844925ed45f3fddce5690896c337f910fa45f82 (diff)
downloadlinhes_pkgbuild-bc20eabc527a488cdde599da89306442342b41f3.zip
linhes_pkgbuild-bc20eabc527a488cdde599da89306442342b41f3.tar.gz
linhes_pkgbuild-bc20eabc527a488cdde599da89306442342b41f3.tar.bz2
util-linux:Bumped to latest.
Diffstat (limited to 'abs/core/util-linux/PKGBUILD')
-rw-r--r--abs/core/util-linux/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/abs/core/util-linux/PKGBUILD b/abs/core/util-linux/PKGBUILD
new file mode 100644
index 0000000..877e013
--- /dev/null
+++ b/abs/core/util-linux/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id: PKGBUILD 123897 2011-05-14 09:14:06Z tpowa $
+# Maintainer:
+# Contributor: judd <jvinet@zeroflux.org>
+
+pkgname=util-linux
+pkgver=2.19.1
+pkgrel=2
+pkgdesc="Miscellaneous system utilities for Linux"
+url="http://userweb.kernel.org/~kzak/util-linux-ng/"
+arch=('i686' 'x86_64')
+groups=('base')
+depends=('bash' 'ncurses>=5.7' 'zlib' 'filesystem')
+replaces=('linux32' 'util-linux-ng')
+conflicts=('linux32' 'util-linux-ng' 'e2fsprogs<1.41.8-2')
+provides=('linux32' "util-linux-ng=${pkgver}")
+license=('GPL2')
+options=('!libtool')
+source=(ftp://ftp.kernel.org/pub/linux/utils/${pkgname}/v2.19/${pkgname}-${pkgver}.tar.bz2
+ mount-segfault-2.19.1.patch)
+optdepends=('perl: for chkdupexe support')
+md5sums=('3eab06f05163dfa65479c44e5231932c'
+ '3247b52f0e4b8044f23f2f7218e2fdea')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # fix https://bugs.archlinux.org/task/24261
+ patch -Np1 -i ../mount-segfault-2.19.1.patch
+ # hardware clock
+ sed -e 's%etc/adjtime%var/lib/hwclock/adjtime%' -i hwclock/hwclock.c
+ ./configure --enable-arch --enable-write --enable-raw --disable-wall --enable-partx
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -dm755 "${pkgdir}/var/lib/hwclock"
+ make DESTDIR="${pkgdir}" install
+}