summaryrefslogtreecommitdiffstats
path: root/abs/core/util-linux
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-07 15:00:37 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-07 15:00:37 (GMT)
commit171326063252ba64350f6df608fb6053a495040f (patch)
tree26c38aff57a5eda46eee684430cc9c98f41a05d1 /abs/core/util-linux
parent77ed548f0790b9b5929bedd8162697214fb8bf94 (diff)
downloadlinhes_pkgbuild-171326063252ba64350f6df608fb6053a495040f.zip
linhes_pkgbuild-171326063252ba64350f6df608fb6053a495040f.tar.gz
linhes_pkgbuild-171326063252ba64350f6df608fb6053a495040f.tar.bz2
util-linux: 2.22.1
Diffstat (limited to 'abs/core/util-linux')
-rw-r--r--abs/core/util-linux/PKGBUILD66
-rw-r--r--abs/core/util-linux/__changelog1
-rw-r--r--abs/core/util-linux/pam-su9
-rw-r--r--abs/core/util-linux/util-linux.install11
-rw-r--r--abs/core/util-linux/uuidd.tmpfiles1
5 files changed, 61 insertions, 27 deletions
diff --git a/abs/core/util-linux/PKGBUILD b/abs/core/util-linux/PKGBUILD
index bfa1517..857bcc4 100644
--- a/abs/core/util-linux/PKGBUILD
+++ b/abs/core/util-linux/PKGBUILD
@@ -1,24 +1,30 @@
-# $Id: PKGBUILD 163535 2012-07-15 00:25:36Z tomegun $
+# $Id: PKGBUILD 171469 2012-11-17 23:02:13Z allan $
# Maintainer: Tom Gundersen <teg@jklm.no>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=util-linux
-pkgver=2.21.2
-pkgrel=5
+pkgver=2.22.1
+pkgrel=3
pkgdesc="Miscellaneous system utilities for Linux"
url="http://www.kernel.org/pub/linux/utils/util-linux/"
arch=('i686' 'x86_64')
groups=('base')
-depends=('pam')
-conflicts=('util-linux-ng')
-provides=("util-linux-ng=${pkgver}")
+depends=('pam' 'shadow' 'coreutils' 'glibc')
+# checkdepends=('bc')
+conflicts=('util-linux-ng' 'eject')
+provides=("util-linux-ng=${pkgver}" 'eject')
license=('GPL2')
options=('!libtool')
-source=(ftp://ftp.kernel.org/pub/linux/utils/${pkgname}/v2.21/${pkgname}-${pkgver}.tar.xz
+source=(ftp://ftp.kernel.org/pub/linux/utils/${pkgname}/v2.22/${pkgname}-${pkgver}.tar.xz
+ uuidd.tmpfiles
pam-login
pam-common
- term_utils-agetty.patch)
-backup=(etc/pam.d/chfn etc/pam.d/chsh etc/pam.d/login)
+ pam-su)
+backup=(etc/pam.d/chfn
+ etc/pam.d/chsh
+ etc/pam.d/login
+ etc/pam.d/su
+ etc/pam.d/su-l)
install=util-linux.install
build() {
@@ -26,43 +32,51 @@ build() {
./configure --prefix=/usr \
--libdir=/usr/lib \
+ --localstatedir=/run \
--enable-fs-paths-extra=/usr/bin:/usr/sbin \
- --enable-write \
--enable-raw \
- --disable-wall \
- --enable-new-mount \
- --enable-login-utils
+ --enable-vipw \
+ --enable-newgrp \
+ --enable-chfn-chsh \
+ --enable-write \
+ --enable-mesg \
+ --enable-socket-activation
+
+# --enable-reset \ # part of ncurses
+# --enable-line \ # not part of any package
+# --enable-last \ # not compat
make
}
-check() {
- make -C "$pkgname-$pkgver" check
-}
+#check() {
+# fails for some reason in chroot, works outside
+# make -C "$pkgname-$pkgver" check
+#}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p0 < ${srcdir}/term_utils-agetty.patch || return 1
make DESTDIR="${pkgdir}" install
cd "${pkgdir}"
- # broken tool, going away in next major release, so just remove it now
- rm "${pkgdir}"/usr/{bin/chkdupexe,share/man/man1/chkdupexe.1}
-
- # delete stray empty dir, fixed upstream
- rm -r usr/share/man/ru
-
# setuid chfn and chsh
- chmod 4755 "$pkgdir"/usr/bin/ch{sh,fn}
+ chmod 4755 "$pkgdir"/usr/bin/{newgrp,ch{sh,fn}}
# install PAM files for login-utils
install -Dm644 "$srcdir/pam-common" "$pkgdir/etc/pam.d/chfn"
install -m644 "$srcdir/pam-common" "$pkgdir/etc/pam.d/chsh"
install -m644 "$srcdir/pam-login" "$pkgdir/etc/pam.d/login"
+ install -m644 "$srcdir/pam-su" "${pkgdir}/etc/pam.d/su"
+ install -m644 "$srcdir/pam-su" "${pkgdir}/etc/pam.d/su-l"
+
+ # include tmpfiles fragment for uuidd
+ # TODO(dreisner): offer this upstream?
+ install -Dm644 "$srcdir/uuidd.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/uuidd.conf"
}
-md5sums=('54ba880f1d66782c2287ee2c898520e9'
+md5sums=('730cf9932531ed09b53a04ca30fcb4c9'
+ 'a39554bfd65cccfd8254bb46922f4a67'
'4368b3f98abd8a32662e094c54e7f9b1'
'a31374fef2cba0ca34dfc7078e2969e4'
- 'da1e8645a7cff8fbc08e861466e2727e')
+ 'fa85e5cce5d723275b14365ba71a8aad')
diff --git a/abs/core/util-linux/__changelog b/abs/core/util-linux/__changelog
deleted file mode 100644
index 5a06d16..0000000
--- a/abs/core/util-linux/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-utils-agetty-patch
diff --git a/abs/core/util-linux/pam-su b/abs/core/util-linux/pam-su
new file mode 100644
index 0000000..cf15f40
--- /dev/null
+++ b/abs/core/util-linux/pam-su
@@ -0,0 +1,9 @@
+#%PAM-1.0
+auth sufficient pam_rootok.so
+# Uncomment the following line to implicitly trust users in the "wheel" group.
+#auth sufficient pam_wheel.so trust use_uid
+# Uncomment the following line to require a user to be in the "wheel" group.
+#auth required pam_wheel.so use_uid
+auth required pam_unix.so
+account required pam_unix.so
+session required pam_unix.so
diff --git a/abs/core/util-linux/util-linux.install b/abs/core/util-linux/util-linux.install
index 90ce5bd..4c0bb10 100644
--- a/abs/core/util-linux/util-linux.install
+++ b/abs/core/util-linux/util-linux.install
@@ -1,3 +1,12 @@
+post_install() {
+ # we don't want use systemd-tmpfiles here because
+ # the package dependency would create a circular dep.
+ if [ ! -d run/uuidd ]; then
+ # refer to uid/gid by number to avoid dependency on filesystem
+ install -o 68 -g 68 -dm755 run/uuidd
+ fi
+}
+
post_upgrade() {
if [ "$(vercmp $2 2.21.2-4)" -lt 0 ]; then
if [ -f /var/lib/hwclock/adjtime ]; then
@@ -7,4 +16,6 @@ post_upgrade() {
rmdir /var/lib/hwclock
fi
fi
+
+ post_install
}
diff --git a/abs/core/util-linux/uuidd.tmpfiles b/abs/core/util-linux/uuidd.tmpfiles
new file mode 100644
index 0000000..b059cfe
--- /dev/null
+++ b/abs/core/util-linux/uuidd.tmpfiles
@@ -0,0 +1 @@
+d /run/uuidd 0755 uuidd uuidd