summaryrefslogtreecommitdiffstats
path: root/abs/core/v4l-dvb/v4l-dvb.install
diff options
context:
space:
mode:
authorMichael Hanson <mihanson@linhes.org>2012-04-14 05:13:05 (GMT)
committerMichael Hanson <mihanson@linhes.org>2012-04-14 05:13:05 (GMT)
commit5e96cb93d1f17a98a8f8a118b2659ea4d71d3f43 (patch)
treeacde2ddc972337f648a826f3d961dcb8bebf892a /abs/core/v4l-dvb/v4l-dvb.install
parent8e721470713e6a5a164f1d7682b0d248cb87b03c (diff)
parent502a19b42d9df3fb3c3e521a37eebd20f9fbd984 (diff)
downloadlinhes_pkgbuild-5e96cb93d1f17a98a8f8a118b2659ea4d71d3f43.zip
linhes_pkgbuild-5e96cb93d1f17a98a8f8a118b2659ea4d71d3f43.tar.gz
linhes_pkgbuild-5e96cb93d1f17a98a8f8a118b2659ea4d71d3f43.tar.bz2
Merge branch 'testing' of linhes.org:linhes_pkgbuild into testing
Conflicts: abs/extra/bluez/PKGBUILD abs/extra/bluez/__changelog
Diffstat (limited to 'abs/core/v4l-dvb/v4l-dvb.install')
-rw-r--r--abs/core/v4l-dvb/v4l-dvb.install8
1 files changed, 8 insertions, 0 deletions
diff --git a/abs/core/v4l-dvb/v4l-dvb.install b/abs/core/v4l-dvb/v4l-dvb.install
index 8fb315c..ec6382d 100644
--- a/abs/core/v4l-dvb/v4l-dvb.install
+++ b/abs/core/v4l-dvb/v4l-dvb.install
@@ -1,10 +1,18 @@
post_install() {
+ echo ">>> Removing duplicate compressed kernel modules..."
+ for file in `find /lib/modules -name "*.ko"`; do if [[ -e $file.gz ]]; then rm "$file.gz"; fi; done
echo ">>> Running depmod..."
depmod
}
post_upgrade() {
+ echo ">>> Removing duplicate compressed kernel modules..."
+ for file in `find /lib/modules -name "*.ko"`; do if [[ -e $file.gz ]]; then rm "$file.gz"; fi; done
echo ">>> Running depmod..."
depmod
}
+post_remove() {
+ echo ">>> v4l-dvb has been removed"
+ echo ">>> kernel26 & dvb-firmware & linux-firmware should be reinstalled"
+}