summaryrefslogtreecommitdiffstats
path: root/abs/core/v4l-dvb
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2012-03-26 16:17:25 (GMT)
committerBritney Fransen <brfransen@gmail.com>2012-03-26 16:17:25 (GMT)
commita26eb8c5c0dd39c49d440a203463c55a05e82180 (patch)
tree6c5df237cf8a9291e4247e6139e1268eaf5b9cdf /abs/core/v4l-dvb
parent3614874a18f4c231f8698faa4225b7c9572b1955 (diff)
downloadlinhes_pkgbuild-a26eb8c5c0dd39c49d440a203463c55a05e82180.zip
linhes_pkgbuild-a26eb8c5c0dd39c49d440a203463c55a05e82180.tar.gz
linhes_pkgbuild-a26eb8c5c0dd39c49d440a203463c55a05e82180.tar.bz2
v4l-dvb: fix breakage
our kernel had compressed modules and were conflicting with the uncompressed modules in v4l-dvb. post-install and post-upgrade remove the compressed modules.
Diffstat (limited to 'abs/core/v4l-dvb')
-rw-r--r--abs/core/v4l-dvb/PKGBUILD6
-rw-r--r--abs/core/v4l-dvb/v4l-dvb.install8
2 files changed, 11 insertions, 3 deletions
diff --git a/abs/core/v4l-dvb/PKGBUILD b/abs/core/v4l-dvb/PKGBUILD
index 4463335..47a168a 100644
--- a/abs/core/v4l-dvb/PKGBUILD
+++ b/abs/core/v4l-dvb/PKGBUILD
@@ -2,9 +2,9 @@
pkgname=v4l-dvb
_kernver=`uname -r`
-pkgver=20120113
-pkgrel=2
-pkgdesc="V4L-DVB device drivers (newer than those included in kernel)"
+pkgver=20120326
+pkgrel=1
+pkgdesc="V4L-DVB device drivers (newer than those included in kernel26)"
arch=('i686' 'x86_64')
url="http://linuxtv.org/"
license=('GPL2')
diff --git a/abs/core/v4l-dvb/v4l-dvb.install b/abs/core/v4l-dvb/v4l-dvb.install
index 8fb315c..46e6277 100644
--- a/abs/core/v4l-dvb/v4l-dvb.install
+++ b/abs/core/v4l-dvb/v4l-dvb.install
@@ -1,10 +1,18 @@
post_install() {
+ echo ">>> Removing duplicate compressed kernel modules"
+ for file in `find /lib/modules -name "*.ko"`; do if [[ -e $file.gz ]]; then rm "$file.gz"; fi; done
echo ">>> Running depmod..."
depmod
}
post_upgrade() {
+ echo ">>> Removing duplicate compressed kernel modules"
+ for file in `find /lib/modules -name "*.ko"`; do if [[ -e $file.gz ]]; then rm "$file.gz"; fi; done
echo ">>> Running depmod..."
depmod
}
+post_remove() {
+ echo ">>> v4l-dvb has been removed"
+ echo ">>> kernel26 & linux-firmware should be reinstalled"
+}