summaryrefslogtreecommitdiffstats
path: root/abs/core/v86d
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-22 05:27:00 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-22 05:27:00 (GMT)
commit3d7f516c0b10ed95e270575ef6155d70c0c16114 (patch)
treebfcfd9635835309d06dfc6183849a6c4784ef252 /abs/core/v86d
parent6d47014ca768abe8852024b9bc4324d56e3e06c5 (diff)
downloadlinhes_pkgbuild-3d7f516c0b10ed95e270575ef6155d70c0c16114.zip
linhes_pkgbuild-3d7f516c0b10ed95e270575ef6155d70c0c16114.tar.gz
linhes_pkgbuild-3d7f516c0b10ed95e270575ef6155d70c0c16114.tar.bz2
v86d: first build, needed for plymouth
refs #869
Diffstat (limited to 'abs/core/v86d')
-rw-r--r--abs/core/v86d/PKGBUILD36
-rw-r--r--abs/core/v86d/modprobe.uvesafb10
-rw-r--r--abs/core/v86d/v86d14
-rw-r--r--abs/core/v86d/v86d_hook4
4 files changed, 64 insertions, 0 deletions
diff --git a/abs/core/v86d/PKGBUILD b/abs/core/v86d/PKGBUILD
new file mode 100644
index 0000000..13cc2eb
--- /dev/null
+++ b/abs/core/v86d/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 159626 2012-05-25 23:57:39Z dreisner $
+# Maintainer: Thomas Baechler <thomas@archlinux.org>
+
+pkgname=v86d
+pkgver=0.1.10
+pkgrel=4
+pkgdesc="userspace helper for uvesafb that runs x86 code in an emulated environment"
+arch=('i686' 'x86_64')
+url="http://dev.gentoo.org/~spock/projects/uvesafb/"
+license=('GPL2')
+depends=('glibc')
+options=('!makeflags')
+source=(http://dev.gentoo.org/~spock/projects/uvesafb/archive/v86d-$pkgver.tar.bz2
+ v86d
+ v86d_hook
+ modprobe.uvesafb)
+md5sums=('51c792ba7b874ad8c43f0d3da4cfabe0'
+ '66ab32602ab29cc5635eaac7f3e42283'
+ '5f75b8bc4a7ddf595014591e5db263cb'
+ '2d7cc8dc6a41916a13869212d0191147')
+
+build() {
+ cd "$srcdir/v86d-$pkgver"
+ ./configure --with-x86emu
+ # we only need /usr/include/video/uvesafb.h
+ make KDIR=/usr
+}
+
+package() {
+ cd "$srcdir/v86d-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ install -D -m644 "$srcdir/v86d" "$pkgdir/usr/lib/initcpio/install/v86d"
+ install -D -m644 "$srcdir/v86d_hook" "$pkgdir/usr/lib/initcpio/hooks/v86d"
+ install -D -m644 "$srcdir/modprobe.uvesafb" "$pkgdir/usr/lib/modprobe.d/uvesafb.conf"
+}
diff --git a/abs/core/v86d/modprobe.uvesafb b/abs/core/v86d/modprobe.uvesafb
new file mode 100644
index 0000000..5e46e10
--- /dev/null
+++ b/abs/core/v86d/modprobe.uvesafb
@@ -0,0 +1,10 @@
+#
+# This file sets the parameters for uvesafb module.
+# The following format should be used:
+# options uvesafb mode=<xres>x<yres>[-<bpp>][@<refresh>] scroll=<ywrap|ypan|redraw> ...
+#
+# For more details see:
+# http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob;f=Documentation/fb/uvesafb.txt
+#
+
+options uvesafb mode_option=1024x768-32 scroll=ywrap
diff --git a/abs/core/v86d/v86d b/abs/core/v86d/v86d
new file mode 100644
index 0000000..840b34e
--- /dev/null
+++ b/abs/core/v86d/v86d
@@ -0,0 +1,14 @@
+build() {
+ add_module 'uvesafb'
+
+ add_binary "v86d"
+ add_file "/usr/lib/modprobe.d/uvesafb.conf"
+
+ add_runscript
+}
+
+help() {
+ echo "This hook sets up v86d, the userspace helper for uvesafb."
+}
+
+# vim: set ft=sh ts=4 sw=4 expandtab:
diff --git a/abs/core/v86d/v86d_hook b/abs/core/v86d/v86d_hook
new file mode 100644
index 0000000..2b4375e
--- /dev/null
+++ b/abs/core/v86d/v86d_hook
@@ -0,0 +1,4 @@
+run_hook()
+{
+ /sbin/modprobe uvesafb
+}