summaryrefslogtreecommitdiffstats
path: root/abs/core/vdpauinfo
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:24:02 (GMT)
commitc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (patch)
treef4e4f7a91e1d9d90033fd99d89e5e26a2c144528 /abs/core/vdpauinfo
parent0e7b327a1ae444233f1308a95420f70540ad74a3 (diff)
downloadlinhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.zip
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.gz
linhes_pkgbuild-c4bd4457b5d640e1c8f5afbca7cd54c53691e5fc.tar.bz2
RSYNC CORE:
resync core-testing -> core Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/core/vdpauinfo')
-rw-r--r--abs/core/vdpauinfo/PKGBUILD24
-rw-r--r--abs/core/vdpauinfo/__changelog2
2 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/vdpauinfo/PKGBUILD b/abs/core/vdpauinfo/PKGBUILD
new file mode 100644
index 0000000..35e8419
--- /dev/null
+++ b/abs/core/vdpauinfo/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Nathan Harris
+pkgname=vdpauinfo
+pkgver=0.0.6
+pkgrel=5
+pkgdesc="NVIDIA VDPAU capability query utility"
+arch=('i686' 'x86_64')
+url="url=http://cgit.freedesktop.org/~aplattner/vdpauinfo"
+license=('custom')
+depends=('libvdpau' 'xorg-server')
+makedepends=('gcc' 'autoconf' 'make')
+optdepends=(nvidia-utils)
+install=()
+source=(http://cgit.freedesktop.org/~aplattner/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz)
+#md5sums=('d5aff9786b44ac5c70b5dd6faea37a67')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ autoreconf -i || return 1
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ install -D -m644 $srcdir/$pkgname-$pkgver/LICENSE $pkgdir/usr/share/licenses/$pkgname/license || return 1
+}
+md5sums=('9f9d387ab981b7a7e4460c70e7bab402')
diff --git a/abs/core/vdpauinfo/__changelog b/abs/core/vdpauinfo/__changelog
new file mode 100644
index 0000000..3acad6e
--- /dev/null
+++ b/abs/core/vdpauinfo/__changelog
@@ -0,0 +1,2 @@
+made nvidia-utils an optional dep. Otherwise this program could drag in the nividia drivers when we don't want them.
+