summaryrefslogtreecommitdiffstats
path: root/abs/core/vi/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-05 15:55:15 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-05 15:55:15 (GMT)
commit19fbfa9bb5a620d7e1b13a5977b5ea66ef3484da (patch)
treed7d356d6305d741e10bf0f3456442f5d331d87e0 /abs/core/vi/PKGBUILD
parent14513c73d75016aadb7217d3d7a23aa60406a92f (diff)
downloadlinhes_pkgbuild-19fbfa9bb5a620d7e1b13a5977b5ea66ef3484da.zip
linhes_pkgbuild-19fbfa9bb5a620d7e1b13a5977b5ea66ef3484da.tar.gz
linhes_pkgbuild-19fbfa9bb5a620d7e1b13a5977b5ea66ef3484da.tar.bz2
vi: replace vi with ex or true vi
ref #647
Diffstat (limited to 'abs/core/vi/PKGBUILD')
-rw-r--r--abs/core/vi/PKGBUILD99
1 files changed, 34 insertions, 65 deletions
diff --git a/abs/core/vi/PKGBUILD b/abs/core/vi/PKGBUILD
index b65cb93..83151a8 100644
--- a/abs/core/vi/PKGBUILD
+++ b/abs/core/vi/PKGBUILD
@@ -1,71 +1,40 @@
-# $Id: PKGBUILD 17437 2008-10-29 18:56:25Z tobias $
+# $Id: PKGBUILD 71573 2010-03-07 19:09:56Z paul $
# Maintainer: tobias [ tobias at archlinux org ]
pkgname=vi
-_srcver=7.2
-_patchlevel=148
-pkgver=${_srcver}.${_patchlevel}
+pkgver=050325
pkgrel=3
-pkgdesc="a highly configurable, improved version of the vi text editor (basic version)"
-arch=(i686 x86_64)
-license=('custom:vim')
-url="http://www.vim.org"
+pkgdesc='The original ex/vi text editor.'
+arch=('i686' 'x86_64')
+url='http://ex-vi.sourceforge.net/'
+license=('custom:ex')
+depends=('ncurses')
groups=('base')
-depends=('glibc' 'ncurses' 'coreutils')
-makedepends=('wget' 'sed' 'grep' 'gettext')
-backup=(etc/virc)
-install=${pkgname}.install
-# we need the extra-stuff to get all patches applied smoothly
-source=(ftp://ftp.vim.org/pub/vim/unix/vim-${_srcver}.tar.bz2 \
- ftp://ftp.vim.org/pub/vim/extra/vim-${_srcver}-extra.tar.gz \
- ftp://ftp.vim.org/pub/vim/extra/vim-${_srcver}-lang.tar.gz \
- fetch_patches.sh fetch_runtime.sh)
-
-build()
-{
- # pull in patches from vim.org (or the src cache alternatively)
- . ${startdir}/src/fetch_patches.sh
- . ${startdir}/src/fetch_runtime.sh
- get_patches || return 1
- cd ${startdir}/src/vim$(echo ${_srcver} | sed "s/\.//")
- # set the virc different from vimrc
- sed -i 's|^.*\(#define SYS_VIMRC_FILE.*"\) .*$|\1|' src/feature.h
- sed -i 's|^.*\(#define VIMRC_FILE.*"\) .*$|\1|' src/feature.h
- sed -i 's|^.*\(#define USR_VIMRC_FILE\t"\).*$|\1$HOME/.virc"|' src/feature.h
- sed -i 's|/etc/vimrc|/etc/virc|' src/feature.h
- sed -i 's|\.vimrc|.virc|' src/feature.h
- # build party
- ./configure --prefix=/usr --localstatedir=/var/lib/vim --mandir=/usr/share/man \
- --with-compiledby=ArchLinux --with-features=normal \
- --with-global-runtime=/usr/share/vim --with-vim-name=vi \
- --disable-gpm --disable-acl --with-x=no --disable-gui --enable-multibyte
- make || return 1
- make VIMRCLOC=/etc DESTDIR=${startdir}/pkg VIMRTDIR= install
- cd ${startdir}/pkg/usr/bin
- rm -f vim rvim view rview vidiff
- ln -s vi evi
-
- # delete the manpages for vidiff, we don't bother with that symlink since vidiff doesn't work
- find ${startdir}/pkg/usr/share/man -type d -name 'man1' 2> /dev/null | \
- while read mandir; do
- cd ${mandir}
- rm -f vidiff.1
- done
-
- _runtimedir="${startdir}/pkg/usr/share/vim/"
- update_runtime
- install -Dm644 ${startdir}/pkg/usr/share/vim/vimrc_example.vim \
- ${startdir}/pkg/etc/virc
- rm -f ${startdir}/pkg/usr/share/vim/gvimrc_example.vim
- install -dm755 ${startdir}/pkg/usr/share/licenses/vim
- cd ${startdir}/pkg/usr/share/licenses/vim
- ln -s ../../vim/doc/uganda.txt license.txt
-
-# Changes to remove mouse support VERY IMPORTANT!
- ########################################################################################
- sed -i "s/mouse=a/mouse-=a/g" $startdir/pkg/etc/virc
-
-
- ############################################################################
-
+options=(force strip !libtool emptydirs)
+source=(http://downloads.sourceforge.net/sourceforge/ex-vi/ex-${pkgver}.tar.bz2
+ navkeys.patch increase-tube.patch exrc.sample)
+md5sums=('e668595254233e4d96811083a3e4e2f3' 'aac133930047eafa4f28736cfaf976b3'
+ 'e596e05a00a24187b576e389fa1de45d' 'd3b483c994d859232ce369b82a4b5668')
+
+build() {
+ cd ${srcdir}/ex-${pkgver} || return 1
+
+ # apply patches
+ patch -Np1 -i ../navkeys.patch || return 1
+ patch -Np0 -i ../increase-tube.patch || return 1
+
+ # correct paths in manpages
+ sed -i -e 's/^\.B \/usr\/libexec/.B \/usr\/lib\/ex/' vi.1 \
+ || return 1
+ sed -i -e 's/^\.B \/var\/preserve$/.B \/var\/lib\/ex/' vi.1 \
+ || return 1
+
+ make PREFIX=/usr LIBEXECDIR=/usr/lib/ex PRESERVEDIR=/var/lib/ex \
+ 'FEATURES=-DCHDIR -DFASTTAG -DUCVISUAL -DMB -DBIT8' TERMLIB=ncurses \
+ || return 1
+ make PREFIX=/usr LIBEXECDIR=/usr/lib/ex PRESERVEDIR=/var/lib/ex INSTALL=/bin/install \
+ "DESTDIR=$pkgdir" install || return 1
+
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE \
+ || return 1
}