summaryrefslogtreecommitdiffstats
path: root/abs/core/vi
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-26 16:09:20 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-26 16:09:20 (GMT)
commit2e3526ac5a45e9318944c69d844cdf376ed7f255 (patch)
tree424a8b681273f0901dd78db2211cf3a829e196fb /abs/core/vi
parent5f2326da87033ebe199aa2b8af8ea39e09d5d4f0 (diff)
downloadlinhes_pkgbuild-2e3526ac5a45e9318944c69d844cdf376ed7f255.zip
linhes_pkgbuild-2e3526ac5a45e9318944c69d844cdf376ed7f255.tar.gz
linhes_pkgbuild-2e3526ac5a45e9318944c69d844cdf376ed7f255.tar.bz2
vi: update to 070224
Diffstat (limited to 'abs/core/vi')
-rw-r--r--abs/core/vi/PKGBUILD67
-rw-r--r--abs/core/vi/exrc.sample5
-rw-r--r--abs/core/vi/fix-tubesize-short-overflow.patch12
-rw-r--r--abs/core/vi/increase-tube.patch13
-rw-r--r--abs/core/vi/preserve-dir.patch (renamed from abs/core/vi/preserve_dir.patch)42
5 files changed, 78 insertions, 61 deletions
diff --git a/abs/core/vi/PKGBUILD b/abs/core/vi/PKGBUILD
index 0a5c7f8..9fa8028 100644
--- a/abs/core/vi/PKGBUILD
+++ b/abs/core/vi/PKGBUILD
@@ -1,47 +1,52 @@
-# $Id: PKGBUILD 160405 2012-06-01 18:35:53Z eric $
-# Maintainer: tobias [ tobias at archlinux org ]
+# $Id$
+# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
pkgname=vi
-pkgver=050325
+pkgver=070224
pkgrel=2
epoch=1
-pkgdesc='The original ex/vi text editor.'
-arch=('i686' 'x86_64')
-url='http://ex-vi.sourceforge.net/'
+pkgdesc="The original ex/vi text editor"
+arch=('x86_64')
+url="http://ex-vi.sourceforge.net/"
license=('custom:ex')
-depends=('ncurses')
-optdepends=('mailx: used by the preserve command for notification')
groups=('base')
-options=(strip !libtool emptydirs)
-source=(http://downloads.sourceforge.net/sourceforge/ex-vi/ex-${pkgver}.tar.bz2
- exrc.sample
+depends=('ncurses')
+optdepends=('s-nail: used by the preserve command for notification')
+source=(https://sources.archlinux.org/other/$pkgname/ex-$pkgver.tar.xz{,.sig}
+ fix-tubesize-short-overflow.patch
navkeys.patch
- increase-tube.patch
- preserve_dir.patch)
-md5sums=('e668595254233e4d96811083a3e4e2f3'
- 'd3b483c994d859232ce369b82a4b5668'
- 'aac133930047eafa4f28736cfaf976b3'
- 'e596e05a00a24187b576e389fa1de45d'
- '419a8755e0dd16e95542bc107e6d2b24')
+ preserve-dir.patch)
+sha256sums=('c3e52dd44edd1f6bf0b52207f717c56149dc50aac0d131fff3851d589727f52f'
+ 'SKIP'
+ '42167fabebe30a13d594346b1d254db82090ba41742a9f35b8895d37092053f0'
+ '0e9e2d381f1d8cb86daae68462b3849825b003c08007725c0db9939d3d5bf58d'
+ 'f0ef9ed2ccea98bf47b08dd3faa2abb911b4e6c0579f5294e9d0e8742282ff65')
+validpgpkeys=('86CFFCA918CF3AF47147588051E8B148A9999C34')
-build() {
- cd "${srcdir}/ex-${pkgver}"
+prepare() {
+ cd ex-$pkgver
+
+ patch -Np1 -i ../fix-tubesize-short-overflow.patch
+ patch -Np1 -i ../navkeys.patch
+
+ # https://bugs.archlinux.org/task/20653
+ patch -Np1 -i ../preserve-dir.patch
+}
- # apply patches
- patch -Np1 -i ../navkeys.patch
- patch -Np0 -i ../increase-tube.patch
- # FS#20653
- patch -Np1 -i ../preserve_dir.patch
+build() {
+ cd ex-$pkgver
make PREFIX=/usr LIBEXECDIR=/usr/lib/ex PRESERVEDIR=/var/lib/ex \
- 'FEATURES=-DCHDIR -DFASTTAG -DUCVISUAL -DMB -DBIT8' TERMLIB=ncurses
+ TERMLIB=ncurses FEATURES="-DCHDIR -DFASTTAG -DUCVISUAL -DMB -DBIT8"
}
package() {
- cd "${srcdir}/ex-${pkgver}"
-
- make PREFIX=/usr LIBEXECDIR=/usr/lib/ex PRESERVEDIR=/var/lib/ex INSTALL=/usr/bin/install \
- DESTDIR="$pkgdir" install
+ cd ex-$pkgver
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ make PREFIX=/usr LIBEXECDIR=/usr/lib/ex PRESERVEDIR=/var/lib/ex \
+ INSTALL=/usr/bin/install DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core/vi/exrc.sample b/abs/core/vi/exrc.sample
deleted file mode 100644
index 44b3045..0000000
--- a/abs/core/vi/exrc.sample
+++ /dev/null
@@ -1,5 +0,0 @@
-" A sample .exrc file. Copy it to your home dir as ~/.exrc in order to work.
-set showmode
-set noflash
-set autoindent
-set shiftwidth=2
diff --git a/abs/core/vi/fix-tubesize-short-overflow.patch b/abs/core/vi/fix-tubesize-short-overflow.patch
new file mode 100644
index 0000000..46cc2af
--- /dev/null
+++ b/abs/core/vi/fix-tubesize-short-overflow.patch
@@ -0,0 +1,12 @@
+diff -upr ex-070224.orig/ex_vis.h ex-070224/ex_vis.h
+--- ex-070224.orig/ex_vis.h 2005-08-06 14:41:15.000000000 +0300
++++ ex-070224/ex_vis.h 2015-05-02 20:41:13.938665281 +0300
+@@ -104,7 +104,7 @@ var enum {
+ */
+ var short TUBELINES;
+ var short TUBECOLS;
+-var short TUBESIZE;
++var int TUBESIZE;
+
+ /*
+ * The screen in visual and crtopen is of varying size; the basic
diff --git a/abs/core/vi/increase-tube.patch b/abs/core/vi/increase-tube.patch
deleted file mode 100644
index 5010798..0000000
--- a/abs/core/vi/increase-tube.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- config.h 2005-02-19 05:25:39.000000000 -0500
-+++ config.h.fixed 2010-01-04 22:02:01.000000000 -0500
-@@ -95,8 +95,8 @@
- #define TUBESIZE 6000 /* Maximum screen size for visual */
- #else /* VMUNIX */
- #define TUBELINES 100
--#define TUBECOLS 160
--#define TUBESIZE 16000
-+#define TUBECOLS 320
-+#define TUBESIZE 32000
- #endif /* VMUNIX */
-
- /*
diff --git a/abs/core/vi/preserve_dir.patch b/abs/core/vi/preserve-dir.patch
index 5209f7b..ddfe878 100644
--- a/abs/core/vi/preserve_dir.patch
+++ b/abs/core/vi/preserve-dir.patch
@@ -43,18 +43,6 @@ diff -Naur ex-050325.ori/exrecover.c ex-050325/exrecover.c
#endif
/*
-diff -Naur ex-050325.ori/ex.spec ex-050325/ex.spec
---- ex-050325.ori/ex.spec 2005-03-24 18:50:09.000000000 -0500
-+++ ex-050325/ex.spec 2011-02-01 16:21:51.496666674 -0500
-@@ -20,7 +20,7 @@
- %define libexecdir %{prefix}/5lib
- %define mandir %{prefix}/share/man/5man
-
--%define preservedir /var/preserve
-+%define preservedir /var/lib/ex
-
- # install command
- %define ucbinstall install
diff -Naur ex-050325.ori/Makefile ex-050325/Makefile
--- ex-050325.ori/Makefile 2005-03-24 18:50:09.000000000 -0500
+++ ex-050325/Makefile 2011-02-01 16:21:51.496666674 -0500
@@ -79,3 +67,33 @@ diff -Naur ex-050325.ori/vi.1 ex-050325/vi.1
preservation directory
.SH SEE ALSO
ex(1),
+--- ex-050325.original/ex.1 2012-01-27 20:43:00.602119283 +0100
++++ ex-050325/ex.1 2012-01-27 20:47:24.535436516 +0100
+@@ -1932,10 +1932,10 @@
+ Determines the terminal type.
+ .SH FILES
+ .TP
+-.B /usr/libexec/expreserve
++.B /usr/lib/ex/expreserve
+ preserve command
+ .TP
+-.B /usr/libexec/exrecover
++.B /usr/lib/ex/exrecover
+ recover command
+ .TP
+ .B /etc/termcap
+--- ex-050325.original/vi.1 2012-01-27 20:43:00.602119283 +0100
++++ ex-050325/vi.1 2012-01-27 20:46:33.815439611 +0100
+@@ -961,10 +961,10 @@
+ Determines the terminal type.
+ .SH FILES
+ .TP
+-.B /usr/libexec/expreserve
++.B /usr/lib/ex/expreserve
+ preserve command
+ .TP
+-.B /usr/libexec/exrecover
++.B /usr/lib/ex/exrecover
+ recover command
+ .TP
+ .B /etc/termcap