summaryrefslogtreecommitdiffstats
path: root/abs/core/wget/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-10-30 20:55:14 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-10-30 20:55:14 (GMT)
commit974aec228ad6f6b9533d922ab8434c32f234787a (patch)
tree1a7b58b0b7f9c3b9bcbf750867b9a2e8f63f5882 /abs/core/wget/PKGBUILD
parent6d45a0bad38f13b2dabf094ebd27736fb9fdcd4f (diff)
downloadlinhes_pkgbuild-974aec228ad6f6b9533d922ab8434c32f234787a.zip
linhes_pkgbuild-974aec228ad6f6b9533d922ab8434c32f234787a.tar.gz
linhes_pkgbuild-974aec228ad6f6b9533d922ab8434c32f234787a.tar.bz2
wget: update to 1.16
Diffstat (limited to 'abs/core/wget/PKGBUILD')
-rw-r--r--abs/core/wget/PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/abs/core/wget/PKGBUILD b/abs/core/wget/PKGBUILD
index d218e4e..c531535 100644
--- a/abs/core/wget/PKGBUILD
+++ b/abs/core/wget/PKGBUILD
@@ -2,23 +2,28 @@
# Maintainer: Eric BĂ©langer <eric@archlinux.org>
pkgname=wget
-pkgver=1.15
-pkgrel=1
+pkgver=1.16
+pkgrel=2
pkgdesc="A network utility to retrieve files from the Web"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/wget/wget.html"
license=('GPL3')
-depends=('openssl' 'libidn' 'util-linux')
-checkdepends=('perl-http-daemon' 'perl-io-socket-ssl')
+depends=('openssl' 'libidn' 'libutil-linux')
+checkdepends=('perl-http-daemon' 'perl-io-socket-ssl' 'python')
optdepends=('ca-certificates: HTTPS downloads')
backup=('etc/wgetrc')
install=wget.install
-source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.sig})
-sha1sums=('e9fb1d25fa04f9c69e74e656a3174dca02700ba1'
- 'SKIP')
+source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.sig}
+ wget-1.16-fix-test-proxied-https-auth.patch)
+sha1sums=('08d991acc80726abe57043a278f9da469c454503'
+ 'SKIP'
+ 'a324d1910a6440552a3745c873da9e3dff7d7ec9')
prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-${pkgver}
+ patch -p1 -i "${srcdir}/wget-1.16-fix-test-proxied-https-auth.patch"
+ sed -i 's/--no-check-certificate/& --no-http-keep-alive/' \
+ tests/Test-proxied-https-auth.px
cat >> doc/sample.wgetrc <<EOF
# default root certs location