summaryrefslogtreecommitdiffstats
path: root/abs/core/wget
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-07 15:04:22 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-07 15:04:22 (GMT)
commit37ac848c79d400adba788a443e2a8650079dfe90 (patch)
tree53557b00b49f23b200222cee72944a4d1df6851c /abs/core/wget
parentf57e45a739947313f9809cafdee59837437a4fac (diff)
downloadlinhes_pkgbuild-37ac848c79d400adba788a443e2a8650079dfe90.zip
linhes_pkgbuild-37ac848c79d400adba788a443e2a8650079dfe90.tar.gz
linhes_pkgbuild-37ac848c79d400adba788a443e2a8650079dfe90.tar.bz2
wget 1.14
Diffstat (limited to 'abs/core/wget')
-rw-r--r--abs/core/wget/PKGBUILD26
-rw-r--r--abs/core/wget/__changelog2
2 files changed, 8 insertions, 20 deletions
diff --git a/abs/core/wget/PKGBUILD b/abs/core/wget/PKGBUILD
index 4258f04..9b12440 100644
--- a/abs/core/wget/PKGBUILD
+++ b/abs/core/wget/PKGBUILD
@@ -1,37 +1,31 @@
-# $Id: PKGBUILD 138218 2011-09-19 05:03:16Z allan $
+# $Id: PKGBUILD 169712 2012-10-27 01:52:51Z stephane $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: Judd Vinet <jvinet@zeroflux.org>
pkgname=wget
-pkgver=1.13.4
-pkgrel=1
+pkgver=1.14
+pkgrel=2
pkgdesc="A network utility to retrieve files from the Web"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/wget/wget.html"
license=('GPL3')
-groups=('base')
-depends=('glibc' 'openssl')
+depends=('openssl' 'libidn' 'pcre' 'util-linux')
optdepends=('ca-certificates: HTTPS downloads')
backup=('etc/wgetrc')
install=wget.install
-source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz)
-md5sums=('7f518b3a71e9efd330e9a0c3714f8463')
+source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.sig})
+md5sums=('316f6f59292c9098ad81fd54f658c579'
+ '3e121933d69f32fa58776bff76bcebd0')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- sed -i '/gets is a security hole/d' lib/stdio.in.h
- # Note : We do not build with --enable-nls, because there is a bug in wget causing
- # international domain names to be not properly converted to punycode if
- # the current locale is a UTF-8 one
- # See : http://lists.gnu.org/archive/html/bug-wget/2011-02/msg00026.html
- ./configure -with-ssl=openssl --prefix=/usr --sysconfdir=/etc
+ ./configure -with-ssl=openssl --prefix=/usr --sysconfdir=/etc --enable-nls
make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
make DESTDIR="${pkgdir}" install
cat >> "$pkgdir/etc/wgetrc" <<EOF
@@ -39,8 +33,4 @@ package() {
# default root certs location
ca_certificate=/etc/ssl/certs/ca-certificates.crt
EOF
-
- # remove IRI option from wgetrc as it does not work (see above)
- sed -i '118,120d' $pkgdir/etc/wgetrc
-
}
diff --git a/abs/core/wget/__changelog b/abs/core/wget/__changelog
deleted file mode 100644
index 55fb64e..0000000
--- a/abs/core/wget/__changelog
+++ /dev/null
@@ -1,2 +0,0 @@
-sed -i '/gets is a security hole/d' \
- gettext-{runtime/gnulib-lib,tools/{gnulib-lib,libgettextpo}}/stdio.in.h