summaryrefslogtreecommitdiffstats
path: root/abs/core/wget
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-06 00:00:00 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-06 00:00:00 (GMT)
commit8821f4948b460a8b5a4921ea45b5c9b450968022 (patch)
treed0ce1f659a4c5a71156caaa895713254451d86a5 /abs/core/wget
parent7285402be560de434c47278d3c6889db2cffdfab (diff)
downloadlinhes_pkgbuild-8821f4948b460a8b5a4921ea45b5c9b450968022.zip
linhes_pkgbuild-8821f4948b460a8b5a4921ea45b5c9b450968022.tar.gz
linhes_pkgbuild-8821f4948b460a8b5a4921ea45b5c9b450968022.tar.bz2
wget: update to 1.15
Diffstat (limited to 'abs/core/wget')
-rw-r--r--abs/core/wget/PKGBUILD41
1 files changed, 24 insertions, 17 deletions
diff --git a/abs/core/wget/PKGBUILD b/abs/core/wget/PKGBUILD
index 9b12440..d218e4e 100644
--- a/abs/core/wget/PKGBUILD
+++ b/abs/core/wget/PKGBUILD
@@ -1,36 +1,43 @@
-# $Id: PKGBUILD 169712 2012-10-27 01:52:51Z stephane $
-# Maintainer: Allan McRae <allan@archlinux.org>
-# Contributor: Judd Vinet <jvinet@zeroflux.org>
+# $Id$
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
pkgname=wget
-pkgver=1.14
-pkgrel=2
+pkgver=1.15
+pkgrel=1
pkgdesc="A network utility to retrieve files from the Web"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/wget/wget.html"
license=('GPL3')
-depends=('openssl' 'libidn' 'pcre' 'util-linux')
+depends=('openssl' 'libidn' 'util-linux')
+checkdepends=('perl-http-daemon' 'perl-io-socket-ssl')
optdepends=('ca-certificates: HTTPS downloads')
backup=('etc/wgetrc')
install=wget.install
source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.sig})
-md5sums=('316f6f59292c9098ad81fd54f658c579'
- '3e121933d69f32fa58776bff76bcebd0')
+sha1sums=('e9fb1d25fa04f9c69e74e656a3174dca02700ba1'
+ 'SKIP')
-build() {
+prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ cat >> doc/sample.wgetrc <<EOF
+
+# default root certs location
+ca_certificate=/etc/ssl/certs/ca-certificates.crt
+EOF
+}
- ./configure -with-ssl=openssl --prefix=/usr --sysconfdir=/etc --enable-nls
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-nls --with-ssl=openssl
make
}
+check() {
+ cd ${pkgname}-${pkgver}
+ make check
+}
+
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
-
- cat >> "$pkgdir/etc/wgetrc" <<EOF
-
-# default root certs location
-ca_certificate=/etc/ssl/certs/ca-certificates.crt
-EOF
}