summaryrefslogtreecommitdiffstats
path: root/abs/core/wget
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/wget
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/wget')
-rw-r--r--abs/core/wget/PKGBUILD20
l---------abs/core/wget/wget-1.12-2-i686.pkg.tar.gz1
-rw-r--r--abs/core/wget/wget.install20
3 files changed, 35 insertions, 6 deletions
diff --git a/abs/core/wget/PKGBUILD b/abs/core/wget/PKGBUILD
index 5a9e0cb..1ef6911 100644
--- a/abs/core/wget/PKGBUILD
+++ b/abs/core/wget/PKGBUILD
@@ -1,21 +1,29 @@
-# $Id: PKGBUILD 4756 2008-07-09 20:00:54Z andyrtr $
-# Maintainer: Judd Vinet <jvinet@zeroflux.org>
+# $Id: PKGBUILD 75183 2010-04-01 01:40:17Z pierre $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
pkgname=wget
-pkgver=1.11.4
-pkgrel=10
+pkgver=1.12
+pkgrel=2
pkgdesc="A network utility to retrieve files from the Web"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://www.gnu.org/software/wget/wget.html"
license=('GPL3')
groups=('base')
depends=('glibc' 'openssl')
+optdepends=('ca-certificates: HTTPS downloads')
backup=('etc/wgetrc')
+install=wget.install
source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('69e8a7296c0e12c53bd9ffd786462e87')
+md5sums=('141461b9c04e454dc8933c9d1f2abf83')
build() {
cd ${srcdir}/$pkgname-$pkgver
./configure --prefix=/usr --sysconfdir=/etc
make || return 1
+}
+
+package() {
+ cd ${srcdir}/$pkgname-$pkgver
make DESTDIR=${pkgdir} install
}
diff --git a/abs/core/wget/wget-1.12-2-i686.pkg.tar.gz b/abs/core/wget/wget-1.12-2-i686.pkg.tar.gz
new file mode 120000
index 0000000..6fc2266
--- /dev/null
+++ b/abs/core/wget/wget-1.12-2-i686.pkg.tar.gz
@@ -0,0 +1 @@
+/data/pkg_repo/packages/wget-1.12-2-i686.pkg.tar.gz \ No newline at end of file
diff --git a/abs/core/wget/wget.install b/abs/core/wget/wget.install
new file mode 100644
index 0000000..1715333
--- /dev/null
+++ b/abs/core/wget/wget.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(wget.info)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}