summaryrefslogtreecommitdiffstats
path: root/abs/core/which
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-11-23 16:38:44 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-11-23 16:38:44 (GMT)
commit55e4254a334f68d02416baa99285d7afe5bba209 (patch)
treec2b940ea86fe967f7f41fee3ce956257a56e4226 /abs/core/which
parentef8611ed6b769602e7264a4455d7f18cec95b235 (diff)
downloadlinhes_pkgbuild-55e4254a334f68d02416baa99285d7afe5bba209.zip
linhes_pkgbuild-55e4254a334f68d02416baa99285d7afe5bba209.tar.gz
linhes_pkgbuild-55e4254a334f68d02416baa99285d7afe5bba209.tar.bz2
which: update to 2.21
Diffstat (limited to 'abs/core/which')
-rw-r--r--abs/core/which/PKGBUILD32
-rw-r--r--abs/core/which/which.install20
2 files changed, 18 insertions, 34 deletions
diff --git a/abs/core/which/PKGBUILD b/abs/core/which/PKGBUILD
index 65495fe..3df51e9 100644
--- a/abs/core/which/PKGBUILD
+++ b/abs/core/which/PKGBUILD
@@ -1,27 +1,31 @@
-# $Id: PKGBUILD 142082 2011-11-04 23:36:20Z allan $
-# Maintainer: Allan McRae <allan@archlinux.org>
+# $Id$
+# Maintainer: Sébastien Luttringer <seblu@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: Andreas Radke <andyrtr@archlinux.org>
pkgname=which
-pkgver=2.20
-pkgrel=5
-pkgdesc="A utility to show the full path of commands"
+pkgver=2.21
+pkgrel=2
+pkgdesc='A utility to show the full path of commands'
arch=('i686' 'x86_64')
-url="http://www.xs4all.nl/~carlo17/which"
+url='https://savannah.gnu.org/projects/which/'
license=('GPL3')
-groups=('base')
-depends=('glibc' 'sh')
-install=which.install
-source=(http://www.xs4all.nl/~carlo17/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('95be0501a466e515422cde4af46b2744')
+groups=('base' 'base-devel')
+depends=('glibc' 'bash')
+# gpg key is using deprecated md5 algo, do not use
+# check if a new one is issued in the next release
+source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('097ff1a324ae02e0a3b0369f07a7544a')
build() {
- cd $srcdir/$pkgname-$pkgver
+ cd $pkgname-$pkgver
./configure --prefix=/usr
make
}
package() {
- cd $srcdir/$pkgname-$pkgver
- make DESTDIR=$pkgdir install
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core/which/which.install b/abs/core/which/which.install
deleted file mode 100644
index 167e250..0000000
--- a/abs/core/which/which.install
+++ /dev/null
@@ -1,20 +0,0 @@
-infodir=/usr/share/info
-filelist=(which.info)
-
-post_install() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- install-info $infodir/$file.gz $infodir/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- install-info --delete $infodir/$file $infodir/dir 2> /dev/null
- done
-}