summaryrefslogtreecommitdiffstats
path: root/abs/core/windowmaker-crm-git/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-06 18:47:39 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-06 18:47:39 (GMT)
commitc534b905d2331ed62fd0c0d4766d54fc987f372d (patch)
tree635fffc28af265d5407038e76496cccc26d38f28 /abs/core/windowmaker-crm-git/PKGBUILD
parentb8bc491c0d660f003071d9be40eb4a01405d1bca (diff)
downloadlinhes_pkgbuild-c534b905d2331ed62fd0c0d4766d54fc987f372d.zip
linhes_pkgbuild-c534b905d2331ed62fd0c0d4766d54fc987f372d.tar.gz
linhes_pkgbuild-c534b905d2331ed62fd0c0d4766d54fc987f372d.tar.bz2
windowmaker: move to core, needed for the program wmsetbg
Diffstat (limited to 'abs/core/windowmaker-crm-git/PKGBUILD')
-rw-r--r--abs/core/windowmaker-crm-git/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/core/windowmaker-crm-git/PKGBUILD b/abs/core/windowmaker-crm-git/PKGBUILD
new file mode 100644
index 0000000..6a47895
--- /dev/null
+++ b/abs/core/windowmaker-crm-git/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 94218 2010-10-05 16:33:23Z daniel $
+# Maintainer: Daniel Isenmann <daniel@archlinux.org>
+
+pkgname=windowmaker-crm-git
+pkgver=20101005
+pkgrel=1
+pkgdesc="An X11 window manager with a NEXTSTEP look and feel - git version from Carlos R. Mafra"
+arch=(i686 x86_64)
+url="http://www.windowmaker.org"
+license=('GPL' 'custom')
+depends=('libxinerama' 'libxrandr' 'libpng' 'libxpm' 'libxft' 'libtiff>=3.9.1' 'giflib' 'libxmu')
+options=('!libtool')
+provides=('windowmaker')
+conflicts=('windowmaker')
+source=(ftp://ftp.archlinux.org/other/windowmaker/windowmaker-$pkgver.tar.gz wmaker.desktop)
+md5sums=('8cc7e736a8d7e446f696b80fc7dcb79c'
+ '2fba97bebfd691836b92b8f0db79ff13')
+
+build() {
+ cd $srcdir/windowmaker-$pkgver
+ [ -z "$LINGUAS" ] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`"
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-xinerama \
+ --with-nlsdir=/usr/share/locale --with-gnustepdir=/usr/lib/GNUstep \
+ --enable-usermenu --enable-modelock
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+ install -D -m644 COPYING.WTFPL $pkgdir/usr/share/licenses/$pkgname/COPYING.WTFPL
+ install -D -m644 $srcdir/wmaker.desktop $pkgdir/usr/share/xsessions/wmaker.desktop
+}