summaryrefslogtreecommitdiffstats
path: root/abs/core/wpa_supplicant
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/wpa_supplicant
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/wpa_supplicant')
-rw-r--r--abs/core/wpa_supplicant/PKGBUILD52
-rw-r--r--abs/core/wpa_supplicant/config148
-rw-r--r--abs/core/wpa_supplicant/wpa_supplicant.install15
3 files changed, 140 insertions, 75 deletions
diff --git a/abs/core/wpa_supplicant/PKGBUILD b/abs/core/wpa_supplicant/PKGBUILD
index 2f022ce..3ecc4a8 100644
--- a/abs/core/wpa_supplicant/PKGBUILD
+++ b/abs/core/wpa_supplicant/PKGBUILD
@@ -1,36 +1,42 @@
-# Contributor: iztok pizorn <pizorn@gmail.com>
-# Contributor: William Rea <sillywilly@gmail.com>
+# $Id: PKGBUILD 32196 2009-03-29 14:55:53Z thomas $
+# Maintainer: Thomas Baechler <thomas@archlinux.org>
+
pkgname=wpa_supplicant
-pkgver=0.5.10
-_madwifi_ver=0.9.4
-pkgrel=10
+pkgver=0.6.9
+#_madwifi_ver=0.9.4
+pkgrel=1
pkgdesc="A utility providing key negotiation for WPA wireless networks"
arch=('i686' 'x86_64')
-makedepends=('kernel26>=2.6.24' 'kernel26<=2.6.26.3')
-depends=('openssl')
+depends=('openssl' 'dbus-core>=1.2.4' 'readline' 'libnl')
+optdepends=('wpa_supplicant_gui: wpa_gui program')
license=('GPL')
groups=('base')
backup=('etc/wpa_supplicant.conf')
url="http://hostap.epitest.fi/wpa_supplicant"
source=(http://hostap.epitest.fi/releases/wpa_supplicant-$pkgver.tar.gz
- config
- http://downloads.sourceforge.net/sourceforge/madwifi/madwifi-${_madwifi_ver}.tar.gz)
-install='wpa_supplicant.install'
-md5sums=('9e7b99da67c47d81121368c6d580d069'
- '87a7bb38e0b4820b29065a9b3e8f4e06'
- '399d20de8d855a59f20058857c2178ad')
+ config)
+ #http://downloads.sourceforge.net/sourceforge/madwifi/madwifi-${_madwifi_ver}.tar.gz)
+md5sums=('0efb8fcedf0a8acf6f423dfdb0658fdd'
+ 'd472554904cca44e1090e25dea7b03c9')
+ #'399d20de8d855a59f20058857c2178ad')
build() {
- cd ${startdir}/src/
- mv madwifi-${_madwifi_ver} madwifi
- cd $startdir/src/$pkgname-$pkgver
- cp ../config ./.config
+ cd "${srcdir}"
+ #mv madwifi-${_madwifi_ver} madwifi
+ cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
+ cp ${srcdir}/config ./.config
sed -i 's@/usr/local@$(PREFIX)@g' Makefile
- sed -i 's@dynamic_eap_methods@@g' Makefile
make || return 1
- make PREFIX=/usr DESTDIR=$startdir/pkg install || return 1
- install -D -m644 wpa_supplicant.conf $startdir/pkg/etc/wpa_supplicant.conf || return 1
- install -d -m755 $startdir/pkg/usr/man/man{5,8} || return 1
- install -m644 doc/docbook/wpa_supplicant.conf.5 $startdir/pkg/usr/man/man5 || return 1
- install -m644 doc/docbook/{wpa_background,wpa_cli,wpa_passphrase,wpa_supplicant}.8 $startdir/pkg/usr/man/man8 || return 1
+ make PREFIX=/usr DESTDIR="${pkgdir}" install || return 1
+ install -m755 -d "${pkgdir}/etc"
+ install -m644 wpa_supplicant.conf "${pkgdir}/etc/wpa_supplicant.conf" || return 1
+ install -d -m755 ${pkgdir}/usr/share/man/man{5,8} || return 1
+ install -m644 doc/docbook/wpa_supplicant.conf.5 "${pkgdir}/usr/share/man/man5/" || return 1
+ install -m644 doc/docbook/{wpa_background,wpa_cli,wpa_passphrase,wpa_supplicant}.8 "${pkgdir}/usr/share/man/man8/" || return 1
+
+ install -m755 -d "${pkgdir}/usr/share/dbus-1/system-services"
+ install -m644 dbus-wpa_supplicant.service "${pkgdir}/usr/share/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service" || return 1
+ sed -e 's/sbin/usr\/sbin/' -i "${pkgdir}/usr/share/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service" || return 1
+ install -m755 -d "${pkgdir}/etc/dbus-1/system.d"
+ install -m644 dbus-wpa_supplicant.conf "${pkgdir}/etc/dbus-1/system.d/fi.epitest.hostap.WPASupplicant.conf" || return 1
}
diff --git a/abs/core/wpa_supplicant/config b/abs/core/wpa_supplicant/config
index 8841fe3..e3582bf 100644
--- a/abs/core/wpa_supplicant/config
+++ b/abs/core/wpa_supplicant/config
@@ -41,7 +41,7 @@
# Driver interface for Host AP driver
-CONFIG_DRIVER_HOSTAP=y
+#CONFIG_DRIVER_HOSTAP=y
# Driver interface for Agere driver
#CONFIG_DRIVER_HERMES=y
@@ -50,14 +50,14 @@ CONFIG_DRIVER_HOSTAP=y
#CFLAGS += -I../../include/wireless
# Driver interface for madwifi driver
-CONFIG_DRIVER_MADWIFI=y
-# Change include directories to match with the local setup
-CFLAGS += -I../madwifi
+#CONFIG_DRIVER_MADWIFI=y
+# Set include directory to the madwifi source tree
+#CFLAGS += -I../../madwifi
# Driver interface for Prism54 driver
# (Note: Prism54 is not yet supported, i.e., this will not work as-is and is
# for developers only)
-CONFIG_DRIVER_PRISM54=y
+#CONFIG_DRIVER_PRISM54=y
# Driver interface for ndiswrapper
CONFIG_DRIVER_NDISWRAPPER=y
@@ -65,17 +65,26 @@ CONFIG_DRIVER_NDISWRAPPER=y
# Driver interface for Atmel driver
CONFIG_DRIVER_ATMEL=y
-# Driver interface for Broadcom driver
+# Driver interface for old Broadcom driver
+# Please note that the newer Broadcom driver ("hybrid Linux driver") supports
+# Linux wireless extensions and does not need (or even work) with the old
+# driver wrapper. Use CONFIG_DRIVER_WEXT=y with that driver.
#CONFIG_DRIVER_BROADCOM=y
# Example path for wlioctl.h; change to match your configuration
#CFLAGS += -I/opt/WRT54GS/release/src/include
# Driver interface for Intel ipw2100/2200 driver
-CONFIG_DRIVER_IPW=y
+#CONFIG_DRIVER_IPW=y
+
+# Driver interface for Ralink driver
+#CONFIG_DRIVER_RALINK=y
# Driver interface for generic Linux wireless extensions
CONFIG_DRIVER_WEXT=y
+# Driver interface for Linux drivers using the nl80211 kernel interface
+CONFIG_DRIVER_NL80211=y
+
# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
#CONFIG_DRIVER_BSD=y
#CFLAGS += -I/usr/local/include
@@ -103,6 +112,9 @@ CONFIG_DRIVER_WEXT=y
# Driver interface for wired Ethernet drivers
CONFIG_DRIVER_WIRED=y
+# Driver interface for the Broadcom RoboSwitch family
+#CONFIG_DRIVER_ROBOSWITCH=y
+
# Enable IEEE 802.1X Supplicant (automatically included if any EAP method is
# included)
CONFIG_IEEE8021X_EAPOL=y
@@ -122,6 +134,13 @@ CONFIG_EAP_PEAP=y
# EAP-TTLS
CONFIG_EAP_TTLS=y
+# EAP-FAST
+# Note: Default OpenSSL package does not include support for all the
+# functionality needed for EAP-FAST. If EAP-FAST is enabled with OpenSSL,
+# the OpenSSL library must be patched (openssl-0.9.8d-tls-extensions.patch)
+# to add the needed functions.
+#CONFIG_EAP_FAST=y
+
# EAP-GTC
CONFIG_EAP_GTC=y
@@ -143,6 +162,13 @@ CONFIG_EAP_LEAP=y
# EAP-AKA (enable CONFIG_PCSC, if EAP-AKA is used)
#CONFIG_EAP_AKA=y
+# EAP-AKA' (enable CONFIG_PCSC, if EAP-AKA' is used).
+# This requires CONFIG_EAP_AKA to be enabled, too.
+#CONFIG_EAP_AKA_PRIME=y
+
+# Enable USIM simulator (Milenage) for EAP-AKA
+#CONFIG_USIM_SIMULATOR=y
+
# EAP-SAKE
#CONFIG_EAP_SAKE=y
@@ -151,6 +177,15 @@ CONFIG_EAP_LEAP=y
# Include support for optional SHA256 cipher suite in EAP-GPSK
#CONFIG_EAP_GPSK_SHA256=y
+# EAP-TNC and related Trusted Network Connect support (experimental)
+#CONFIG_EAP_TNC=y
+
+# Wi-Fi Protected Setup (WPS)
+CONFIG_WPS=y
+
+# EAP-IKEv2
+#CONFIG_EAP_IKEV2=y
+
# PKCS#12 (PFX) support (used to read private key and certificate file from
# a file that usually has extension .p12 or .pfx)
CONFIG_PKCS12=y
@@ -166,13 +201,10 @@ CONFIG_SMARTCARD=y
# Development testing
#CONFIG_EAPOL_TEST=y
-# Replace native Linux implementation of packet sockets with libdnet/libpcap.
-# This will be automatically set for non-Linux OS.
-#CONFIG_DNET_PCAP=y
-
# Select control interface backend for external programs, e.g, wpa_cli:
# unix = UNIX domain sockets (default for Linux/*BSD)
-# udp = UDP sockets (default for Windows)
+# udp = UDP sockets using localhost (127.0.0.1)
+# named_pipe = Windows Named Pipe (default for Windows)
# y = use default (backwards compatibility)
# If this option is commented out, control interface is not included in the
# build.
@@ -182,7 +214,7 @@ CONFIG_CTRL_IFACE=y
# When building a wpa_cli binary for distribution, please note that these
# libraries are licensed under GPL and as such, BSD license may not apply for
# the resulting binary.
-#CONFIG_READLINE=y
+CONFIG_READLINE=y
# Remove debugging code that is printing out debug message to stdout.
# This can be used to reduce the size of the wpa_supplicant considerably
@@ -199,16 +231,39 @@ CONFIG_CTRL_IFACE=y
# or 6 kB if building for WPA-Enterprise.
#CONFIG_NO_WPA2=y
+# Remove IEEE 802.11i/WPA-Personal ASCII passphrase support
+# This option can be used to reduce code size by removing support for
+# converting ASCII passphrases into PSK. If this functionality is removed, the
+# PSK can only be configured as the 64-octet hexstring (e.g., from
+# wpa_passphrase). This saves about 0.5 kB in code size.
+#CONFIG_NO_WPA_PASSPHRASE=y
+
# Remove AES extra functions. This can be used to reduce code size by about
# 1.5 kB by removing extra AES modes that are not needed for commonly used
# client configurations (they are needed for some EAP types).
#CONFIG_NO_AES_EXTRAS=y
+# Disable scan result processing (ap_mode=1) to save code size by about 1 kB.
+# This can be used if ap_scan=1 mode is never enabled.
+#CONFIG_NO_SCAN_PROCESSING=y
+
# Select configuration backend:
-# file = text file (e.g., wpa_supplicant.conf)
+# file = text file (e.g., wpa_supplicant.conf; note: the configuration file
+# path is given on command line, not here; this option is just used to
+# select the backend that allows configuration files to be used)
# winreg = Windows registry (see win_example.reg for an example)
CONFIG_BACKEND=file
+# Remove configuration write functionality (i.e., to allow the configuration
+# file to be updated based on runtime configuration changes). The runtime
+# configuration can still be changed, the changes are just not going to be
+# persistent over restarts. This option can be used to reduce code size by
+# about 3.5 kB.
+#CONFIG_NO_CONFIG_WRITE=y
+
+# Remove support for configuration blobs to reduce code size by about 1.5 kB.
+#CONFIG_NO_CONFIG_BLOBS=y
+
# Select program entry point implementation:
# main = UNIX/POSIX like main() function (default)
# main_winsvc = Windows service (read parameters from registry)
@@ -236,13 +291,15 @@ CONFIG_BACKEND=file
# none = Empty template
#CONFIG_L2_PACKET=linux
-# IEEE 802.11i/IEEE 802.11e STAKey negotiation for direct link connection
-#CONFIG_STAKEY=y
-
-# Proposed replacement for STAKey negotiation: PeerKey handshake for
-# Station to Station Link
+# PeerKey handshake for Station to Station Link (IEEE 802.11e DLS)
CONFIG_PEERKEY=y
+# IEEE 802.11w (management frame protection)
+# This version is an experimental implementation based on IEEE 802.11w/D1.0
+# draft and is subject to change since the standard has not yet been finalized.
+# Driver support is also needed for IEEE 802.11w.
+#CONFIG_IEEE80211W=y
+
# Select TLS implementation
# openssl = OpenSSL (default)
# gnutls = GnuTLS (needed for TLS/IA, see also CONFIG_GNUTLS_EXTRA)
@@ -259,21 +316,29 @@ CONFIG_PEERKEY=y
#CONFIG_GNUTLS_EXTRA=y
# If CONFIG_TLS=internal is used, additional library and include paths are
-# needed for LibTomCrypt and TomsFastMath.
-#LTC_PATH=/usr/src/libtomcrypt-1.11
-#TFM_PATH=/usr/src/tomsfastmath-0.09
-#CFLAGS += -I$(LTC_PATH)/src/headers
-#LIBS += -L$(LTC_PATH) -L$(TFM_PATH)
-#LIBS_p += -L$(LTC_PATH) -L$(TFM_PATH)
-
-# Integrate ndis_events.exe functionality into wpa_supplicant.
+# needed for LibTomMath. Alternatively, an integrated, minimal version of
+# LibTomMath can be used. See beginning of libtommath.c for details on benefits
+# and drawbacks of this option.
+#CONFIG_INTERNAL_LIBTOMMATH=y
+#ifndef CONFIG_INTERNAL_LIBTOMMATH
+#LTM_PATH=/usr/src/libtommath-0.39
+#CFLAGS += -I$(LTM_PATH)
+#LIBS += -L$(LTM_PATH)
+#LIBS_p += -L$(LTM_PATH)
+#endif
+# At the cost of about 4 kB of additional binary size, the internal LibTomMath
+# can be configured to include faster routines for exptmod, sqr, and div to
+# speed up DH and RSA calculation considerably
+#CONFIG_INTERNAL_LIBTOMMATH_FAST=y
+
+# Include NDIS event processing through WMI into wpa_supplicant/wpasvc.
# This is only for Windows builds and requires WMI-related header files and
# WbemUuid.Lib from Platform SDK even when building with MinGW.
#CONFIG_NDIS_EVENTS_INTEGRATED=y
#PLATFORMSDKLIB="/opt/Program Files/Microsoft Platform SDK/Lib"
# Add support for DBus control interface
-#CONFIG_CTRL_IFACE_DBUS=y
+CONFIG_CTRL_IFACE_DBUS=y
# Add support for loading EAP methods dynamically as shared libraries.
# When this option is enabled, each EAP method can be either included
@@ -294,15 +359,24 @@ CONFIG_PEERKEY=y
# Please also note that using dynamic libraries will increase the total binary
# size. Thus, it may not be the best option for targets that have limited
# amount of memory/flash.
-CONFIG_DYNAMIC_EAP_METHODS=y
+#CONFIG_DYNAMIC_EAP_METHODS=y
# Include client MLME (management frame processing).
-# This can be used to move MLME processing of Devicescape IEEE 802.11 stack
-# into user space.
+# This can be used to move MLME processing of Linux mac80211 stack into user
+# space. Please note that this is currently only available with
+# driver_nl80211.c and only with a modified version of Linux kernel and
+# wpa_supplicant.
#CONFIG_CLIENT_MLME=y
-# Currently, driver_devicescape.c build requires some additional parameters
-# to be able to include some of the kernel header files. Following lines can
-# be used to set these (WIRELESS_DEV must point to the root directory of the
-# wireless-dev.git tree).
-WIRELESS_DEV=/lib/modules/2.6.24-ARCH/build
-CFLAGS += -I$(WIRELESS_DEV)/net/mac80211
+
+# IEEE Std 802.11r-2008 (Fast BSS Transition)
+#CONFIG_IEEE80211R=y
+
+# Add support for writing debug log to a file (/tmp/wpa_supplicant-log-#.txt)
+#CONFIG_DEBUG_FILE=y
+
+# Enable privilege separation (see README 'Privilege separation' for details)
+#CONFIG_PRIVSEP=y
+
+# Enable mitigation against certain attacks against TKIP by delaying Michael
+# MIC error reports by a random amount of time between 0 and 60 seconds
+#CONFIG_DELAYED_MIC_ERROR_REPORT=y
diff --git a/abs/core/wpa_supplicant/wpa_supplicant.install b/abs/core/wpa_supplicant/wpa_supplicant.install
deleted file mode 100644
index 0c31765..0000000
--- a/abs/core/wpa_supplicant/wpa_supplicant.install
+++ /dev/null
@@ -1,15 +0,0 @@
-# arg 1: the new package version
-post_install() {
- post_upgrade
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- echo "==> For wpa_gui please install 'wpa_supplicant_gui'"
-}
-
-op=$1
-shift
-
-$op $*