summaryrefslogtreecommitdiffstats
path: root/abs/core/wpa_supplicant
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/wpa_supplicant
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/wpa_supplicant')
-rw-r--r--abs/core/wpa_supplicant/PKGBUILD21
-rw-r--r--abs/core/wpa_supplicant/config9
2 files changed, 16 insertions, 14 deletions
diff --git a/abs/core/wpa_supplicant/PKGBUILD b/abs/core/wpa_supplicant/PKGBUILD
index 3ecc4a8..0e709fb 100644
--- a/abs/core/wpa_supplicant/PKGBUILD
+++ b/abs/core/wpa_supplicant/PKGBUILD
@@ -1,13 +1,12 @@
-# $Id: PKGBUILD 32196 2009-03-29 14:55:53Z thomas $
+# $Id: PKGBUILD 75193 2010-04-01 02:03:01Z pierre $
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgname=wpa_supplicant
-pkgver=0.6.9
-#_madwifi_ver=0.9.4
-pkgrel=1
+pkgver=0.6.10
+pkgrel=2
pkgdesc="A utility providing key negotiation for WPA wireless networks"
arch=('i686' 'x86_64')
-depends=('openssl' 'dbus-core>=1.2.4' 'readline' 'libnl')
+depends=('openssl' 'dbus-core>=1.2.4' 'readline>=6.0' 'libnl')
optdepends=('wpa_supplicant_gui: wpa_gui program')
license=('GPL')
groups=('base')
@@ -15,18 +14,18 @@ backup=('etc/wpa_supplicant.conf')
url="http://hostap.epitest.fi/wpa_supplicant"
source=(http://hostap.epitest.fi/releases/wpa_supplicant-$pkgver.tar.gz
config)
- #http://downloads.sourceforge.net/sourceforge/madwifi/madwifi-${_madwifi_ver}.tar.gz)
-md5sums=('0efb8fcedf0a8acf6f423dfdb0658fdd'
- 'd472554904cca44e1090e25dea7b03c9')
- #'399d20de8d855a59f20058857c2178ad')
+md5sums=('8985b1030d753e5f74f8acfc34e591bb'
+ '6577abc7060ed2d45dba14bf8934e850')
build() {
- cd "${srcdir}"
- #mv madwifi-${_madwifi_ver} madwifi
cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
cp ${srcdir}/config ./.config
sed -i 's@/usr/local@$(PREFIX)@g' Makefile
make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
make PREFIX=/usr DESTDIR="${pkgdir}" install || return 1
install -m755 -d "${pkgdir}/etc"
install -m644 wpa_supplicant.conf "${pkgdir}/etc/wpa_supplicant.conf" || return 1
diff --git a/abs/core/wpa_supplicant/config b/abs/core/wpa_supplicant/config
index e3582bf..e5c8cc7 100644
--- a/abs/core/wpa_supplicant/config
+++ b/abs/core/wpa_supplicant/config
@@ -50,6 +50,7 @@
#CFLAGS += -I../../include/wireless
# Driver interface for madwifi driver
+# Deprecated; use CONFIG_DRIVER_WEXT=y instead.
#CONFIG_DRIVER_MADWIFI=y
# Set include directory to the madwifi source tree
#CFLAGS += -I../../madwifi
@@ -60,10 +61,11 @@
#CONFIG_DRIVER_PRISM54=y
# Driver interface for ndiswrapper
-CONFIG_DRIVER_NDISWRAPPER=y
+# Deprecated; use CONFIG_DRIVER_WEXT=y instead.
+#CONFIG_DRIVER_NDISWRAPPER=y
# Driver interface for Atmel driver
-CONFIG_DRIVER_ATMEL=y
+#CONFIG_DRIVER_ATMEL=y
# Driver interface for old Broadcom driver
# Please note that the newer Broadcom driver ("hybrid Linux driver") supports
@@ -74,6 +76,7 @@ CONFIG_DRIVER_ATMEL=y
#CFLAGS += -I/opt/WRT54GS/release/src/include
# Driver interface for Intel ipw2100/2200 driver
+# Deprecated; use CONFIG_DRIVER_WEXT=y instead.
#CONFIG_DRIVER_IPW=y
# Driver interface for Ralink driver
@@ -372,7 +375,7 @@ CONFIG_CTRL_IFACE_DBUS=y
#CONFIG_IEEE80211R=y
# Add support for writing debug log to a file (/tmp/wpa_supplicant-log-#.txt)
-#CONFIG_DEBUG_FILE=y
+CONFIG_DEBUG_FILE=y
# Enable privilege separation (see README 'Privilege separation' for details)
#CONFIG_PRIVSEP=y