summaryrefslogtreecommitdiffstats
path: root/abs/core/x264/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-08-06 19:57:15 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-08-06 19:57:15 (GMT)
commit38c5ac49f4383ef85e45ddccf478460de489e495 (patch)
tree4931d076bd7814b324016403a8580cb1727377a7 /abs/core/x264/PKGBUILD
parentbfcda4429a75db0ec4c3f05b235bb5f82a06eee6 (diff)
downloadlinhes_pkgbuild-38c5ac49f4383ef85e45ddccf478460de489e495.zip
linhes_pkgbuild-38c5ac49f4383ef85e45ddccf478460de489e495.tar.gz
linhes_pkgbuild-38c5ac49f4383ef85e45ddccf478460de489e495.tar.bz2
x264: update to 148.20150725
Diffstat (limited to 'abs/core/x264/PKGBUILD')
-rw-r--r--abs/core/x264/PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/abs/core/x264/PKGBUILD b/abs/core/x264/PKGBUILD
index e8cb861..b3c6a71 100644
--- a/abs/core/x264/PKGBUILD
+++ b/abs/core/x264/PKGBUILD
@@ -1,19 +1,21 @@
# $Id$
# Maintainer: Ionut Biru <ibiru@archlinux.org>
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: damir <damir@archlinux.org>
# Contributor: Paul Mattal <paul@archlinux.org>
pkgname=('x264' 'libx264' 'libx264-10bit')
-pkgver=142.20140826
-pkgrel=3
-epoch=1
+pkgver=148.20150725
+pkgrel=1
+epoch=2
arch=('i686' 'x86_64')
url='http://www.videolan.org/developers/x264.html'
license=('GPL')
depends=('glibc')
-makedepends=('yasm' 'git' 'ffmpeg')
-source=(git://git.videolan.org/x264.git#commit=021c0dc6c95c)
+makedepends=('yasm' 'git' 'ffmpeg' 'l-smash')
+_commit=73ae2d11d472d0eb3b7c218dc1659db32f649b14
+source=(git://git.videolan.org/x264.git#commit=${_commit})
md5sums=('SKIP')
pkgver() {
@@ -43,7 +45,7 @@ build() {
package_x264() {
pkgdesc='CLI tools for encoding H264/AVC video streams'
- depends=('glibc' 'ffmpeg')
+ depends=('ffmpeg' 'liblsmash.so')
provides=('x264-10bit')
conflicts=('x264-10bit')
replaces=('x264-10bit')
@@ -54,8 +56,7 @@ package_x264() {
package_libx264() {
pkgdesc='Library for encoding H264/AVC video streams'
- depends=('glibc')
- provides=('x264-dev')
+ provides=('libx264.so' 'x264-dev')
conflicts=('x264-dev')
replaces=('x264-dev')
@@ -65,8 +66,7 @@ package_libx264() {
package_libx264-10bit() {
pkgdesc='Library for encoding H264/AVC video streams. 10bit-depth.'
- depends=('glibc')
- provides=('libx264' 'x264-dev')
+ provides=('libx264.so' 'libx264' 'x264-dev')
conflicts=('libx264' 'x264-dev')
install -d "$pkgdir"/usr/lib