summaryrefslogtreecommitdiffstats
path: root/abs/core/xbitmaps
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:12:33 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:12:33 (GMT)
commit22ea84ac6f7d6bee05c12e3bff8672fbad753ea3 (patch)
treed5089aa3b2779c672338075fcb0935752b1e1544 /abs/core/xbitmaps
parentfd255056dd9f3aa7f2d61c71497fc98039497907 (diff)
downloadlinhes_pkgbuild-22ea84ac6f7d6bee05c12e3bff8672fbad753ea3.zip
linhes_pkgbuild-22ea84ac6f7d6bee05c12e3bff8672fbad753ea3.tar.gz
linhes_pkgbuild-22ea84ac6f7d6bee05c12e3bff8672fbad753ea3.tar.bz2
Xorg update part1
Diffstat (limited to 'abs/core/xbitmaps')
-rw-r--r--abs/core/xbitmaps/LICENSE50
-rw-r--r--abs/core/xbitmaps/PKGBUILD27
2 files changed, 15 insertions, 62 deletions
diff --git a/abs/core/xbitmaps/LICENSE b/abs/core/xbitmaps/LICENSE
deleted file mode 100644
index c5fe9b0..0000000
--- a/abs/core/xbitmaps/LICENSE
+++ /dev/null
@@ -1,50 +0,0 @@
-Copyright 1988, 1998 The Open Group
-
-Permission to use, copy, modify, distribute, and sell this software and its
-documentation for any purpose is hereby granted without fee, provided that
-the above copyright notice appear in all copies and that both that
-copyright notice and this permission notice appear in supporting
-documentation.
-
-The above copyright notice and this permission notice shall be included
-in all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
-OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
-IN NO EVENT SHALL THE OPEN GROUP BE LIABLE FOR ANY CLAIM, DAMAGES OR
-OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
-ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
-OTHER DEALINGS IN THE SOFTWARE.
-
-Except as contained in this notice, the name of The Open Group shall
-not be used in advertising or otherwise to promote the sale, use or
-other dealings in this Software without prior written authorization
-from The Open Group.
-
-
-/*****************************************************************************/
-/** Copyright 1988 by Evans & Sutherland Computer Corporation, **/
-/** Salt Lake City, Utah **/
-/** **/
-/** All Rights Reserved **/
-/** **/
-/** Permission to use, copy, modify, and distribute this software and **/
-/** its documentation for any purpose and without fee is hereby **/
-/** granted, provided that the above copyright notice appear in all **/
-/** copies and that both that copyright notice and this permis- **/
-/** sion notice appear in supporting documentation, and that the **/
-/** name of Evans & Sutherland not be used in advertising or publi- **/
-/** city pertaining to distribution of the software without specif- **/
-/** ic, written prior permission. **/
-/** **/
-/** EVANS & SUTHERLAND DISCLAIMS ALL WARRANTIES WITH REGARD TO **/
-/** THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILI- **/
-/** TY AND FITNESS, IN NO EVENT SHALL EVANS & SUTHERLAND BE LIABLE **/
-/** FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAM- **/
-/** AGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, **/
-/** WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS **/
-/** ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PER- **/
-/** FORMANCE OF THIS SOFTWARE. **/
-/*****************************************************************************/
-
diff --git a/abs/core/xbitmaps/PKGBUILD b/abs/core/xbitmaps/PKGBUILD
index ba46954..2fc3e77 100644
--- a/abs/core/xbitmaps/PKGBUILD
+++ b/abs/core/xbitmaps/PKGBUILD
@@ -1,22 +1,25 @@
-# $Id: PKGBUILD 56379 2009-10-21 19:00:03Z andyrtr $
-#Maintainer: Jan de Groot <jgc@archlinux.org>
+# $Id: PKGBUILD 151200 2012-02-25 07:27:18Z allan $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=xbitmaps
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="X.org Bitmap files"
arch=('any')
url="http://xorg.freedesktop.org/"
license=('custom')
-makedepends=('pkgconfig')
-source=(${url}/releases/individual/data/${pkgname}-${pkgver}.tar.bz2 LICENSE)
+makedepends=('xorg-util-macros')
+source=(${url}/releases/individual/data/${pkgname}-${pkgver}.tar.bz2)
+sha1sums=('578afff7e4912192b524c25254cf7f54c16e57d8')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr || return 1
- make || return 1
- make DESTDIR=${pkgdir} install || return 1
- install -D -m644 ../LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}
-md5sums=('7444bbbd999b53bec6a60608a5301f4c'
- '8d6c2d0109ea72abdcbf6846a908f399')