summaryrefslogtreecommitdiffstats
path: root/abs/core/xcursor-vanilla-dmz
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-09-21 21:58:49 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-09-21 21:58:49 (GMT)
commitc07a0a22356118de3a14f8a08136c2bfd2654607 (patch)
tree14f2f8d04aaffa1abad0225cc3518d8cb648b536 /abs/core/xcursor-vanilla-dmz
parentd3b112d34c237bd8bddedad8af0027bb86ad9116 (diff)
downloadlinhes_pkgbuild-c07a0a22356118de3a14f8a08136c2bfd2654607.zip
linhes_pkgbuild-c07a0a22356118de3a14f8a08136c2bfd2654607.tar.gz
linhes_pkgbuild-c07a0a22356118de3a14f8a08136c2bfd2654607.tar.bz2
xcursor-vanilla-dmz: Initial inclusion. To be used as default LinHES mouse cursor for both large and normal sizes.
Diffstat (limited to 'abs/core/xcursor-vanilla-dmz')
-rw-r--r--abs/core/xcursor-vanilla-dmz/PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/abs/core/xcursor-vanilla-dmz/PKGBUILD b/abs/core/xcursor-vanilla-dmz/PKGBUILD
new file mode 100644
index 0000000..c0f4319
--- /dev/null
+++ b/abs/core/xcursor-vanilla-dmz/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id$
+# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
+# Contributor: Björn Martensen <bjoern.martensen@gmail.com>
+# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgbase=xcursor-vanilla-dmz
+pkgname=('xcursor-vanilla-dmz' 'xcursor-vanilla-dmz-aa')
+pkgver=0.4.3
+pkgrel=1
+arch=('any')
+url="http://jimmac.musichall.cz/themes.php?skin=7"
+license=('CCPL:by-nc-sa')
+makedepends=('xorg-xcursorgen')
+source=(http://ftp.de.debian.org/debian/pool/main/d/dmz-cursor-theme/dmz-cursor-theme_${pkgver}.tar.gz)
+md5sums=('412256b1b8a65dd05b46f65b32e2f5e6')
+
+build() {
+ cd "${srcdir}/dmz-cursor-theme-${pkgver}"
+ (cd DMZ-White/pngs ; ./make.sh)
+ (cd DMZ-Black/pngs ; ./make.sh)
+}
+
+package_xcursor-vanilla-dmz() {
+ pkgdesc="Vanilla DMZ cursor theme"
+
+ cd "${srcdir}/dmz-cursor-theme-${pkgver}"
+ install -d "${pkgdir}"/usr/share/icons/Vanilla-DMZ/cursors
+ cp -a DMZ-White/xcursors/* "${pkgdir}"/usr/share/icons/Vanilla-DMZ/cursors
+ install -Dm644 DMZ-White/index.theme "${pkgdir}"/usr/share/icons/Vanilla-DMZ/index.theme
+}
+
+package_xcursor-vanilla-dmz-aa() {
+ pkgdesc="Vanilla DMZ AA cursor theme"
+
+ cd "${srcdir}/dmz-cursor-theme-${pkgver}"
+ install -d "${pkgdir}"/usr/share/icons/Vanilla-DMZ-AA/cursors
+ cp -a DMZ-Black/xcursors/* "${pkgdir}"/usr/share/icons/Vanilla-DMZ-AA/cursors
+ install -Dm644 DMZ-Black/index.theme "${pkgdir}"/usr/share/icons/Vanilla-DMZ-AA/index.theme
+}