summaryrefslogtreecommitdiffstats
path: root/abs/core/xf86-video-ati
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-06-24 19:12:36 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-06-24 19:12:36 (GMT)
commit475a23548f0d6379c8c7f6f692a4f69c51b6dc7b (patch)
treebe345de5344c1c98c96ea85c3f7c4db57f5db391 /abs/core/xf86-video-ati
parent98a093f6f165f60448df060c86d8f118b41f63cb (diff)
downloadlinhes_pkgbuild-475a23548f0d6379c8c7f6f692a4f69c51b6dc7b.zip
linhes_pkgbuild-475a23548f0d6379c8c7f6f692a4f69c51b6dc7b.tar.gz
linhes_pkgbuild-475a23548f0d6379c8c7f6f692a4f69c51b6dc7b.tar.bz2
xf86-video-ati: update to 1.7.5
Diffstat (limited to 'abs/core/xf86-video-ati')
-rw-r--r--abs/core/xf86-video-ati/PKGBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/abs/core/xf86-video-ati/PKGBUILD b/abs/core/xf86-video-ati/PKGBUILD
index 40f66e5..83835b6 100644
--- a/abs/core/xf86-video-ati/PKGBUILD
+++ b/abs/core/xf86-video-ati/PKGBUILD
@@ -1,31 +1,33 @@
-# $Id: PKGBUILD 170785 2012-11-11 10:23:19Z andyrtr $
+# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Alexander Baldeck <alexander@archlinux.org>
pkgname=xf86-video-ati
-pkgver=7.0.0
+pkgver=7.5.0
epoch=1
-pkgrel=1
+pkgrel=2
pkgdesc="X.org ati video driver"
arch=('i686' 'x86_64')
url="http://xorg.freedesktop.org/"
license=('custom')
-depends=('libdrm>=2.4.40' 'systemd-tools' 'ati-dri')
-makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=13' 'resourceproto' 'scrnsaverproto')
-conflicts=('xorg-server<1.13.0' 'X-ABI-VIDEODRV_VERSION<13' 'X-ABI-VIDEODRV_VERSION>=14')
+depends=('libdrm>=2.4.58' 'systemd' 'mesa-dri')
+makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=19')
+conflicts=('xorg-server<1.16.0' 'X-ABI-VIDEODRV_VERSION<19' 'X-ABI-VIDEODRV_VERSION>=20')
groups=('xorg-drivers' 'xorg')
-options=('!libtool')
source=(${url}/releases/individual/driver/${pkgname}-${pkgver}.tar.bz2)
-sha256sums=('c0acc81386425651aae5dfe02d89f935bb63b2a62104da0d88deac3c773ea10e')
+sha256sums=('ec3e6f06b6cf9a40c72aafa3448aae8b034c80b37410ca9442d5cf6806e07936')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr
+ cd ${pkgname}-${pkgver}
+
+ ./configure --prefix=/usr \
+ --enable-glamor
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-${pkgver}
+
make "DESTDIR=${pkgdir}" install
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"