summaryrefslogtreecommitdiffstats
path: root/abs/core/xf86-video-ati
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-09 21:38:29 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-09 21:38:29 (GMT)
commit87d4c6f73cdcf411352bea2ff2539105f81f1e84 (patch)
tree6a288b254108788be0fe3a68927be754b2ae3f6f /abs/core/xf86-video-ati
parent72555a87c8775dd404fa62d7003e557ad05c90ba (diff)
downloadlinhes_pkgbuild-87d4c6f73cdcf411352bea2ff2539105f81f1e84.zip
linhes_pkgbuild-87d4c6f73cdcf411352bea2ff2539105f81f1e84.tar.gz
linhes_pkgbuild-87d4c6f73cdcf411352bea2ff2539105f81f1e84.tar.bz2
xf86-video-ati: xorg ati driver.
Diffstat (limited to 'abs/core/xf86-video-ati')
-rw-r--r--abs/core/xf86-video-ati/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/xf86-video-ati/PKGBUILD b/abs/core/xf86-video-ati/PKGBUILD
new file mode 100644
index 0000000..40f66e5
--- /dev/null
+++ b/abs/core/xf86-video-ati/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 170785 2012-11-11 10:23:19Z andyrtr $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Alexander Baldeck <alexander@archlinux.org>
+
+pkgname=xf86-video-ati
+pkgver=7.0.0
+epoch=1
+pkgrel=1
+pkgdesc="X.org ati video driver"
+arch=('i686' 'x86_64')
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('libdrm>=2.4.40' 'systemd-tools' 'ati-dri')
+makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=13' 'resourceproto' 'scrnsaverproto')
+conflicts=('xorg-server<1.13.0' 'X-ABI-VIDEODRV_VERSION<13' 'X-ABI-VIDEODRV_VERSION>=14')
+groups=('xorg-drivers' 'xorg')
+options=('!libtool')
+source=(${url}/releases/individual/driver/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('c0acc81386425651aae5dfe02d89f935bb63b2a62104da0d88deac3c773ea10e')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make "DESTDIR=${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}