summaryrefslogtreecommitdiffstats
path: root/abs/core/xf86-video-unichrome
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-10 03:37:08 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-10 03:37:08 (GMT)
commit7c5f001026414ccb3fc0a83287b889a41078bbc4 (patch)
treeef0b336d5ee21acc668bbd92557048d6dd596149 /abs/core/xf86-video-unichrome
parent88d2b4ec6aeaa8a367c64b891dadf40425060d81 (diff)
downloadlinhes_pkgbuild-7c5f001026414ccb3fc0a83287b889a41078bbc4.zip
linhes_pkgbuild-7c5f001026414ccb3fc0a83287b889a41078bbc4.tar.gz
linhes_pkgbuild-7c5f001026414ccb3fc0a83287b889a41078bbc4.tar.bz2
xf86-video-*: recompiled against local arch abs.
Diffstat (limited to 'abs/core/xf86-video-unichrome')
-rw-r--r--abs/core/xf86-video-unichrome/PKGBUILD4
-rw-r--r--abs/core/xf86-video-unichrome/fix-defines.patch68
2 files changed, 2 insertions, 70 deletions
diff --git a/abs/core/xf86-video-unichrome/PKGBUILD b/abs/core/xf86-video-unichrome/PKGBUILD
index 490dc84..b2aa60e 100644
--- a/abs/core/xf86-video-unichrome/PKGBUILD
+++ b/abs/core/xf86-video-unichrome/PKGBUILD
@@ -9,9 +9,9 @@ arch=(i686 x86_64)
url="http://unichrome.sf.net/"
license=('custom')
depends=('glibc' 'unichrome-dri')
-makedepends=('xorg-server' 'libx11' 'libdrm' 'xf86driproto' 'mesa' 'libxvmc')
+makedepends=('xorg-server-devel' 'libx11' 'libdrm' 'xf86driproto' 'mesa' 'libxvmc')
options=('!libtool')
-conflicts=('xf86-video-via' 'openchrome' 'xf86-video-openchrome' 'xorg-server<1.8.1')
+conflicts=('xf86-video-via' 'openchrome' 'xf86-video-openchrome' 'xorg-server<1.9.0')
source=(http://cgit.freedesktop.org/~libv/${pkgname}/snapshot/${pkgname}-${_gitversion}.tar.bz2
drm-include.patch
LICENSE)
diff --git a/abs/core/xf86-video-unichrome/fix-defines.patch b/abs/core/xf86-video-unichrome/fix-defines.patch
deleted file mode 100644
index 5b9f040..0000000
--- a/abs/core/xf86-video-unichrome/fix-defines.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From: Luc Verhaegen <libv@skynet.be>
-Date: Wed, 6 Dec 2006 23:16:01 +0000 (+0100)
-Subject: Fix build issues due to hard uint32_t and Bool #defines.
-X-Git-Url: http://gitweb.freedesktop.org/?p=users/libv/xf86-video-unichrome.git;a=commitdiff;h=13c214345787a3340f230e77b7770b7c2d115c85
-
-Fix build issues due to hard uint32_t and Bool #defines.
-
-Ported from xf86-video_via, which was by Matthias Hopf.
----
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -70,6 +70,7 @@ sdkdir=$(pkg-config --variable=sdkdir xo
-
- # Checks for header files.
- AC_HEADER_STDC
-+AC_CHECK_HEADERS([inttypes.h])
-
- if test "$DRI" != no; then
- AC_CHECK_FILE([${sdkdir}/dri.h],
---- a/src/via_dri.h
-+++ b/src/via_dri.h
-@@ -35,7 +35,7 @@
- #define VIA_DRIDDX_VERSION_MINOR 0
- #define VIA_DRIDDX_VERSION_PATCH 0
-
--#ifndef XFree86Server
-+#if !defined(XFree86Server) && !defined(_XTYPEDEF_BOOL)
- typedef int Bool;
- #endif
-
---- a/src/via_drmclient.h
-+++ b/src/via_drmclient.h
-@@ -27,7 +27,13 @@
- #include "drm.h"
- #include "xf86drm.h"
-
--typedef CARD32 uint32_t;
-+#ifdef HAVE_INTTYPES_H
-+# include <inttypes.h>
-+#else
-+# ifndef uint32_t
-+# define uint32_t CARD32
-+# endif
-+#endif
-
- #ifdef X_NEED_DRMLOCK
- #define drm_hw_lock_t drmLock
---- a/src/via_video.c
-+++ b/src/via_video.c
-@@ -367,7 +367,7 @@ ViaSwovCopyDMA(VIAPtr pVia, struct ViaMe
- if (error) {
- xf86DrvMsg(pVia->scrnIndex, X_ERROR, "%s: DMA copy sheduling failed: %d.\n",
- __FUNCTION__, error);
-- xf86DrvMsg(pVia->scrnIndex, X_ERROR, "%s: Copying %p to %08lX\n",
-+ xf86DrvMsg(pVia->scrnIndex, X_ERROR, "%s: Copying %p to %08X\n",
- __func__, blit.mem_addr, blit.fb_addr);
- if (new_buf)
- xfree(new_buf);
-@@ -391,7 +391,7 @@ ViaSwovCopyDMA(VIAPtr pVia, struct ViaMe
- if (error) {
- xf86DrvMsg(pVia->scrnIndex, X_ERROR, "%s: DMA copy sync failed: %d - %d\n",
- __FUNCTION__, error, -EAGAIN);
-- xf86DrvMsg(pVia->scrnIndex, X_ERROR, "%s: Copying %p to %08lX\n",
-+ xf86DrvMsg(pVia->scrnIndex, X_ERROR, "%s: Copying %p to %08X\n",
- __func__, blit.mem_addr, blit.fb_addr);
- return FALSE;
- }