summaryrefslogtreecommitdiffstats
path: root/abs/core/xf86driproto
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:12:33 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:12:33 (GMT)
commit22ea84ac6f7d6bee05c12e3bff8672fbad753ea3 (patch)
treed5089aa3b2779c672338075fcb0935752b1e1544 /abs/core/xf86driproto
parentfd255056dd9f3aa7f2d61c71497fc98039497907 (diff)
downloadlinhes_pkgbuild-22ea84ac6f7d6bee05c12e3bff8672fbad753ea3.zip
linhes_pkgbuild-22ea84ac6f7d6bee05c12e3bff8672fbad753ea3.tar.gz
linhes_pkgbuild-22ea84ac6f7d6bee05c12e3bff8672fbad753ea3.tar.bz2
Xorg update part1
Diffstat (limited to 'abs/core/xf86driproto')
-rw-r--r--abs/core/xf86driproto/LICENSE50
-rw-r--r--abs/core/xf86driproto/PKGBUILD33
2 files changed, 18 insertions, 65 deletions
diff --git a/abs/core/xf86driproto/LICENSE b/abs/core/xf86driproto/LICENSE
deleted file mode 100644
index 07a911b..0000000
--- a/abs/core/xf86driproto/LICENSE
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright (C) 1994 X Consortium
-#
-# Permission is hereby granted, free of charge, to any person obtaining a copy
-# of this software and associated documentation files (the "Software"), to
-# deal in the Software without restriction, including without limitation the
-# rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
-# sell copies of the Software, and to permit persons to whom the Software is
-# furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice shall be included in
-# all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-# X CONSORTIUM BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
-# AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNEC-
-# TION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-#
-# Except as contained in this notice, the name of the X Consortium shall not
-# be used in advertising or otherwise to promote the sale, use or other deal-
-
-
-/**************************************************************************
-
-Copyright 1998-1999 Precision Insight, Inc., Cedar Park, Texas.
-Copyright 2000 VA Linux Systems, Inc.
-All Rights Reserved.
-
-Permission is hereby granted, free of charge, to any person obtaining a
-copy of this software and associated documentation files (the
-"Software"), to deal in the Software without restriction, including
-without limitation the rights to use, copy, modify, merge, publish,
-distribute, sub license, and/or sell copies of the Software, and to
-permit persons to whom the Software is furnished to do so, subject to
-the following conditions:
-
-The above copyright notice and this permission notice (including the
-next paragraph) shall be included in all copies or substantial portions
-of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
-OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT.
-IN NO EVENT SHALL PRECISION INSIGHT AND/OR ITS SUPPLIERS BE LIABLE FOR
-ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
-TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
-SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-
-**************************************************************************/
diff --git a/abs/core/xf86driproto/PKGBUILD b/abs/core/xf86driproto/PKGBUILD
index 197c37f..860e1e7 100644
--- a/abs/core/xf86driproto/PKGBUILD
+++ b/abs/core/xf86driproto/PKGBUILD
@@ -1,23 +1,26 @@
-# $Id: PKGBUILD 50995 2009-09-04 12:48:43Z jgc $
-# Maintainer: Alexander Baldeck <alexander@archlinux.org>
-# Contributor: Jan de Groot <jgc@archlinux.org>
+# $Id: PKGBUILD 151192 2012-02-25 07:11:08Z allan $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Alexander Baldeck <alexander@archlinux.org>
+
pkgname=xf86driproto
-pkgver=2.1.0
-pkgrel=1
+pkgver=2.1.1
+pkgrel=2
pkgdesc="X11 DRI extension wire protocol"
-arch=(any)
+arch=('any')
+makedepends=('xorg-util-macros')
url="http://xorg.freedesktop.org/"
license=('custom')
-source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2
- LICENSE)
-sha1sums=('0dfc6616ffc68ca3c3b5decb1e365aaa93be8548'
- '32bab65dd9c0b49333146abf16602967041b0d92')
+source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2)
+sha1sums=('23e861f40ba0f0cbbfd7db7ba2ef623762ffca17')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
- install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}