summaryrefslogtreecommitdiffstats
path: root/abs/core/xmlrpc-c
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/core/xmlrpc-c
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/core/xmlrpc-c')
-rw-r--r--abs/core/xmlrpc-c/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/xmlrpc-c/PKGBUILD b/abs/core/xmlrpc-c/PKGBUILD
new file mode 100644
index 0000000..4a1057e
--- /dev/null
+++ b/abs/core/xmlrpc-c/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Pierre Schmitz <pierre@archlinux.de>
+# Contributor: Vitaliy Berdinskikh <skipper13@root.ua>
+
+pkgname=xmlrpc-c
+pkgver=1.06.32
+pkgrel=1
+pkgdesc='This library provides a modular implementation of XML-RPC for C and C++'
+arch=('i686' 'x86_64')
+url='http://xmlrpc-c.sourceforge.net/'
+license=('custom')
+depends=('curl' 'libxml2')
+makedepends=('libtool')
+options=('!makeflags' '!libtool')
+source=("http://downloads.sourceforge.net/xmlrpc-c/xmlrpc-c-${pkgver}.tgz")
+md5sums=('1a5a0771a22e75819d90e7fab38ef377')
+
+build() {
+ [ "${CARCH}" = "x86_64" ] && export CFLAGS="${CFLAGS} -fPIC"
+
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --enable-libxml2-backend \
+ --disable-cgi-server \
+ --disable-abyss-server \
+ --disable-libwww-client \
+ --disable-wininet-client
+
+ make CFLAGS_PERSONAL="${CFLAGS}" || return 1
+ make DESTDIR=$pkgdir install
+
+ install -m 644 -D doc/COPYING $pkgdir/usr/share/licenses/${pkgname}/COPYING
+}