summaryrefslogtreecommitdiffstats
path: root/abs/core/xorg-xinit
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-28 16:21:01 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-28 16:21:01 (GMT)
commite647a91566e63835f9805cf62b7bfa5b7bcbd957 (patch)
treeb55f6df867f885f41a057ef35bc834eccd6c6710 /abs/core/xorg-xinit
parent9adb403d50b1a213553742e07aeb66ffc25c2e8a (diff)
downloadlinhes_pkgbuild-e647a91566e63835f9805cf62b7bfa5b7bcbd957.zip
linhes_pkgbuild-e647a91566e63835f9805cf62b7bfa5b7bcbd957.tar.gz
linhes_pkgbuild-e647a91566e63835f9805cf62b7bfa5b7bcbd957.tar.bz2
xorg-server and server-utils 1.13
Diffstat (limited to 'abs/core/xorg-xinit')
-rw-r--r--abs/core/xorg-xinit/PKGBUILD6
-rw-r--r--abs/core/xorg-xinit/xserverrc7
2 files changed, 9 insertions, 4 deletions
diff --git a/abs/core/xorg-xinit/PKGBUILD b/abs/core/xorg-xinit/PKGBUILD
index f4d5673..f9bb1c6 100644
--- a/abs/core/xorg-xinit/PKGBUILD
+++ b/abs/core/xorg-xinit/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 149821 2012-02-11 08:52:05Z andyrtr $
+# $Id: PKGBUILD 170012 2012-10-31 00:12:04Z thomas $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Alexander Baldeck <alexander@archlinux.org>
pkgname=xorg-xinit
pkgver=1.3.2
-pkgrel=1
+pkgrel=3
pkgdesc="X.Org initialisation program "
arch=('i686' 'x86_64')
license=('custom')
@@ -28,7 +28,7 @@ md5sums=('9c0943cbd83e489ad1b05221b97efd44'
'73a597d3fb7f5b9487318ac8cfd4bedf'
'c7b406c3c5c1e8011b3ac7d6b29c1a2c'
'7873d97db30d6c279ed37e3559e7c59d'
- 'c5baef10fdb7239594daee72a94ddab3')
+ '4deba1b7f2cc7f93b304b956023e65d6')
build() {
cd "${srcdir}/xinit-${pkgver}"
diff --git a/abs/core/xorg-xinit/xserverrc b/abs/core/xorg-xinit/xserverrc
index 6f746cd..6b57eeb 100644
--- a/abs/core/xorg-xinit/xserverrc
+++ b/abs/core/xorg-xinit/xserverrc
@@ -1 +1,6 @@
-exec /usr/bin/X -nolisten tcp "$@"
+#!/bin/sh
+if [ -z "$XDG_VTNR" ]; then
+ exec /usr/bin/X -nolisten tcp "$@"
+else
+ exec /usr/bin/X -nolisten tcp "$@" vt$XDG_VTNR
+fi