summaryrefslogtreecommitdiffstats
path: root/abs/core/xymon
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-12-25 22:42:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-12-25 22:42:09 (GMT)
commit72fad9e7b6b5a4c090bc2af18ab50d4c28479ae0 (patch)
tree14ce0bffae3fe87316f34974f7e2c5b4767e12bb /abs/core/xymon
parent11eaeebe7d98daa45e5e61703c2c10e15db9ad48 (diff)
downloadlinhes_pkgbuild-72fad9e7b6b5a4c090bc2af18ab50d4c28479ae0.zip
linhes_pkgbuild-72fad9e7b6b5a4c090bc2af18ab50d4c28479ae0.tar.gz
linhes_pkgbuild-72fad9e7b6b5a4c090bc2af18ab50d4c28479ae0.tar.bz2
xymon: change database backup location to /myth/system_backup.
Also fix the generation of hbnotes for standalone. The webpage was missing the backup option
Diffstat (limited to 'abs/core/xymon')
-rw-r--r--abs/core/xymon/PKGBUILD4
-rw-r--r--abs/core/xymon/hbnotes.py11
2 files changed, 8 insertions, 7 deletions
diff --git a/abs/core/xymon/PKGBUILD b/abs/core/xymon/PKGBUILD
index 5332ff5..2b18cdb 100644
--- a/abs/core/xymon/PKGBUILD
+++ b/abs/core/xymon/PKGBUILD
@@ -1,7 +1,7 @@
pkgbase=xymon
pkgname=(xymonserver xymonclient)
pkgver=4.3.5
-pkgrel=26
+pkgrel=29
pkgdesc="Hobbit is a system for monitoring servers and networks. "
license="GPL"
arch=('i686' 'x86_64')
@@ -118,7 +118,7 @@ md5sums=('31923ec126fe1c264fceb459d2175161'
'cc845b5aedc33dda8e3103b915fe4967'
'650b523d879f32c1bad3b4a9e10e7c93'
'093648dabb0d1da0fdcc37b327737f43'
- '84f6b0db44e5142bb59aeabc7ea875af'
+ 'cac3478de106d875ddbdaa377d26692d'
'6eb6ecdf33454f35b6c2409b863c816f'
'f6921f0413215ae174e81306be80d37f'
'be02f5d21373f97224ffa4727ec9718a'
diff --git a/abs/core/xymon/hbnotes.py b/abs/core/xymon/hbnotes.py
index 13dbd86..2a1b221 100644
--- a/abs/core/xymon/hbnotes.py
+++ b/abs/core/xymon/hbnotes.py
@@ -19,8 +19,8 @@ except:
-def createdropdown():
- dir = "/data/database_backup"
+def createdropdown(currenthostype):
+ dir = "/myth/system_backup"
dropdown=" "
#dropdown='''
#<input name="param2" type="radio" value="Restore" />Restore database </>
@@ -33,7 +33,8 @@ def createdropdown():
#dropdown+='<option value="' + file + '">' + file + '</option> '
dropdown+='</select> <br><input name="param2" type="radio" value="Backup" checked="checked" />Backup database<br /> '
dropdown+='<input name="param2" type="radio" value="Optimize" />Optimize database<br /> '
- dropdown+='<input name="param2" type="radio" value="ShutdownAll" />Shutdown All Systems (expect MBE)<br /> '
+ if currenthostype == "Master_backend":
+ dropdown+='<input name="param2" type="radio" value="ShutdownAll" />Shutdown All Systems (expect MBE)<br /> '
#dropdown+='''<input name="param2" type="radio" value="UpdateAll" />Update All Systems </> <select name="param5">
#<option value="Myth_only">Myth only</option>
#<option value="All"> Full System</option>
@@ -339,8 +340,8 @@ def main(argv):
</div>
'''
- if currenthostype == "Master_backend":
- mbeoptions=createdropdown()
+ if currenthostype == "Master_backend" or currenthostype == "Standalone":
+ mbeoptions=createdropdown(currenthostype)
else:
mbeoptions=''
returnurl="/xymon/notes/"