summaryrefslogtreecommitdiffstats
path: root/abs/core/xymon
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-12-03 18:28:48 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-12-03 18:28:48 (GMT)
commit8c3ad44135b42290b15395fdcb5a5167a33b4788 (patch)
tree437a5a988ea5941be2ac3c01ca33545ac6b44974 /abs/core/xymon
parentb1e1aee98b199446c5322507fd675dcd6301d846 (diff)
downloadlinhes_pkgbuild-8c3ad44135b42290b15395fdcb5a5167a33b4788.zip
linhes_pkgbuild-8c3ad44135b42290b15395fdcb5a5167a33b4788.tar.gz
linhes_pkgbuild-8c3ad44135b42290b15395fdcb5a5167a33b4788.tar.bz2
xymon: set mythfrontend to go yellow instead of red, fix timestamp format for checking the mtc log.
refs #945
Diffstat (limited to 'abs/core/xymon')
-rwxr-xr-xabs/core/xymon/PKGBUILD6
-rw-r--r--abs/core/xymon/analysis.cfg10
-rwxr-xr-xabs/core/xymon/hobbit_myth_data.py4
3 files changed, 11 insertions, 9 deletions
diff --git a/abs/core/xymon/PKGBUILD b/abs/core/xymon/PKGBUILD
index 96aa82f..c5acbe9 100755
--- a/abs/core/xymon/PKGBUILD
+++ b/abs/core/xymon/PKGBUILD
@@ -1,7 +1,7 @@
pkgbase=xymon
pkgname=(xymonserver xymonclient)
pkgver=4.3.5
-pkgrel=51
+pkgrel=52
pkgdesc="Hobbit is a system for monitoring servers and networks. "
license="GPL"
arch=('i686' 'x86_64')
@@ -136,7 +136,7 @@ md5sums=('31923ec126fe1c264fceb459d2175161'
'b2f98ac0df013332deedc1efae0a270d'
'1141fc6f846e91f380bbcdb212b44f7d'
'0f70e76a164f648f0a4a01110137cb20'
- 'b0664f3b38717dce911f59bcbd84e7a4'
+ '166279c006c3ef7bf0c21537cf89fc83'
'80d9cfac86c6d96836e6f406e35e7cf5'
'd210c43fb9ee9ad6cd7648e0c2e0efea'
'0c808fa12672289f86b0651545381308'
@@ -145,7 +145,7 @@ md5sums=('31923ec126fe1c264fceb459d2175161'
'6baa410da1dfb86435191f4805186ea7'
'a834dd134b6d640d753b1e26609d37df'
'9b5f3079c461f1e0a1b5fb805d073665'
- '77a542c2fd13468791ef23057ba8e77d'
+ '0820163ec63b3993577ac8cd9c3ab3ca'
'b4e8641e97e6b689dbc634af785e6799'
'e2844513e2c92e8b5084818f3b2a478d'
'98e9242ae346f729b14cb195786571f2'
diff --git a/abs/core/xymon/analysis.cfg b/abs/core/xymon/analysis.cfg
index da833e1..460d157 100644
--- a/abs/core/xymon/analysis.cfg
+++ b/abs/core/xymon/analysis.cfg
@@ -317,7 +317,7 @@
# the alert module, which can then use it to control who gets an alert when
# a failure occurs. E.g. the following associates the "httpd" process check
# with the "web" group, and the "sshd" check with the "admins" group:
-# PROC httpd 5 GROUP=web
+# PROC httpd ?5 GROUP=web
# PROC sshd 1 GROUP=admins
# In the alerts.cfg file, you could then have rules like
# GROUP=web
@@ -364,7 +364,7 @@ HOST=_MASTERBACKEND_
PORT "LOCAL=%([.:]22)$" state=LISTEN TEXT=ssh
HOST=_MASTERFRONTEND_
- PROC mythfrontend
+ PROC mythfrontend 1 5 yellow
PROC sshd 1
PROC lighttpd
PROC xymond
@@ -385,7 +385,7 @@ HOST=_MASTERFRONTEND_
HOST=_FRONTEND_
PROC sshd 1
PROC crond
- PROC mythfrontend
+ PROC mythfrontend 1 5 yellow
PROC msg_daemon.py
PORT "LOCAL=%([.:]22)$" state=LISTEN TEXT=ssh
@@ -405,7 +405,7 @@ HOST=_SLAVEFRONTEND_
PROC hobbitd
PROC crond
PROC mythbackend
- PROC mythfrontend
+ PROC mythfrontend 1 5 yellow
PROC msg_daemon.py
DISK %^/cdrom.* IGNORE
DISK %^/mnt.* IGNORE
@@ -415,7 +415,7 @@ HOST=_SLAVEFRONTEND_
HOST=_STANDALONE_
- PROC mythfrontend
+ PROC mythfrontend 1 5 yellow
PROC sshd 1
PROC lighttpd
PROC xymond
diff --git a/abs/core/xymon/hobbit_myth_data.py b/abs/core/xymon/hobbit_myth_data.py
index 52d6a6b..3c7ad49 100755
--- a/abs/core/xymon/hobbit_myth_data.py
+++ b/abs/core/xymon/hobbit_myth_data.py
@@ -95,7 +95,9 @@ def find_data_left():
now = datetime.datetime.now()
-date = "%s-%s-%s" %(now.year, now.month, now.day)
+#date = "%s-%s-%s" %(now.year, now.month, now.day)
+date = (now.strftime('%Y-%m-%d'))
+
mtc_file = "/var/log/%s/myth_mtc.log" %date
mtc=check_mtc(mtc_file)