summaryrefslogtreecommitdiffstats
path: root/abs/core/xymon
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-08-04 12:46:33 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-08-04 12:46:33 (GMT)
commitd3b1bb6d77ab7e31192cd6926ca5fd79a94e19c2 (patch)
treea4f37fc3d83f4f901754bae6f3621b4a601df723 /abs/core/xymon
parentf0dce6aa6732f0792b0348677358b1b134f9a70a (diff)
downloadlinhes_pkgbuild-d3b1bb6d77ab7e31192cd6926ca5fd79a94e19c2.zip
linhes_pkgbuild-d3b1bb6d77ab7e31192cd6926ca5fd79a94e19c2.tar.gz
linhes_pkgbuild-d3b1bb6d77ab7e31192cd6926ca5fd79a94e19c2.tar.bz2
xymon: hbnotes.py: replace - in hostname with __
Needed because the dot file format doesn't like -
Diffstat (limited to 'abs/core/xymon')
-rwxr-xr-xabs/core/xymon/PKGBUILD4
-rwxr-xr-xabs/core/xymon/hbnotes.py1
2 files changed, 3 insertions, 2 deletions
diff --git a/abs/core/xymon/PKGBUILD b/abs/core/xymon/PKGBUILD
index 932497b..b56c668 100755
--- a/abs/core/xymon/PKGBUILD
+++ b/abs/core/xymon/PKGBUILD
@@ -1,7 +1,7 @@
pkgbase=xymon
pkgname=('xymonserver' 'xymonclient')
pkgver=4.3.17
-pkgrel=18
+pkgrel=19
pkgdesc="Xymon is a system for monitoring of hosts and networks"
license="GPL"
arch=('i686' 'x86_64')
@@ -168,7 +168,7 @@ md5sums=('d8d119a777e7b7204d1292fb27314312'
'a19c8c546dcd95049476bb19f9d4e3ae'
'c9a31ea9ae131fb351db913e922c25aa'
'b2f98ac0df013332deedc1efae0a270d'
- '4a8244c1bb44fe35ca7372355b01cec4'
+ 'df77d1de72157d23a301a72288fbf7e5'
'aa7c2eec6cd894dc171e90a4eed69de1'
'166279c006c3ef7bf0c21537cf89fc83'
'80d9cfac86c6d96836e6f406e35e7cf5'
diff --git a/abs/core/xymon/hbnotes.py b/abs/core/xymon/hbnotes.py
index d14d62a..d18a606 100755
--- a/abs/core/xymon/hbnotes.py
+++ b/abs/core/xymon/hbnotes.py
@@ -40,6 +40,7 @@ def create_dot_file():
for row in result:
hostname = row[0]
dot_hostname = row[0].replace('.','_')
+ dot_hostname = row[0].replace('-','__')
#Find the system type
cursor.execute("select value,data from settings where hostname=%s and value in ('HostSystemType','HostRunFrontend');",(row))
hostvalues=cursor.fetchall()