summaryrefslogtreecommitdiffstats
path: root/abs/core/yasm
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-24 02:54:10 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-24 02:54:10 (GMT)
commitf9182240c853e3449a959441b074ce90d58d9ab4 (patch)
treeadb4fd64a69845713412f254fe75fbd3a65eb576 /abs/core/yasm
parent4672d53ca9bf88bbf1e11e611392effebacdbfa8 (diff)
downloadlinhes_pkgbuild-f9182240c853e3449a959441b074ce90d58d9ab4.zip
linhes_pkgbuild-f9182240c853e3449a959441b074ce90d58d9ab4.tar.gz
linhes_pkgbuild-f9182240c853e3449a959441b074ce90d58d9ab4.tar.bz2
yasm: upgrade
Diffstat (limited to 'abs/core/yasm')
-rw-r--r--abs/core/yasm/PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/abs/core/yasm/PKGBUILD b/abs/core/yasm/PKGBUILD
index fcbd935..7741fbf 100644
--- a/abs/core/yasm/PKGBUILD
+++ b/abs/core/yasm/PKGBUILD
@@ -1,23 +1,28 @@
-# $Id: PKGBUILD 18746 2008-11-08 22:44:05Z aaron $
-# Maintainer: Aaron Griffin <aaron@archlinux.org>
+# $Id: PKGBUILD 98381 2010-11-08 19:21:18Z andrea $
+# Maintainer:
+# Contributor: Aaron Griffin <aaron@archlinux.org>
# Contributor: Vinay S Shastry <vinayshastry@gmail.com>
pkgname=yasm
-pkgver=0.7.2
+pkgver=1.1.0
pkgrel=1
pkgdesc="A rewrite of NASM to allow for multiple syntax supported (NASM, TASM, GAS, etc.)"
arch=('i686' 'x86_64')
license=('custom')
url="http://www.tortall.net/projects/yasm/"
depends=('glibc')
-source=(http://www.tortall.net/projects/yasm/releases/$pkgname-$pkgver.tar.gz)
+source=(http://www.tortall.net/projects/yasm/releases/${pkgname}-${pkgver}.tar.gz)
options=('!libtool')
-md5sums=('cc9360593de5625dca286f0bfcb27dd5')
+md5sums=('8392e5f2235c2c2a981e1a633f2698cb')
build() {
- cd $startdir/src/$pkgname-$pkgver
+ cd ${srcdir}/${pkgname}-${pkgver}
./configure --prefix=/usr
make || return 1
- make DESTDIR=$startdir/pkg install
- install -Dm644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/COPYING
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+ install -Dm644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}