summaryrefslogtreecommitdiffstats
path: root/abs/core/zd1211-firmware
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/zd1211-firmware
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/zd1211-firmware')
-rw-r--r--abs/core/zd1211-firmware/PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/abs/core/zd1211-firmware/PKGBUILD b/abs/core/zd1211-firmware/PKGBUILD
index 179a8ca..a583f8e 100644
--- a/abs/core/zd1211-firmware/PKGBUILD
+++ b/abs/core/zd1211-firmware/PKGBUILD
@@ -1,22 +1,23 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 59439 2009-11-23 22:50:09Z giovanni $
# Maintainer: Dan McGee <dan@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
pkgname=zd1211-firmware
pkgver=1.4
-pkgrel=2
+pkgrel=3
pkgdesc="Firmware for the in-kernel26 zd1211rw wireless driver"
-arch=(i686 x86_64)
+arch=('any')
url="http://zd1211.wiki.sourceforge.net/"
-# firmware files are here:
-# http://sourceforge.net/project/showfiles.php?group_id=129083
license=('GPL')
provides=('zd1211')
-source=(http://downloads.sourceforge.net/zd1211/zd1211-firmware-$pkgver.tar.bz2)
+source=(http://downloads.sourceforge.net/zd1211/${pkgname}-${pkgver}.tar.bz2)
md5sums=('19f28781d76569af8551c9d11294c870')
build() {
- cd $startdir/src/zd1211-firmware
- mkdir -p $startdir/pkg/lib/firmware/zd1211/
- # just unpack the files to the firmware directory
- install -m644 * $startdir/pkg/lib/firmware/zd1211/ || return 1
+ cd "${srcdir}/${pkgname}"
+ # Install firmware
+ for i in zd1211* WS11U*
+ do
+ install -D -m 644 $i "${pkgdir}/lib/firmware/zd1211/$i" || return 1
+ done
}