summaryrefslogtreecommitdiffstats
path: root/abs/core/zlib
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:09:31 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:09:31 (GMT)
commit9afea266704f35e14f46bf1958327266208bd176 (patch)
treec4583af2c3ff0acf8ea8b035499a6c8a45aef0b7 /abs/core/zlib
parent49b3ac7600e4443e95569b95d723cd9ab38c64e8 (diff)
downloadlinhes_pkgbuild-9afea266704f35e14f46bf1958327266208bd176.zip
linhes_pkgbuild-9afea266704f35e14f46bf1958327266208bd176.tar.gz
linhes_pkgbuild-9afea266704f35e14f46bf1958327266208bd176.tar.bz2
zlib 1.2.7
Diffstat (limited to 'abs/core/zlib')
-rw-r--r--abs/core/zlib/PKGBUILD25
-rw-r--r--abs/core/zlib/zlib-1.2.5-lfs-decls.patch13
2 files changed, 12 insertions, 26 deletions
diff --git a/abs/core/zlib/PKGBUILD b/abs/core/zlib/PKGBUILD
index f320d37..e9a9866 100644
--- a/abs/core/zlib/PKGBUILD
+++ b/abs/core/zlib/PKGBUILD
@@ -1,33 +1,32 @@
-# $Id: PKGBUILD 80715 2010-05-20 20:58:22Z pierre $
+# $Id: PKGBUILD 158552 2012-05-04 22:14:53Z pierre $
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
pkgname=zlib
-pkgver=1.2.5
-pkgrel=2
+pkgver=1.2.7
+pkgrel=1
pkgdesc='Compression library implementing the deflate compression method found in gzip and PKZIP'
arch=('i686' 'x86_64')
license=('custom')
url="http://www.zlib.net/"
depends=('glibc')
-options=('!makeflags')
-source=("http://zlib.net/zlib-${pkgver}.tar.gz"
- 'zlib-1.2.5-lfs-decls.patch')
-md5sums=('c735eab2d659a96e5a594c9e8541ad63'
- '4cb279ea3beab621f3526bf7b7ab99e5')
+source=("http://zlib.net/current/zlib-${pkgver}.tar.gz")
+md5sums=('60df6a37c56e7c1366cca812414f7b85')
build() {
cd ${srcdir}/zlib-$pkgver
- # see http://bugs.archlinux.org/task/19280
- patch -p1 -i ${srcdir}/zlib-1.2.5-lfs-decls.patch || return 1
- export CFLAGS="${CFLAGS/-O2/-O3} -DUNALIGNED_OK"
./configure --prefix=/usr
- make || return 1
+ make
grep -A 24 '^ Copyright' zlib.h > LICENSE
}
+check() {
+ cd ${srcdir}/zlib-$pkgver
+ make test
+}
+
package() {
cd ${srcdir}/zlib-$pkgver
- make install DESTDIR=${pkgdir} || return 1
+ make install DESTDIR=${pkgdir}
install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/zlib/LICENSE
}
diff --git a/abs/core/zlib/zlib-1.2.5-lfs-decls.patch b/abs/core/zlib/zlib-1.2.5-lfs-decls.patch
deleted file mode 100644
index 36e26af..0000000
--- a/abs/core/zlib/zlib-1.2.5-lfs-decls.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: zlib-1.2.5/zlib.h
-===================================================================
---- zlib-1.2.5.orig/zlib.h
-+++ zlib-1.2.5/zlib.h
-@@ -1578,7 +1578,7 @@ ZEXTERN int ZEXPORT inflateBackInit_ OF(
- # define gzoffset gzoffset64
- # define adler32_combine adler32_combine64
- # define crc32_combine crc32_combine64
--# ifdef _LARGEFILE64_SOURCE
-+# ifndef _LARGEFILE64_SOURCE
- ZEXTERN gzFile ZEXPORT gzopen64 OF((const char *, const char *));
- ZEXTERN z_off_t ZEXPORT gzseek64 OF((gzFile, z_off_t, int));
- ZEXTERN z_off_t ZEXPORT gztell64 OF((gzFile));