summaryrefslogtreecommitdiffstats
path: root/abs/core/zlib
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core/zlib
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core/zlib')
-rw-r--r--abs/core/zlib/PKGBUILD36
-rw-r--r--abs/core/zlib/zlib-1.2.5-lfs-decls.patch13
2 files changed, 35 insertions, 14 deletions
diff --git a/abs/core/zlib/PKGBUILD b/abs/core/zlib/PKGBUILD
index 70d4b2d..f320d37 100644
--- a/abs/core/zlib/PKGBUILD
+++ b/abs/core/zlib/PKGBUILD
@@ -1,25 +1,33 @@
-# $Id: PKGBUILD 4237 2008-07-05 19:17:35Z pierre $
+# $Id: PKGBUILD 80715 2010-05-20 20:58:22Z pierre $
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
pkgname=zlib
-pkgver=1.2.3.3
-pkgrel=14
-pkgdesc="A compression/decompression Library"
+pkgver=1.2.5
+pkgrel=2
+pkgdesc='Compression library implementing the deflate compression method found in gzip and PKZIP'
arch=('i686' 'x86_64')
-license=('custom:zlib')
-url="http://www.gzip.org/zlib"
-groups=('base')
+license=('custom')
+url="http://www.zlib.net/"
depends=('glibc')
-source=("ftp://ftp.archlinux.org/other/zlib/zlib-${pkgver}.tar.gz")
-md5sums=('c444cf020e5f0e3323b11f5a2d8af8d3')
+options=('!makeflags')
+source=("http://zlib.net/zlib-${pkgver}.tar.gz"
+ 'zlib-1.2.5-lfs-decls.patch')
+md5sums=('c735eab2d659a96e5a594c9e8541ad63'
+ '4cb279ea3beab621f3526bf7b7ab99e5')
build() {
cd ${srcdir}/zlib-$pkgver
-
- ./configure --prefix=/usr --shared
+ # see http://bugs.archlinux.org/task/19280
+ patch -p1 -i ${srcdir}/zlib-1.2.5-lfs-decls.patch || return 1
+ export CFLAGS="${CFLAGS/-O2/-O3} -DUNALIGNED_OK"
+ ./configure --prefix=/usr
make || return 1
- make install prefix=${pkgdir}/usr || return 1
- grep -A 24 '^ Copyright' zlib.h > license.txt
- install -D license.txt ${pkgdir}/usr/share/licenses/zlib/license.txt
+ grep -A 24 '^ Copyright' zlib.h > LICENSE
+}
+
+package() {
+ cd ${srcdir}/zlib-$pkgver
+ make install DESTDIR=${pkgdir} || return 1
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/zlib/LICENSE
}
diff --git a/abs/core/zlib/zlib-1.2.5-lfs-decls.patch b/abs/core/zlib/zlib-1.2.5-lfs-decls.patch
new file mode 100644
index 0000000..36e26af
--- /dev/null
+++ b/abs/core/zlib/zlib-1.2.5-lfs-decls.patch
@@ -0,0 +1,13 @@
+Index: zlib-1.2.5/zlib.h
+===================================================================
+--- zlib-1.2.5.orig/zlib.h
++++ zlib-1.2.5/zlib.h
+@@ -1578,7 +1578,7 @@ ZEXTERN int ZEXPORT inflateBackInit_ OF(
+ # define gzoffset gzoffset64
+ # define adler32_combine adler32_combine64
+ # define crc32_combine crc32_combine64
+-# ifdef _LARGEFILE64_SOURCE
++# ifndef _LARGEFILE64_SOURCE
+ ZEXTERN gzFile ZEXPORT gzopen64 OF((const char *, const char *));
+ ZEXTERN z_off_t ZEXPORT gzseek64 OF((gzFile, z_off_t, int));
+ ZEXTERN z_off_t ZEXPORT gztell64 OF((gzFile));