summaryrefslogtreecommitdiffstats
path: root/abs/core/zoneminder
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-03 17:59:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-03 17:59:45 (GMT)
commit4be23d4482a7aec8820be8fa373bc8de5a0272b5 (patch)
tree453c78e84078cb6cfa3da1daa4906050aedb68a2 /abs/core/zoneminder
parent306d9e4bfa29faaa561d54df14a0533d034f9773 (diff)
downloadlinhes_pkgbuild-4be23d4482a7aec8820be8fa373bc8de5a0272b5.zip
linhes_pkgbuild-4be23d4482a7aec8820be8fa373bc8de5a0272b5.tar.gz
linhes_pkgbuild-4be23d4482a7aec8820be8fa373bc8de5a0272b5.tar.bz2
mythweb, mythexport,zoneminder, web_auth: convert packages to use gen_light_include.conf
refs #864 closes #864
Diffstat (limited to 'abs/core/zoneminder')
-rw-r--r--abs/core/zoneminder/PKGBUILD7
-rw-r--r--abs/core/zoneminder/__changelog2
-rw-r--r--abs/core/zoneminder/gen_light_zm.conf1
-rw-r--r--abs/core/zoneminder/zm_gen_light.conf1
-rw-r--r--abs/core/zoneminder/zoneminder.install28
5 files changed, 16 insertions, 23 deletions
diff --git a/abs/core/zoneminder/PKGBUILD b/abs/core/zoneminder/PKGBUILD
index 4dc5c63..9ea64a5 100644
--- a/abs/core/zoneminder/PKGBUILD
+++ b/abs/core/zoneminder/PKGBUILD
@@ -63,6 +63,7 @@ source=(
patch-ffmpeg-0.11.patch
zm.include
zm.sysctrl.conf
+ zm_gen_light.conf
)
@@ -193,9 +194,12 @@ package() {
ln -s /usr/share/cambozola/cambozola.jar $pkgdir/data/srv/httpd/$pkgname
mkdir -p $pkgdir/etc/lighttpd
+
install -D -m 644 $srcdir/zm.include $pkgdir/etc/lighttpd/
#sysctrl conf
install -o root -g root -D -m 0755 $srcdir/zm.sysctrl.conf $startdir/pkg/etc/sysctl.d/zm.conf
+ #gen_light_conf
+ install -D -m0744 ${srcdir}/zm_gen_light.conf ${pkgdir}/etc/gen_light_conf.d/zoneminder.conf
install -D -m 644 $srcdir/httpd-$pkgname.conf $pkgdir/etc/httpd/conf/extra
install -D -m 644 $srcdir/$pkgname $pkgdir/etc/rc.d
@@ -210,4 +214,5 @@ md5sums=('eaefa14befd482154970541252aa1a39'
'ca3fe00739707b9f92eaaa9034d4da2b'
'81c8be870260142e2633eedf73c72040'
'9d93f9b7b0a1384df533efde19ed3021'
- '9a60f8b9af050220e1cb86da438952b3')
+ '9a60f8b9af050220e1cb86da438952b3'
+ '81cb12b36616a299ec808ac70a809ec2')
diff --git a/abs/core/zoneminder/__changelog b/abs/core/zoneminder/__changelog
index e7181bc..5ebce4d 100644
--- a/abs/core/zoneminder/__changelog
+++ b/abs/core/zoneminder/__changelog
@@ -3,6 +3,7 @@ Change cgidir and webdir:
--
added zm.include for lighttpd
added zm.sysctrl.conf to set the shared mem
+added zm_gen_light.conf
--
run file
@@ -13,3 +14,4 @@ Removed modifications of php.ini
Added remove/add of zm.include in post install/remove
added install_db
add http to video group
+gen_light_conf.py
diff --git a/abs/core/zoneminder/gen_light_zm.conf b/abs/core/zoneminder/gen_light_zm.conf
new file mode 100644
index 0000000..3716bb0
--- /dev/null
+++ b/abs/core/zoneminder/gen_light_zm.conf
@@ -0,0 +1 @@
+include "/etc/lighttpd/zm.include"
diff --git a/abs/core/zoneminder/zm_gen_light.conf b/abs/core/zoneminder/zm_gen_light.conf
new file mode 100644
index 0000000..3716bb0
--- /dev/null
+++ b/abs/core/zoneminder/zm_gen_light.conf
@@ -0,0 +1 @@
+include "/etc/lighttpd/zm.include"
diff --git a/abs/core/zoneminder/zoneminder.install b/abs/core/zoneminder/zoneminder.install
index c2e1cb8..bf5cd99 100644
--- a/abs/core/zoneminder/zoneminder.install
+++ b/abs/core/zoneminder/zoneminder.install
@@ -60,23 +60,17 @@ post_install() {
fi
#---
usermod -G video http
- COUNT=`grep -c "zm.include" /etc/lighttpd/conf.include`
- if [ $COUNT == 0 ]
- then
- echo "==> Adding zm.include to conf.include"
- echo "include \"/etc/lighttpd/zm.include\"" >> /etc/lighttpd/conf.include
- fi
- echo
- echo "==> Forcing a re-read of lighttpd's configuration file."
- echo ""
- /sbin/sv hup /service/lighttpd
-
install_db
+ gen_light_include.py
+ /sbin/sv hup /service/lighttpd
#---
}
+
post_upgrade() {
post_install
/usr/bin/zmupdate.pl -f >/dev/null
+ gen_light_include.py
+ /sbin/sv hup /service/lighttpd
}
post_remove() {
@@ -85,17 +79,7 @@ post_remove() {
fi
#--
- COUNT=`grep -c "zm.include" /etc/lighttpd/conf.include`
- if [ $COUNT -gt 0 ]
- then
- echo "==> Removing zm.include from conf.include"
- sed -i 's#include \"/etc/lighttpd/zm.include\"##' -i /etc/lighttpd/conf.include
- fi
-
-
- echo
- echo "==> Forcing a re-read of lighttpd's configuration file."
- echo ""
+ gen_light_include.py
/sbin/sv hup /service/lighttpd
#--