summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-30 21:21:23 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-30 21:21:23 (GMT)
commit2c1d7e9e6b841addd6e3060fec9434e10cb742c3 (patch)
tree7968e67f53b4e315796aea648010d7b2f34f32b4 /abs/core
parent61fbc34a07d7620a6bb233a2a90f3c3119eea3ac (diff)
downloadlinhes_pkgbuild-2c1d7e9e6b841addd6e3060fec9434e10cb742c3.zip
linhes_pkgbuild-2c1d7e9e6b841addd6e3060fec9434e10cb742c3.tar.gz
linhes_pkgbuild-2c1d7e9e6b841addd6e3060fec9434e10cb742c3.tar.bz2
python-six: initial inclusion. dep of pyopenssl
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/python_modules/python-six/PKGBUILD41
-rw-r--r--abs/core/python_modules/python-six/__changelog1
2 files changed, 42 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-six/PKGBUILD b/abs/core/python_modules/python-six/PKGBUILD
new file mode 100644
index 0000000..0e8986b
--- /dev/null
+++ b/abs/core/python_modules/python-six/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributer: Allan McRae <allan@archlinux.org>
+# Maintainer: Jelle van der Waa <jelle@vdwaa.nl>
+
+pkgbase=python-six
+pkgname=('python2-six')
+pkgver=1.6.1
+pkgrel=2
+pkgdesc="Python 2 and 3 compatibility utilities"
+arch=('any')
+url="http://pypi.python.org/pypi/six/"
+license=('MIT')
+makedepends=('python2')
+source=(http://pypi.python.org/packages/source/s/six/six-$pkgver.tar.gz)
+md5sums=('07d606ac08595d795bf926cc9985674f')
+
+build() {
+ cd $srcdir
+ cp -r six-$pkgver six2-$pkgver
+}
+
+check() {
+# cd $srcdir/six-$pkgver
+# python3 setup.py check
+
+ cd $srcdir/six2-$pkgver
+ python2 setup.py check
+}
+
+#package_python-six() {
+# depends=('python')
+# cd $srcdir/six-$pkgver
+# python3 setup.py install --root "${pkgdir}" --optimize=1
+# install -Dm644 "${srcdir}/six-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+#}
+
+package_python2-six() {
+ depends=('python2')
+ cd $srcdir/six2-$pkgver
+ python2 setup.py install --root "${pkgdir}" --optimize=1
+ install -Dm644 "${srcdir}/six-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/abs/core/python_modules/python-six/__changelog b/abs/core/python_modules/python-six/__changelog
new file mode 100644
index 0000000..488d3cf
--- /dev/null
+++ b/abs/core/python_modules/python-six/__changelog
@@ -0,0 +1 @@
+PKGBUILD: rm py 3 stuff