summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-07 16:55:39 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-07 16:55:39 (GMT)
commit4a914dde9929428b8b05ffe6e176ef177563f329 (patch)
tree2be879f671ebb536f307699b8d7606fea45289c7 /abs/core
parent18a16759c1ed3a84519ecb05e3601290bd91c0f1 (diff)
downloadlinhes_pkgbuild-4a914dde9929428b8b05ffe6e176ef177563f329.zip
linhes_pkgbuild-4a914dde9929428b8b05ffe6e176ef177563f329.tar.gz
linhes_pkgbuild-4a914dde9929428b8b05ffe6e176ef177563f329.tar.bz2
runit-scripts: handle stopped plymouth a bit better. refs #891
Diffstat (limited to 'abs/core')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/312
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/frontend/finish2
3 files changed, 14 insertions, 2 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index ea41c96..64eeff7 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=8.1
-pkgrel=12
+pkgrel=13
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/3 b/abs/core/runit-scripts/runitscripts/3
index 91617e5..062f2c6 100755
--- a/abs/core/runit-scripts/runitscripts/3
+++ b/abs/core/runit-scripts/runitscripts/3
@@ -6,6 +6,16 @@ clear
. /etc/rc.conf
. /etc/rc.d/functions
+#continue plymouthd that was stopped in /etc/X11/Sessions/Linhes
+cp -f /run/plymouth.pid /tmp/plymouthd
+pidfile=/run/plymouth.pid
+if [ -e "$pidfile" ]; then
+ plypid=`cat "$pidfile"`
+ if [ -n "$plypid" ]; then
+ kill -s CONT "$plypid"
+ fi
+fi
+
stat_busy "Waiting for services to stop..."
sv -w196 force-stop /service/*
sv exit /service/*
@@ -32,4 +42,6 @@ ethtool -s eth0 wol g 2>/dev/null
ethtool -s eth1 wol g 2>/dev/null
ethtool -s eth2 wol g 2>/dev/null
+plymouth quit --retain-splash
+
/etc/rc.shutdown
diff --git a/abs/core/runit-scripts/runitscripts/services/frontend/finish b/abs/core/runit-scripts/runitscripts/services/frontend/finish
index 702b543..d96bcf0 100755
--- a/abs/core/runit-scripts/runitscripts/services/frontend/finish
+++ b/abs/core/runit-scripts/runitscripts/services/frontend/finish
@@ -9,7 +9,7 @@ function cleanup(){
printhl " Cleaning up /etc/sv/frontend/.runtime/"
}
-#unpause plymouthd that was paused in /etc/X11/Sessions/Linhes
+#continue plymouthd that was stopped in /etc/X11/Sessions/Linhes
pidfile=/run/plymouth.pid
if [ -e "$pidfile" ]; then
plypid=`cat "$pidfile"`