summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-29 23:17:15 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-29 23:17:15 (GMT)
commit593cf54c6c5cd88164bfe85441a2a993a09a89e3 (patch)
tree481ce50e949b5822a90ab675084fd2ed33e61ced /abs/core
parent88c34a9f842d5f7424c8fc9ab204d4cbc62e01d7 (diff)
downloadlinhes_pkgbuild-593cf54c6c5cd88164bfe85441a2a993a09a89e3.zip
linhes_pkgbuild-593cf54c6c5cd88164bfe85441a2a993a09a89e3.tar.gz
linhes_pkgbuild-593cf54c6c5cd88164bfe85441a2a993a09a89e3.tar.bz2
python-pygments:initial inclusion
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/python_modules/python-pygments/PKGBUILD56
-rw-r--r--abs/core/python_modules/python-pygments/__changelog1
-rw-r--r--abs/core/python_modules/python-pygments/python-pygments.install7
3 files changed, 64 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-pygments/PKGBUILD b/abs/core/python_modules/python-pygments/PKGBUILD
new file mode 100644
index 0000000..fa1e572
--- /dev/null
+++ b/abs/core/python_modules/python-pygments/PKGBUILD
@@ -0,0 +1,56 @@
+# $Id$
+# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Timm Preetz <timm@preetz.us>
+
+pkgname=('python2-pygments')
+pkgver=1.6
+pkgrel=3
+pkgdesc="Python syntax highlighter"
+arch=('any')
+url="http://pygments.org/"
+license=('BSD')
+makedepends=('python2-setuptools')
+options=('!emptydirs')
+source=(http://pypi.python.org/packages/source/P/Pygments/Pygments-$pkgver.tar.gz)
+sha256sums=('799ed4caf77516e54440806d8d9cd82a7607dfdf4e4fb643815171a4b5c921c0')
+
+build() {
+ cd "$srcdir"
+
+ rm -rf python{2,3}-build
+ for builddir in python2-build; do
+ cp -r Pygments-$pkgver $builddir
+ pushd $builddir
+ ${builddir%-build} setup.py build
+ popd
+ done
+}
+
+#package_python-pygments() {
+# depends=('python-setuptools')
+# install=python-pygments.install
+
+# cd "$srcdir/python3-build"
+
+# python3 setup.py install --root="$pkgdir" -O1
+
+ # pygmentize has been moved to the python2-pygments package
+# rm "$pkgdir/usr/bin/pygmentize"
+
+# install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+#}
+
+package_python2-pygments() {
+ depends=('python2-setuptools')
+
+ cd "$srcdir/python2-build"
+
+ python2 setup.py install --root="$pkgdir" -O1
+
+ install -Dm644 external/pygments.bashcomp \
+ "$pkgdir/usr/share/bash-completion/completions/pygmentize"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core/python_modules/python-pygments/__changelog b/abs/core/python_modules/python-pygments/__changelog
new file mode 100644
index 0000000..488d3cf
--- /dev/null
+++ b/abs/core/python_modules/python-pygments/__changelog
@@ -0,0 +1 @@
+PKGBUILD: rm py 3 stuff
diff --git a/abs/core/python_modules/python-pygments/python-pygments.install b/abs/core/python_modules/python-pygments/python-pygments.install
new file mode 100644
index 0000000..eab5811
--- /dev/null
+++ b/abs/core/python_modules/python-pygments/python-pygments.install
@@ -0,0 +1,7 @@
+post_upgrade() {
+ if (($(vercmp $2 1.4-5) < 0)); then
+ echo '/usr/bin/pygmentize has been moved to the python2-pygments package'
+ fi
+}
+
+# vim:set ts=2 sw=2 et: