summaryrefslogtreecommitdiffstats
path: root/abs/core
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-10 23:13:08 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-10 23:13:08 (GMT)
commit88c1b84963b442a1d39d8193ce72d17e297f006f (patch)
tree707179173751bff29a018a403dbed4923db47985 /abs/core
parentbf347ccc26e6d65950cea72b1990dbf8c9fe98c1 (diff)
parent7921961814dea89fbf846d06095afd207c8dfd23 (diff)
downloadlinhes_pkgbuild-88c1b84963b442a1d39d8193ce72d17e297f006f.zip
linhes_pkgbuild-88c1b84963b442a1d39d8193ce72d17e297f006f.tar.gz
linhes_pkgbuild-88c1b84963b442a1d39d8193ce72d17e297f006f.tar.bz2
Merge branch 'testing' of ssh://linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core')
-rw-r--r--abs/core/ffmpeg-svn/PKGBUILD82
-rw-r--r--abs/core/imagemagick/PKGBUILD9
-rw-r--r--abs/core/libtheora/PKGBUILD24
-rw-r--r--abs/core/morethemes/PKGBUILD66
-rw-r--r--abs/core/morethemes/retro-wide_video-ui.xml-filetypes.patch22
-rw-r--r--abs/core/mplayer/PKGBUILD83
-rw-r--r--abs/core/mythplugins/PKGBUILD2
-rw-r--r--abs/core/myththemes/PKGBUILD51
-rwxr-xr-xabs/core/mythtv/stable-0.24/PKGBUILD21
-rw-r--r--abs/core/mythtv/stable-0.24/menu-xml/mainmenu.xml.patch18
-rw-r--r--abs/core/mythtv/stable-0.24/smolt_jump.patch28
-rw-r--r--abs/core/transcode/PKGBUILD87
-rw-r--r--abs/core/transcode/transcode-1.1.5-jpeg-7.patch16
-rw-r--r--abs/core/transcode/transcode-1.1.5-mpa.patch10
-rw-r--r--abs/core/x264/PKGBUILD18
15 files changed, 358 insertions, 179 deletions
diff --git a/abs/core/ffmpeg-svn/PKGBUILD b/abs/core/ffmpeg-svn/PKGBUILD
index 0eafb3f..7195000 100644
--- a/abs/core/ffmpeg-svn/PKGBUILD
+++ b/abs/core/ffmpeg-svn/PKGBUILD
@@ -1,59 +1,71 @@
-# Contributor: raubkopierer <mail[dot]sensenmann[at]googlemail[dot]com>
+# $Id: PKGBUILD 98250 2010-11-05 15:59:39Z ibiru $
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: Paul Mattal <paul@archlinux.org>
pkgname=ffmpeg-svn
-pkgver=19483
-pkgrel=1
+pkgver=25715
+pkgrel=2
pkgdesc="Complete and free Internet live audio and video broadcasting solution for Linux/Unix"
arch=('i686' 'x86_64')
-url="http://ffmpeg.mplayerhq.hu/"
+url="http://ffmpeg.org/"
license=('GPL')
-depends=('lame' 'sdl' 'faad2' 'faac' 'zlib' 'imlib2' 'x264' 'libtheora')
-makedepends=('subversion')
+depends=('bzip2' 'lame' 'sdl' 'libtheora' 'libvorbis' 'faac' 'xvidcore' 'zlib' 'x264' 'libtheora' 'opencore-amr' 'alsa-lib' 'libvdpau' 'libxfixes' 'schroedinger' 'libvpx' 'libva>=1.0.4' 'openjpeg')
+makedepends=('yasm')
+options=('force')
provides=("ffmpeg=`date +%Y%m%d`")
conflicts=('ffmpeg')
-source=()
-md5sums=()
_svntrunk=svn://svn.ffmpeg.org/ffmpeg/trunk
_svnmod=ffmpeg
build() {
- cd "$srcdir"
+ cd "${srcdir}"
- if [ -d $_svnmod/.svn ]; then
- (cd $_svnmod && svn up -r $pkgver)
+ if [ -d ${_svnmod}/.svn ]; then
+ (cd ${_svnmod} && svn up -r ${pkgver})
else
- svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn co ${_svntrunk} --config-dir ./ -r ${pkgver} ${_svnmod}
fi
msg "SVN checkout done or server timeout"
msg "Starting make..."
- rm -rf "$_svnmod-build"
- mkdir "$_svnmod-build"
- cd "$_svnmod-build"
-
- "$srcdir/$_svnmod/configure" \
- --prefix=/usr \
- --enable-gpl \
- --enable-nonfree \
- --enable-libmp3lame \
- --enable-libfaac \
- --enable-libfaad \
- --enable-libx264 \
- --enable-libtheora \
- --enable-postproc \
- --enable-shared \
- --enable-pthreads \
- --enable-x11grab \
- --arch=`uname -m` \
- --enable-libxvid \
- || return 1
+ rm -rf "{$_svnmod}-build"
+ mkdir "${_svnmod}-build"
+ cd "${_svnmod}-build"
+
+ "${srcdir}/${_svnmod}/configure" \
+ --prefix=/usr \
+ --enable-gpl \
+ --enable-libmp3lame \
+ --enable-libvorbis \
+ --enable-libfaac \
+ --enable-libxvid \
+ --enable-libx264 \
+ --enable-libvpx \
+ --enable-libtheora \
+ --enable-postproc \
+ --enable-shared \
+ --enable-pthreads \
+ --enable-x11grab \
+ --enable-libopencore_amrnb \
+ --enable-libopencore_amrwb \
+ --enable-libschroedinger \
+ --enable-libopenjpeg \
+ --enable-version3 \
+ --enable-nonfree \
+ --enable-runtime-cpudetect \
+ --disable-debug # libfaac is nonfree
make || return 1
make doc/ff{mpeg,play,server}.1 || return 1
+}
- make DESTDIR="$pkgdir" install || return 1
- make DESTDIR="$pkgdir" install-man || return 1
-
+package() {
+ cd "${srcdir}/${_svnmod}-build"
+ make DESTDIR="${pkgdir}" install || return 1
+ make DESTDIR="${pkgdir}" install-man || return 1
}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core/imagemagick/PKGBUILD b/abs/core/imagemagick/PKGBUILD
index 2a797c7..bf65b7f 100644
--- a/abs/core/imagemagick/PKGBUILD
+++ b/abs/core/imagemagick/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: DAniel J Griffiths <ghost1227@archlinux.us>
pkgname=imagemagick
-pkgver=6.6.4.3
+pkgver=6.6.5.7
pkgrel=1
pkgdesc="An image viewing/manipulation program"
arch=('i686' 'x86_64')
@@ -21,10 +21,6 @@ options=('!makeflags' '!docs' 'force')
source=(ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz \
libpng_mmx_patch_x86_64.patch
perlmagick.rpath.patch)
-md5sums=('be87050ec143205326f2e9fbbc7da03a' '069980fc2590c02aed86420996259302'\
- 'ff9974decbfe9846f8e347239d87e4eb')
-sha1sums=('9f6c800560998b6a5e96b1a62d2b13140de9d1d7' 'e42f3acbe85b6098af75c5cecc9a254baaa0482c'\
- '23405f80904b1de94ebd7bd6fe2a332471b8c283')
build() {
cd "${srcdir}"/ImageMagick-${pkgver%.*}-${pkgver##*.}
@@ -56,3 +52,6 @@ package() {
find "${pkgdir}" -name '*.bs' -exec rm {} \;
rm -f "${pkgdir}"/usr/lib/*.la
}
+md5sums=('dd8ae557c11472df1a5643c7d1e24c33'
+ '069980fc2590c02aed86420996259302'
+ 'ff9974decbfe9846f8e347239d87e4eb')
diff --git a/abs/core/libtheora/PKGBUILD b/abs/core/libtheora/PKGBUILD
index b0ee1ac..1592aa5 100644
--- a/abs/core/libtheora/PKGBUILD
+++ b/abs/core/libtheora/PKGBUILD
@@ -1,26 +1,28 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 57638 2009-11-01 07:56:06Z eric $
# Maintainer: Tom Killian <tom@archlinux.org>
# Committer: dorphell <dorphell@archlinux.org>
pkgname=libtheora
-pkgver=1.0beta1
+pkgver=1.1.1
pkgrel=1
pkgdesc="An open video codec developed by the Xiph.org"
arch=('i686' 'x86_64')
+url="http://www.xiph.org"
+license=('BSD')
depends=('libogg')
makedepends=('libvorbis')
-url=http://www.xiph.org
-license=('custom')
+options=('!libtool')
source=(http://downloads.xiph.org/releases/theora/libtheora-${pkgver}.tar.bz2)
+md5sums=('292ab65cedd5021d6b7ddd117e07cd8e')
+sha1sums=('8dcaa8e61cd86eb1244467c0b64b9ddac04ae262')
build() {
- cd ${startdir}/src/libtheora-${pkgver}
- ./configure --prefix=/usr --enable-shared
+ cd "${srcdir}/libtheora-${pkgver}"
+ ./configure --prefix=/usr --enable-shared --disable-static || return 1
make || return 1
- make DESTDIR=${startdir}/pkg install
+ make DESTDIR="${pkgdir}" install || return 1
- for file in LICENSE COPYING ; do
- install -D $file $startdir/pkg/usr/share/licenses/libtheora/$file
- done
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
}
-md5sums=('e2ff1996c5a9fadd0df1025aa10bc35e')
+
diff --git a/abs/core/morethemes/PKGBUILD b/abs/core/morethemes/PKGBUILD
new file mode 100644
index 0000000..739689a
--- /dev/null
+++ b/abs/core/morethemes/PKGBUILD
@@ -0,0 +1,66 @@
+pkgname=morethemes
+pkgver=0.24
+pkgrel=2
+pkgdesc="Additional themes for MythTV"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('any')
+depends=('mythtv')
+groups=('mythtv-extras')
+source=(#'ftp://ftp.knoppmyth.net/R6/sources/morethemes-0.23.tar.bz2'
+ 'ftp://miroku.no-ip.com/blue-abstract-wide.2010.09.16.tar.bz2'
+ 'http://elkin.de/mythtv/2010.09.08-blootube-ng.tar.bz2'
+ 'http://elkin.de/mythtv/2010.11.04-Willi.tar.lzma'
+ 'http://elkin.de/mythtv/2010.03.13-bando-blue.tar.bz2'
+ 'http://www.thepetersclan.com/files/TintedGlass-1.18.tbz2'
+ 'http://www.thepetersclan.com/files/Mod-Gray-OSD.tar.bz2'
+ 'http://www.thepetersclan.com/files/Bluebar-Hires-OSD.tar.bz2'
+ 'http://www.thepetersclan.com/files/BlueCurves-OSD.tar.bz2'
+ 'http://www.thepetersclan.com/files/SimplyBlue-OSD.tbz2'
+ 'http://www.thepetersclan.com/files/BlueCurves2-OSD.tbz2'
+ 'http://www.thepetersclan.com/files/BlueCurves-2.1-OSD.tbz2'
+ 'http://www.mythtv.org/themes/LCARS.tar.gz'
+ 'http://www.mythtv.org/themes/TransBlue.tar.gz'
+ 'http://www.westnet.com/~chris/Mythtv/Retro-wide.tar.gz'
+ 'retro-wide_video-ui.xml-filetypes.patch'
+ 'http://capnbry.net/~bmayland/fi/pvr150/SimpleGray-OSD-0.4.tar.bz2'
+ 'http://www.jobs-khakis-chicks.com/MythTV/IsthmusBlue-OSD.tar.gz'
+ 'http://static.castlesblog.com/public/Glass-OSD-V1.3.zip'
+ 'http://static.castlesblog.com/public/Minimal-OSD-V1.1.zip')
+
+build() {
+ cd ${srcdir}
+ mkdir -p ${pkgdir}/usr/share/mythtv/themes
+
+ msg "Copying files..."
+ for d in `ls -d */`
+ do
+ cp -a "${d}" ${pkgdir}/usr/share/mythtv/themes
+ done
+
+ # Housekeeping
+ rm -fr "${pkgdir}/usr/share/mythtv/themes/__MACOSX" || return 1
+ # Little fix
+ cd ${pkgdir}/usr/share/mythtv/themes/Retro-wide || return 1
+ patch -p0 <${srcdir}/retro-wide_video-ui.xml-filetypes.patch || return 1
+}
+
+md5sums=('878605505599a0f49c44f3df9affe10f'
+ '7c2a2b238b7d44e52b7a8a0361d395aa'
+ '2890f3b991db805a88a48eb6c7048f91'
+ 'c6d90fb469bc30a94e32f76c82122dd3'
+ '80d250bf87c8f72ee238a91c854c0a11'
+ 'c973d0779967034f7a5bc0043574d6f9'
+ 'fb32ddd900e54cff62a62a21025b2585'
+ '79247cf87bbee10363bb214325b7f671'
+ '67c501b80afdefeca623261634dafd9c'
+ '7b2f2eca37f2d9598b00bce85a193bae'
+ '9793dc85a486e1ad9d0c0b6684efd245'
+ 'a36bb7b2597a44128401b1aba9106122'
+ '21d6f967631e45b7039b965a63755282'
+ 'bfc56ffe1c872989f7a1cb7ae20aea49'
+ 'e05bb3d77a11f97a1d547b2f5bc1ddf7'
+ '09dd8679b56794f9850a2382b4e1ea62'
+ 'b6c187b233778abacce102fe609d4e09'
+ 'f8d4fd90f1e45512ea5237de59d5090d'
+ '5646e1df6f593f7116cbdec656146266')
diff --git a/abs/core/morethemes/retro-wide_video-ui.xml-filetypes.patch b/abs/core/morethemes/retro-wide_video-ui.xml-filetypes.patch
new file mode 100644
index 0000000..c98487f
--- /dev/null
+++ b/abs/core/morethemes/retro-wide_video-ui.xml-filetypes.patch
@@ -0,0 +1,22 @@
+--- video-ui.xml.orig 2010-07-04 06:21:18.000000000 +0000
++++ video-ui.xml 2010-07-04 06:22:22.000000000 +0000
+@@ -967,14 +967,17 @@
+
+ <button name="done_button" from="basebutton">
+ <position>700,550</position>
++ <value>Done</value>
+ </button>
+
+ <button name="new_button" from="basebutton">
+- <position>600,550</position>
++ <position>400,550</position>
++ <value>New</value>
+ </button>
+
+ <button name="delete_button" from="basebutton">
+- <position>0,550</position>
++ <position>100,550</position>
++ <value>Delete</value>
+ </button>
+ </window>
+
diff --git a/abs/core/mplayer/PKGBUILD b/abs/core/mplayer/PKGBUILD
index 0b670c1..211fb50 100644
--- a/abs/core/mplayer/PKGBUILD
+++ b/abs/core/mplayer/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mplayer
-pkgver=29438
+pkgver=32613
pkgrel=1
pkgdesc="Famous multimedia player, dev. version, without its GUI"
arch=('i686' 'x86_64')
@@ -7,57 +7,72 @@ url="http://www.mplayerhq.hu/"
license=('GPL')
depends=('libxxf86dga' 'libxv' 'libmad' 'giflib' 'cdparanoia' 'gtk2'
'sdl' 'lame' 'libtheora' 'xvidcore' 'zlib' 'libmng' 'libxss'
- 'libgl' 'smbclient' 'aalib' 'x264>=20090108' 'faac' 'lirc-utils'
- 'ttf-dejavu' 'fribidi' 'libmng' 'libxfont' 'libjpeg')
+ 'libgl' 'smbclient' 'aalib' 'x264>=20101109' 'faac' 'lirc-utils'
+ 'ttf-dejavu' 'libmng' 'libxfont' 'libjpeg' 'rtmpdump' 'ladspa'
+ 'mpg123' 'libbluray-git' 'libcdio')
license=('GPL')
makedepends=('libcaca' 'unzip' 'live-media' 'libdca' 'subversion' 'nvidia-utils')
conflicts=('mplayer-nogui-svn')
provides=('mplayer')
-source=(http://knoppmyth.net/repo/source/mplayer-export-snapshot.tar.bz2 http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2)
-md5sums=()
+#source=(http://knoppmyth.net/repo/source/mplayer-export-snapshot.tar.bz2 http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2)
+source=(http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2)
_svnmod="mplayer"
_svntrunk=svn://svn.mplayerhq.hu/mplayer/trunk/
build() {
-
- cd $srcdir
-# if [ -d $_svnmod/.svn ]; then
-# cd $_svnmod
-# svn up -r $pkgver
-# else
-# svn co $_svntrunk --config-dir . -r $pkgver $_svnmod
-# fi
- # msg "SVN checkout done or server timeout"
+ cd ${srcdir}
+ if [ -d "${_svnmod}/.svn" ]; then
+ cd "${_svnmod}"
+ svn up -r ${pkgver}
+ else
+ svn co "${_svntrunk}" --config-dir . -r ${pkgver} "${_svnmod}"
+ fi
+ msg "SVN checkout done or server timeout"
- #cp -r $_svnmod $_svnmod-build
- cp -r mplayer-export-2009-04-03/ $_svnmod-build
- cd $_svnmod-build
+ cp -r "${_svnmod}" "${_svnmod}-build"
+# cp -r mplayer-export-2009-04-03/ "${_svnmod}-build"
+ cd "${_svnmod}-build"
msg "Building the package..."
- CFLAGS="$CFLAGS -fomit-frame-pointer"
+# CFLAGS="$CFLAGS -fomit-frame-pointer"
# Custom CFLAGS break the mplayer build
-# unset CFLAGS
- ./configure --prefix=/usr --enable-gui --disable-arts --enable-x11 \
- --enable-runtime-cpudetection --confdir=/etc/mplayer --disable-nas \
- --enable-tv-v4l1 --enable-tv-v4l2 --enable-largefiles \
- --disable-liblzo --disable-speex --disable-openal \
- --enable-fribidi --disable-libdv --disable-musepack \
- --language=all --disable-dvdnav --disable-esd --disable-mga \
- --disable-libamr_nb --enable-lirc --disable-jack \
- --enable-freetype --enable-vdpau
+ unset CFLAGS LDFLAGS
+ ./configure --prefix=/usr \
+ --enable-runtime-cpudetection \
+ --disable-gui \
+ --disable-arts \
+ --disable-liblzo \
+ --disable-speex \
+ --disable-openal \
+ --disable-fribidi \
+ --disable-libdv \
+ --disable-musepack \
+ --disable-esd \
+ --disable-mga \
+ --enable-xvmc \
+ --language=all \
+ --confdir=/etc/mplayer
+
+ [ "$CARCH" = "i686" ] && sed 's|-march=i486|-march=i686|g' -i config.mak
+
make || return 1
- make DESTDIR=$pkgdir install || return 1
+}
- install -m0644 etc/{codecs.conf,input.conf,example.conf} $pkgdir/etc/mplayer
- install -d $pkgdir/usr/share/mplayer/
- ln -s /usr/share/fonts/TTF/DejaVuSans.ttf $pkgdir/usr/share/mplayer/subfont.ttf
+package() {
+ cd "${srcdir}/${_svnmod}-build"
+ make -j1 DESTDIR=${pkgdir} install
+ install -Dm644 etc/{codecs.conf,input.conf,example.conf} ${pkgdir}/etc/mplayer/
+ install -dm755 ${pkgdir}/usr/share/mplayer/
+ ln -s /usr/share/fonts/TTF/DejaVuSans.ttf ${pkgdir}/usr/share/mplayer/subfont.ttf
rm -rf ${pkgdir}/usr/share/mplayer/font
+ mkdir -p ${pkgdir}/usr/share/mplayer/skins/default
mv ${srcdir}/Blue ${pkgdir}/usr/share/mplayer/skins/default
mkdir -p ${pkgdir}/usr/share/doc/mplayer
- cp ${srcdir}/$_svnmod-build/DOCS/tech/* ${pkgdir}/usr/share/doc/mplayer
- msg "Cleaning build files..."
- rm -rf $srcdir/$_svnmod-build
+ cp -r ${srcdir}/${_svnmod}-build/DOCS/tech/* ${pkgdir}/usr/share/doc/mplayer/
+ msg "Cleaning build files..."
+ rm -rf "${srcdir}/${_svnmod}-build"
}
+md5sums=('e4e2020d11b681aac898103b3ba723c4')
diff --git a/abs/core/mythplugins/PKGBUILD b/abs/core/mythplugins/PKGBUILD
index dbb0627..a6ac056 100644
--- a/abs/core/mythplugins/PKGBUILD
+++ b/abs/core/mythplugins/PKGBUILD
@@ -14,7 +14,7 @@ pkgname=('mythplugins-mytharchive'
'mythplugins-mythweb'
'mythplugins-mythzoneminder')
pkgver=0.24
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.mythtv.org"
license=('GPL')
diff --git a/abs/core/myththemes/PKGBUILD b/abs/core/myththemes/PKGBUILD
new file mode 100644
index 0000000..9c71117
--- /dev/null
+++ b/abs/core/myththemes/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id: PKGBUILD 86938 2010-08-06 21:53:33Z ibiru $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=myththemes
+pkgver=0.24
+pkgrel=2
+pkgdesc="Themes for MythTV"
+arch=('any')
+url="http://www.mythtv.org/"
+license=('GPL')
+depends=("mythtv>=${pkgver}")
+source=(`echo ${patches[@]:0}`)
+
+build() {
+ _svntrunk="http://svn.mythtv.org/svn/branches/release-0-24-fixes"
+ _svnmod="${pkgname}"
+
+ # get clean copy from SVN repo
+ if [ -d "${srcdir}/${pkgname}" ]
+ then
+ cd "${srcdir}/${pkgname}"
+ msg "Clean up from previous build..."
+ make distclean
+ msg "Updating from SVN..."
+ svn up
+ else
+ cd "${srcdir}"
+ msg "Checking Out from SVN..."
+ svn co "${_svntrunk}/${_svnmod}"
+ cd "${srcdir}/${pkgname}"
+ fi
+
+ # apply patches
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patchs[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${startdir}/src/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ cd "${srcdir}/${pkgname}"
+ ./configure --prefix=/usr || return 1
+}
+package() {
+ cd "${srcdir}/${pkgname}"
+ make INSTALL_ROOT="${pkgdir}" install || return 1
+}
diff --git a/abs/core/mythtv/stable-0.24/PKGBUILD b/abs/core/mythtv/stable-0.24/PKGBUILD
index a00c1b6..da98662 100755
--- a/abs/core/mythtv/stable-0.24/PKGBUILD
+++ b/abs/core/mythtv/stable-0.24/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=mythtv
pkgver=0.24
-pkgrel=1
+pkgrel=4
pkgdesc="A Homebrew PVR project"
arch=('i686' 'x86_64')
url="http://www.mythtv.org/"
@@ -23,8 +23,7 @@ groups=('pvr')
#options=(!strip)
#MAKEFLAGS="-j6"
install='mythtv.install'
-patchs=()
-#patchs=('smolt_jump.patch')
+patchs=('smolt_jump.patch')
optdepends=('xmltv: to download tv listings')
#replaces=('mythtv-contrib')
#conflicts=('mythtv-contrib')
@@ -39,11 +38,13 @@ build() {
if [ -d "${srcdir}/${pkgname}" ]
then
cd "${srcdir}/${pkgname}"
- echo "Updating from SVN..."
+ msg "Clean up previous build..."
+ make distclean
+ msg "Updating from SVN..."
svn up
- else
+ else
cd "${srcdir}"
- echo "Checking Out from SVN..."
+ msg "Checking Out from SVN..."
svn co "${_svntrunk}/${_svnmod}"
cd "${srcdir}/${pkgname}"
fi
@@ -61,12 +62,6 @@ build() {
sed -i -e "s/\`(svnversion \$\${SVNTREEDIR} 2>\/dev\/null) || echo Unknown\`/$pkgver/" version.pro
find bindings/python contrib -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
- # clean up from last build
- echo " simple configure to make sure the distclean works"
- ./configure
- make distclean
- echo "our configure"
-
ARCH=${CARCH/_/-}
./configure --prefix=/usr --cpu=${ARCH} \
--disable-audio-jack \
@@ -80,7 +75,6 @@ build() {
--enable-opengl-vsync \
--with-bindings=perl,python --python=python2 || return 1
-# qmake mythtv.pro || return 1
make all || return 1
}
@@ -114,6 +108,7 @@ package() {
}
md5sums=('7ef6de58240e7aad389a0b13d91b1cf6'
'2babd4b8e146a7538d18dcd55695b0be'
+ 'a837de9ccc201994320071e48952b17d'
'f735805a80b0d1180dee01f9df1b7004'
'f407d6af23e74a49540755420f84fa58'
'5469d9921b726db750b991c87d226158')
diff --git a/abs/core/mythtv/stable-0.24/menu-xml/mainmenu.xml.patch b/abs/core/mythtv/stable-0.24/menu-xml/mainmenu.xml.patch
index 2ea90d7..0491803 100644
--- a/abs/core/mythtv/stable-0.24/menu-xml/mainmenu.xml.patch
+++ b/abs/core/mythtv/stable-0.24/menu-xml/mainmenu.xml.patch
@@ -1,5 +1,5 @@
---- themes/defaultmenu/mainmenu.xml.orig 2010-11-06 00:39:35.000000000 +0000
-+++ themes/defaultmenu/mainmenu.xml 2010-11-06 00:41:27.000000000 +0000
+--- themes/defaultmenu/mainmenu.xml.orig 2010-11-08 22:30:08.000000000 +0000
++++ themes/defaultmenu/mainmenu.xml 2010-11-08 22:35:51.000000000 +0000
@@ -2,6 +2,13 @@
<mythmenu name="MAIN">
@@ -14,11 +14,10 @@
<type>MENU_MEDIA_LIBRARY</type>
<text>Media Library</text>
<action>MENU library.xml</action>
-@@ -30,18 +37,4 @@
- <depends>mythmusic mythvideo mytharchive mythburn</depends>
+@@ -31,17 +38,10 @@
</button>
-- <button>
+ <button>
- <type>TV_WATCH_TV</type>
- <text>Watch TV</text>
- <description>Watch live television</description>
@@ -26,10 +25,13 @@
- </button>
-
- <button>
-- <type>MENU_UTILITIES_SETUP</type>
+ <type>MENU_UTILITIES_SETUP</type>
- <text>Utilities / Setup</text>
- <description>Configure MythTV and plugins</description>
- <action>MENU util_menu.xml</action>
-- </button>
--
++ <text>Service Menu</text>
++ <description>Configure your system</description>
++ <action>MENU linhes.xml</action>
+ </button>
+
</mythmenu>
diff --git a/abs/core/mythtv/stable-0.24/smolt_jump.patch b/abs/core/mythtv/stable-0.24/smolt_jump.patch
index 0fc452a..76f884c 100644
--- a/abs/core/mythtv/stable-0.24/smolt_jump.patch
+++ b/abs/core/mythtv/stable-0.24/smolt_jump.patch
@@ -1,30 +1,10 @@
-Index: programs/mythfrontend/networkcontrol.cpp
-===================================================================
---- programs/mythfrontend/networkcontrol.cpp (revision 19291)
-+++ programs/mythfrontend/networkcontrol.cpp (working copy)
-@@ -83,6 +83,7 @@
+--- programs/mythfrontend/networkcontrol.cpp.orig 2010-11-08 23:07:04.000000000 +0000
++++ programs/mythfrontend/networkcontrol.cpp 2010-11-08 23:08:06.000000000 +0000
+@@ -88,6 +88,7 @@
jumpMap["zoneminderliveview"] = "ZoneMinder Live View";
jumpMap["zoneminderevents"] = "ZoneMinder Events";
jumpMap["snapshot"] = "ScreenShot";
+ jumpMap["mythsmolt"] = "MythSmolt";
- // These jump point names match the (lowercased) locations from gContext
jumpMap["channelrecpriority"] = "Channel Recording Priorities";
-@@ -191,7 +192,7 @@
- pthread_create(&command_thread, NULL, CommandThread, this);
-
- gContext->addListener(this);
--
-+
- connect(this, SIGNAL(newConnection()), this, SLOT(newConnection()));
- }
-
-@@ -307,7 +308,7 @@
- cs = new QTextStream(s);
- cs->setCodec("UTF-8");
- }
--
-+
- if (client)
- {
- closedOldConn = true;
+ jumpMap["viewscheduled"] = "Manage Recordings / Fix Conflicts";
diff --git a/abs/core/transcode/PKGBUILD b/abs/core/transcode/PKGBUILD
index 4535bce..574188e 100644
--- a/abs/core/transcode/PKGBUILD
+++ b/abs/core/transcode/PKGBUILD
@@ -1,39 +1,42 @@
-# $Id: PKGBUILD 26150 2009-02-03 03:22:44Z eric $
+# $Id: PKGBUILD 91207 2010-09-24 03:35:03Z eric $
+# Maintainer:
# Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
-# Maintainer: roberto <roberto@archlinux.org>
+# Contributor: roberto <roberto@archlinux.org>
pkgname=transcode
_sripver=0.3-4
-pkgver=1.1.0
-pkgrel=6
-pkgdesc="Transcode is a video/DVD ripper and encoder for the terminal/console."
-arch=(i686 x86_64)
-license=('GPL2')
-depends=('imagemagick>=6.4.8.10' 'lzo2' 'libdv' 'libdvdread' 'ffmpeg>=20081220' 'mjpegtools' \
- 'xvidcore' 'libmpeg2' 'libtheora' 'libxaw' 'x264>=20090108' 'libxml2' \
- 'libxv' 'a52dec')
-makedepends=('nasm')
-install=transcode.install
-url="http://transcoding.org"
-options=(!libtool !makeflags)
-source=(http://fromani.exit1.org/${pkgname}-${pkgver}.tar.bz2 \
- http://downloads.sourceforge.net/sourceforge/subtitleripper/subtitleripper-${_sripver}.tgz)
-md5sums=('5ca205e32b546402a48ea8004a7b3232' 'c0bd49a88f667c68c4430ad25bbed510')
+pkgver=1.1.5
+pkgrel=5
+pkgdesc="A video/DVD ripper and encoder for the terminal/console"
+arch=('i686' 'x86_64')
+url="http://tcforge.berlios.de/"
+license=('GPL')
+depends=('imagemagick=6.6.5.7' 'lzo2' 'libdv' 'libdvdread' 'ffmpeg-svn' 'mjpegtools'
+ 'libmpeg2' 'libtheora' 'libxaw' 'libxml2' 'libxv' 'a52dec' 'alsa-lib')
+makedepends=('nasm' 'pkg-config')
+options=('!libtool' '!makeflags')
+source=(http://download2.berlios.de/tcforge/${pkgname}-${pkgver}.tar.bz2
+ http://downloads.sourceforge.net/sourceforge/subtitleripper/subtitleripper-${_sripver}.tgz
+ transcode-1.1.5-jpeg-7.patch transcode-1.1.5-mpa.patch)
+md5sums=('41ac6b1c0fe30f3aab286e771fc31b9e' 'c0bd49a88f667c68c4430ad25bbed510'\
+ 'af4056b7530a6f147594f676849e7c7b' 'c299cfc6c4be6a5512d1a129f04e5450')
+sha1sums=('48c36e06ca0cd1cdc1a9c6a241e231f896eefd26' 'd93ff3578dd5f722c8f4ef16bc0903eec5781a0d'\
+ '9e380c00a3b31725dc3ec483fa7bf5e3d8a8a977' '6f45d9167c3aa15a83cb29545749f55eb1f1e5a2')
build() {
- cd $startdir/src/$pkgname-$pkgver
- sed -i 's|ffmpeg/avcodec.h|libavcodec/avcodec.h|' import/{import_ffmpeg.c,decode_lavc.c} || return 1
- sed -i 's|ffmpeg/avcodec.h|libavcodec/avcodec.h|' export/{aud_aux.c,export_ffmpeg.c,ffmpeg_cfg.h} || return 1
- sed -i 's|ffmpeg/avcodec.h|libavcodec/avcodec.h|' filter/filter_resample.c || return 1
- autoconf || return 1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p0 < ../transcode-1.1.5-jpeg-7.patch
+ patch -p1 < ../transcode-1.1.5-mpa.patch
# building from here
- ./configure --prefix=/usr --enable-deprecated \
+ ./configure --prefix=/usr \
--enable-sse=no --enable-sse2=no --enable-altivec=no --enable-mmx \
- --enable-avifile=no --enable-lame --enable-ogg --enable-vorbis --enable-theora \
- --enable-libdv --enable-a52-default-decoder --enable-libxml2 --enable-v4l \
+ --enable-lame --enable-ogg --enable-vorbis --enable-theora \
+ --enable-libdv --enable-libxml2 --enable-v4l \
--enable-imagemagick --enable-libjpeg --enable-lzo --enable-mjpegtools \
--enable-sdl --enable-freetype2 --enable-a52 --enable-libpostproc \
+ --enable-xvid --enable-x264 --enable-alsa \
+ --enable-libmpeg2 --enable-libmpeg2convert \
--with-libxml2-prefix=/usr \
--with-mjpegtools-prefix=/usr \
--with-imagemagick-prefix=/usr \
@@ -45,23 +48,29 @@ build() {
--with-libavcodec-prefix=/usr \
--with-libavcodec-includes=/usr/include \
--with-libavcodec-libs=/usr/lib
- make || return 1
- make DESTDIR=$startdir/pkg install
+
+ make
##############################################################################
# this imports the latest subtitleripper sources and replaces the internal
-### rm -rf $startdir/src/$pkgname-$pkgver/contrib/subrip
- mkdir $startdir/src/$pkgname-$pkgver/contrib
- tar xzf ../subtitleripper-$_sripver.tgz -C $startdir/src/$pkgname-$pkgver/contrib
- mv $startdir/src/$pkgname-$pkgver/contrib/subtitleripper \
- $startdir/src/$pkgname-$pkgver/contrib/subrip
+ mkdir contrib
+ mv "${srcdir}/subtitleripper" contrib/subrip
# removes dependency on libppm, make it dependend on netpbm just failed, argh...
- sed -i 's|^\(.*lppm.*\)$|#\1|' contrib/subrip/Makefile
- sed -i 's|^\(.*D_HAVE_LIB_PPM.*\)$|#\1|' contrib/subrip/Makefile
cd contrib/subrip
+ sed -e 's|^\(.*lppm.*\)$|#\1|' \
+ -e 's|^\(.*D_HAVE_LIB_PPM.*\)$|#\1|' \
+ -e 's/DEFINES :=/DEFINES = -DHAVE_GETLINE/' \
+ -i Makefile
make
- install -m 755 pgm2txt $startdir/pkg/usr/bin/
- install -m 755 srttool $startdir/pkg/usr/bin/
- install -m 755 subtitle2pgm $startdir/pkg/usr/bin/
- install -m 755 subtitle2vobsub $startdir/pkg/usr/bin/
- install -m 755 vobsub2pgm $startdir/pkg/usr/bin/
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ cd contrib/subrip
+ install -m 755 pgm2txt "${pkgdir}/usr/bin/"
+ install -m 755 srttool "${pkgdir}/usr/bin/"
+ install -m 755 subtitle2pgm "${pkgdir}/usr/bin/"
+ install -m 755 subtitle2vobsub "${pkgdir}/usr/bin/"
+ install -m 755 vobsub2pgm "${pkgdir}/usr/bin/"
}
diff --git a/abs/core/transcode/transcode-1.1.5-jpeg-7.patch b/abs/core/transcode/transcode-1.1.5-jpeg-7.patch
new file mode 100644
index 0000000..288932a
--- /dev/null
+++ b/abs/core/transcode/transcode-1.1.5-jpeg-7.patch
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/show_bug.cgi?id=294488
+
+Patch by: Salah Coronya
+
+Fix segmentation fault with jpeg-7 and above where dinfo.do_fancy_upsampling isn't set by default to FALSE anymore.
+
+--- export/export_jpg.c
++++ export/export_jpg.c
+@@ -91,6 +91,7 @@
+
+ jpeg_set_quality(&encinfo, quality, TRUE);
+ encinfo.raw_data_in = TRUE;
++ encinfo.do_fancy_downsampling = FALSE;
+ encinfo.in_color_space = JCS_YCbCr;
+
+ encinfo.comp_info[0].h_samp_factor = 2;
diff --git a/abs/core/transcode/transcode-1.1.5-mpa.patch b/abs/core/transcode/transcode-1.1.5-mpa.patch
new file mode 100644
index 0000000..e7fb0fc
--- /dev/null
+++ b/abs/core/transcode/transcode-1.1.5-mpa.patch
@@ -0,0 +1,10 @@
+--- transcode-1.1.5-old/export/aud_aux.c 2010-07-04 12:44:31.867550180 -0500
++++ transcode-1.1.5/export/aud_aux.c 2010-07-04 13:41:01.253292529 -0500
+@@ -347,6 +347,7 @@
+ //-- set parameters (bitrate, channels and sample-rate) --
+ //--------------------------------------------------------
+ memset(&mpa_ctx, 0, sizeof(mpa_ctx)); // default all
++ mpa_ctx.codec_type = CODEC_TYPE_AUDIO;
+ mpa_ctx.bit_rate = vob->mp3bitrate * 1000; // bitrate dest.
+ mpa_ctx.channels = vob->dm_chan; // channels
+ mpa_ctx.sample_rate = vob->a_rate;
diff --git a/abs/core/x264/PKGBUILD b/abs/core/x264/PKGBUILD
index 4f1756b..6b10ec9 100644
--- a/abs/core/x264/PKGBUILD
+++ b/abs/core/x264/PKGBUILD
@@ -3,33 +3,33 @@
# Maintainer: Paul Mattal <paul@archlinux.org>
pkgname=x264
-pkgver=20090416
-pkgrel=1
+pkgver=20101109
+pkgrel=2
pkgdesc="free library for encoding H264/AVC video streams"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://www.videolan.org/developers/x264.html"
license=('GPL')
-depends=('libx11')
+depends=('libx11' 'gpac')
makedepends=('yasm')
-source=(ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-$pkgver-2245.tar.bz2)
-md5sums=('f5730feaa6175539e8227e48e38b7d67')
+source=(ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-${pkgver}-2245.tar.bz2)
build() {
- cd "$srcdir/$pkgname-snapshot-$pkgver-2245" || return 1
+ cd "${srcdir}/${pkgname}-snapshot-${pkgver}-2245" || return 1
./configure \
- --enable-pthread \
--enable-visualize \
--enable-shared \
--enable-pic || return 1
make || return 1
- make DESTDIR="$pkgdir" \
+ make DESTDIR="${pkgdir}" \
bindir=/usr/bin \
libdir=/usr/lib \
includedir=/usr/include \
install || return 1
}
+md5sums=('068cc8f2d03b087e0d90fb2c5df70e13')
+
# vim:set ts=2 sw=2 et: